Pi4 bootet nach Update && Upgrade nicht mehr

  • Hallo zusammen,


    ich habe mir einen neuen Pi4 zugelegt (möchte mal was mit ioBroker testen, ob das eine Alternative zu Fhem ist?). Nach einem Update && Upgrade (was gefühlt 1,5 Tage benötigt hat) auf einer frisch heruntergeladenen SD-Karte kommt folgender Fehlerscreen (siehe Anhang). Aber eines nach dem anderen. Was habe ich getan:

    0. Pi4 startet und läuft mit der Bastel-Raspi SD-Karte von meinem alten Pi3 --> ausgeschaltet und SD-Karte wieder in den alten Pi3 --> passt

    1. Mit Windows10 Buster aktuell (2020-08-20) runtergeladen und auf formatierter SD-Karte(SD Card Formatter) mit Win32DiskImager draufgespielt.

    2. Pi4 startet und ich stelle mit dem Assi alles soweit ein --> passt alles läuft

    3. sudo apt-get update && sudo apt-get upgrade

    4. ca. 30h auf die Eingabeaufforderung gewartet, dabei auch einige Fehlermeldungen bei einigen Paketen gesehen (aber die rauschen da ja relativ schnell durch)

    5. Pi4 neu gebootet

    6. Fehlerbild beim booten

    Macht nichts waren ja noch keine Daten oder produktive Dienste drauf

    7. SD-Karte nochmal mit SD Card Formatter formatiert und mit Win32DiskImager das oben erwähnte Image drauf

    8. Nach dem Booten gleiche Fehlermeldung wie vorher


    Soweit ich den Fehlerscreen interpretiere, ist im Pi4 ein Bit für ein Update gesetzt, welches irgendwelche Daten auf der SD-Karte erwartet, welche nicht vorhanden sind (auf der "alten" nicht, wegen Fehlern beim Download und auf der neuen nicht, weil die ja "jungfräulich" ist).


    Wie bekomme ich den Pi4 wieder in den "Werkszustand"?


    Danke für eure Hilfe

  • Merkwürdigerweise finde ich in der Dokumentation keinen Hinweis auf die Zeile updates: enabled 1

    Mit Windows10 Buster aktuell (2020-08-20) runtergeladen und auf formatierter SD-Karte(SD Card Formatter) mit Win32DiskImager draufgespielt.

    Testweise solltest Du einmal probieren, das Image einfach mit dem Raspberry Pi Imager zu schreiben. Vorheriges Formatieren ist unnötig und verkürzt nur die Lebensdauer der SD Karte. Deine Kombi beinhaltet Fallstricke schon beim Entpacken des Images.

  • Aber eines nach dem anderen. Was habe ich getan:

    0. Pi4 startet und läuft mit der Bastel-Raspi SD-Karte von meinem alten Pi3 --> ausgeschaltet und SD-Karte wieder in den alten Pi3 --> passt

    Ist es so, dass das 1. booten deines PI4 mit einer SD-karte aus deinem PI3, statt gefunden hat?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Bin wieder ein Stück weiter: Habe die Quick-Format-Option beim SC Card Formatter deaktiviert und noch mal von vorne begonnen. Sieht bis jetzt soweit gut aus: Pi4 bootet erst mal wieder. Deinen Weg versuche ichdanach auch mal, weil ich das Gefühl habe der Pi4 oder die SD-Card die ich verwende ist sehr langsam. Eventuell wird es dann flüssiger??

  • weil ich das Gefühl habe der Pi4 oder die SD-Card die ich verwende ist sehr langsam.

    Lass das mit Win32Imager. etcher oder der Pi Imager prüfen auch automagisch, ob das Geschriebene korrekt ist und entpacken vor Allem die Datei richtig.

  • Sieht bis jetzt soweit gut aus: Pi4 bootet erst mal wieder.

    Wie sind jetzt die Ausgaben von:

    Code
    sudo rpi-eeprom-config
    sudo vcgencmd bootloader_version
    sudo rpi-eeprom-update

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Sorry, ich glaub ich muss jetzt erstmal raus - Sonne und Vitamin D tanken. Die scheint bei uns zw. Nov. und Feb. äußerst selten.

  • Also, mein Pi3 mit Jessie, meine ich läuft wesentlich schneller. Ich weiß nun halt nicht, ob es an Buster, oder an irgendeinem Problem mit der Installation liegt? Mit der Jessie-SD-Card vom Pi3 läuft der Pi4 auch wesentlich schneller.

  • .... läuft der Pi4 auch wesentlich schneller.

    Was genau meinst Du mit "schneller laufen"?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • also, Zeiten habe ich nicht gestoppt, aber wenn ich den Explorer aufrufe, dauert das beim Pi3 nicht so lange bis sich etwas aufbaut. Und auch der Bootvorgang dauert - gefühlt - eine Ewigkeit. Aber mal sehen...

  • so, und in der kurzen Zeit, habe ich den Pi4 mit neuer SD-Card, die mit Pi Imager schon vorbereitet war installiert, mit dem Assi alle Einstellungen erledigt und zweimal gebootet. DAS hat vorher VIEL LÄÄÄÄÄNGER gedauert. Teamviewer kommt auch drauf damit ich vom Büro aus den Rest machen kann (Second Screen etc.).


    Fazit: Bereitet die SD-Card mit dem Pi Imager vor. Ich glaube den gab es bei meiner letzten Installation noch nicht?


    DANKE und bleibt gesund und schönen Sonntach noch

  • .... wenn ich den Explorer aufrufe, dauert das beim Pi3 nicht so lange bis sich etwas aufbaut. Und auch der Bootvorgang dauert - gefühlt - eine Ewigkeit. Aber mal sehen...

    Die Zeit für das Booten kannst Du mit:

    Code
    dmesg | tail -n 5

    und/oder mit:

    Code
    systemd-analyze time

    abschätzen. Betr. Browser evtl. die Zeiten für das DNS zeigen lassen. Z. B.:

    Code
    dig loc.gov | grep msec -A1
    Code
    cat /etc/resolv.conf

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden