Teensy 3.2 Probleme...

  • Moin minigl,


    dann, wie Leroy Cemoi scgreibt, Serial.begin(9600) freigeben und dann noch zusätzlich in der Zeile 206 ein Serial.println("loop"); einsetzen.


    Code
    void loop() {
      Serial.println("Loop");
      // Add entropy to random number generator; we use a lot of it.
      random16_add_entropy(random());

    Auszug aus dem Sketch.



    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin minigl,


    in Zeile 202 auch die // wech...


    und was is?


    Wenn immer noch keine Ausgabe, dann mal das:

    Code
    void setup() {
      delay(500); // sanity delay
      Serial.begin(9600);
    
      delay(2000); //2 Sekunden warten
    
      Serial.println("setup start");

    Irgendwie muss gezeigt werden, das das Programm läuft.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin minigl,


    tja, so langsam....


    Das funktionierte auch auf dem Teensy?


    73 de Bernd


    // Ich bin mal ne Stunde wech

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin minigl,


    na, hat sich was ergeben?


    Hast du eigentlich in der Arduino IDE unter "Datei/Voreinstellunugen" bei "ausführliche Ausgabe" die beiden Hacken gesetzt und die "Compilerwarnungen" auf "alle" gestellt?


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin minigl,


    ich wollte auch nur dadurch sicherstellen das man ev vorhandene Warungen übersieht.


    Das Teensy3.2-Board hat ja eine Led. Wird die, bei diesem Programm oder im Standard genutzt?


    73 de Bernd


    //Nachtrag: Hast du das "nackte" Board mal gestartet. Ohne die LED's?

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Moin minigl,


    hast du mal mit dem Takt und der Optimierung gespielt?


    Unter Werkzeuge cpu-speed mal langsamer z.B.; 72 MHz und unter optimize auf fast.


    wie ich schon geschrieben habe, leider ist bei mir kein Teensy vorhanden.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Naja, ich finde den Effekt sehr gelungen und es würde mich natürlich interessieren, warum der Code nicht funktioniert.

    Andere Projekte von Cine-Lights mit einem Arduino funktionieren super. Wenn du an dem Teensy interssiert bist, kannst du mich ja mit 3dmik@web.de erreichen.

  • Moin minigl,


    ich/wir sind keine Dienstleister, die von Euch bezahlt werden.


    Manchmal haben wir auch eigene Projekte oder, einfach nur, Familie. Verständnis?


    Wenn nicht, dann ... OK


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • OK, das war es dann wohl.

    Danke für eure Hilfe.

    Das war absolut nicht perönlich gemeint. Ich habe das nur geschrieben, weil keine Reaktion mehr kam, damit meinte ich NICHT die von dir,

    sondern allgemein. Ich habe doch Verständnis dafür, wenn irgendwann der "Wissenspool" leer ist, man kann ja nicht alles zu jedem Thema wissen.


    Aber natürlich bin ich weiterhin interessiert, mein kleines Problem zu lösen ;)