Raspberry Pi 4 mit Iobroker zerstört SD Karten

  • Guten Tag zusammen,

    Ich bin neu in diesem Forum.

    Ich hätte eine Frage vielleicht kennt ja jemand dieses Problem.


    Ich besitze einen Raspberry Pi 4 mit 4 GB Ram. Auf ihm ist Iobroker installiert. Er macht jeden Tag mit einem Adapter ein Backup auf Dropbox. In ihm war eine SanDisk Mikro SD Karte mit 32GB eingebaut. Diese hat er zerstört. Wo ich sie in den PC gesteckt hat, hat er sie auch nicht erkannt. Nicht im Explorer nicht im Festplattenpartitionsprogramm und der Raspberry Pi hat so getan wie wenn keine SD Karte vorhanden ist. Keine Verbindung über SSH oder HDMI. Auf anderen Betriebssystem wird sie auch nicht erkannt. Die SD Karte war also kaputt. Das ganze hab ich mit einer 64 GB SanDisk auch probiert. Backup eingespielt. Und das gleiche.


    Hat dieses Problem schon mal jemand gehabt?


    Ich würde mich sehr über Antworten freuen

    Dankeschön

  • IObrocker läuft unter Linux!

    Da könnte es sein, das er die SD Card mit einem Linu Format versehen hat.

    Und genau dass kann ein Windows Betriebssytem nicht Lesen und fordert dann zum Formatieren des Datenträgers auf.

    Windows kann ohne externes Tool, keine Linuxformate Lesen.

    Kann aber auch daran liegen, dass die karte vom System nicht ausgeklink wurde, damit sie Entfernen kann.

    Auch kann es sein, dass die karte ein FAKE ist und viel weniger tatsächlicher Kapazität hat, darüber gibt es Berichte im Netz.

    Gerade zu SanDisk 32GB karten.

    LINK


    PS. Ich kaufe meine SD-Karten nur beim Elektronik Fachhändler und nicht bei A..... oder E....

    Manchmal, wenn ich kleine Micro SD mit 8 oder 16GB brauche, auch bei Pollin oder wenn mein Fachhändler ein Angebot hat.

    Da kommen dann 2-4 karten in den Warenkorb.

  • Hallo MovieHoshi und herzlich willkommen im Forum,

    Problem schon mal jemand

    Nein, das ist sehr ungewöhnlich.


    Womit hast Du versucht, die Karte im PC zu lesen?

    Welche (Fehler)meldungen tauchten wo genau auf?

    Mit welchen Betriebssystemen hast Du was genau probiert?

  • Hallo Vielen Dank für die schnellen Antworten. Wenn ich die SD in den PC schiebe kommt keine Fehlermeldung und auch keine Erkennung. Ich hab auch keine Möglichkeit die Karte zu formatieren. Er erkennt sie nicht. Auf Windows taucht sie auch nicht im Festplattenpartitionsprogramm auf. Ich habe keine Möglichkeit gefunden die Karte zu retten. Auch ist nicht nur das Dateisystem sonder die ganze SD Karte. Auch MacOS hab ich auch kein Zugriff auch nicht im (Windows Ähnlichen Festplattenpartitionsprogramm) Festplattendienstprogramm.


    V.G.

  • Meine Primitiverklärung:

    Du hast alle Dateien auf die Dropbox verschoben und nicht nur kopiert, oder es sind nur Metadaten zerstört/gelöscht/unlesbar.


    Servus !


    PS: zerstören kannst Du einen Datenträger eigentlich nur:

    Wenn Du ihn

    - mit einem 80-er Nagel irgendwo antackerst

    - in die Mikrowelle legst und einschaltest

    - schredderst (auch im Mixer möglich)

    - mit einer Spannung > 12 V bestromst, oder anders als Heizelement verwendest

    - [nicht vollständig]


    Bei bestimmungsgemäßer Verwendung kan kein Datenträger zerstört werden.

    RTFM = Read The Factory Manual, oder so

  • Wenn ich die SD in den PC schiebe ...

    Was genau meinst Du? Versuch evtl. mit einem Adapter und einem geeigneten USB-Kartenlesegerät.

    An meinem Laptop gibt es auch einen Kartenslot, den ich nicht mit allen OSs benutzen kann.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ja. Ich weiß es klingt komisch, aber die Karte kann ich dann wirklich nicht mehr ansprechen. Es passiert nicht wenn ich sie an einen PC anschließe.

    Was genau meinst Du?

    Ich habe es an einem Windows PC mit einem passendem Karten Lese Gerät versuch wie auch an einem MacBook mit eingebautem Slot. Nichts funktioniert. Ich hatte diese Probleme nie mit meinem 3b+ da hat immer alles funktioniert. Vielleicht ist es auch einfach ein Hardware Problem.

    PS: zerstören kannst Du einen Datenträger eigentlich nur:

    Es kommt mir auch ein bisschen komisch vor. Vielleicht gibt der Raspi an bestimmten Fällen einfach mal zu viel Spannung oder sowas.


    V.G.

  • Zuviel Spannung gibts nur, wenn der Admin absichtlich etwas übertaktet/konfiguriert.


    Wenn die SD ihren MBR verloren hat, kannst Du unter Linux versuchen mit sfdisk einen neuen - nach Vorlage - direkt zu verpassen, oder, nach löschen aller Partitionen einen neuen DOS-MBR mit einer Partition zu erstellen. Mit parted im Linux musst Du dazu ein neues "Label" erstellen.



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Guten Tag. Entschuldigt, dass ich mich jetzt erst melde.


    Leider hab ich keine Partition mehr. Der PC, MacBook erkennt die SD Karte nicht. Bevor diese zerstört worden ist schon, da hatte ich zwei Partitionen. Jetzt keine Partition. Die SD Karte besitzt keine Partition mehr. Sie wird auch nicht erkannt. Zum Beispiel in einer Kamera zeigt die Kamera an, damit keine SD Karte vorhanden ist.


    V.G.

  • Und warum verpasst Du der SD nicht einen neuen DOS-MBR (MBR= Master Boot Record)

    Alles ganz hübsch, WENN denn ein Device angezeigt würde. Und das veneint der TO doch schon etliche Male. Merkwürdig ist das schon, ja.

  • Natürlich wird das Device im Dateibrowser nicht angezeigt, wenn es keinen gültigen MBR hat.

    Der Kernel sollte aber trotzdem das Einstecken eines Blockdevice erkennen und das unter /dev/sda oder /dev/sdb, oder /dev/sdc etc. zur Erstellung eines neuen MBR z.V. stellen.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Diese hat er zerstört.

    Von was für einem Zeitraum sprechen wir denn? Ich habe bis jetzt erst eine SD-Karte mit einem Pi 'zerstört' und das ist erst nach vielen Jahren Betrieb passiert.


    Ich selbst nutze ioBroker und habe mich auch schon mal damit befasst. Aktuell ist alles noch auf einer großen SD-Karte (64GB, wovon 59GB frei sind), damit die große Anzahl an Zellen gleichmäßig beschrieben wird. Für den endgültigen Einsatz werde ich aber eine externe SSD nehmen und auch von dieser booten.

    Bin mir nicht mehr sicher, aber ich glaube ich habe log2ram (https://github.com/azlux/log2ram) benutzt, um die states.json Datei von ioBroker in den RAM zu speichern und dann alle 12h fest auf die SD-Karte. Bei jeder einzelnen Änderung eines Zustandes wird diese Datei nämlich neu geschrieben und das passiert wirklich durchgehend. Bei einem Pi 4 mit mehr RAM würde ich noch weitere temporäre Dateien (z.B. Logs) nur in den RAM speichern, um die SD-Karte noch weiter zu entlasten.

    Kelvin

  • Ich würde sagen "SD-Karte Entsorgen!"

    Das wird nix mehr.

    Das Einzige was man noch versucehn könnte, vom Händler das Geld wieder zu Bekommen!

    Wobei ich da recht Schwarz sehe,

    Also entsorg die Karte und besorg eine Neue und schreib es unter "Erfahrungen" ab.

    Am Besten eine vom Fachhändler.


    So ähnlich ging es mir letztens mit einem 4 GB USb Stick, Markenwaren vom Fachhändler, der auf einmal nicht mehr erkannt wurde bzw. nicht mehr Schreib und Lesbar war.

    Im Leser hatte er 0kb und zwar in mehrern verschiedenen lesern.

    Letztendlich habe ich ihn entsorgt, da er eh schon älter war und man mit 4GB auch nicht mehr viel anfängt.

    Aber ich weis bis Heute nicht, was ihn gekillt hat.

  • Guten Tag,

    Ich habe jetzt nochmal das Image auf eine 8 GB SD-Karte. Und darauf IoBroker installiert.

    Bis jetzt läuft alles einwandfrei. Ich habe die Befürchtung, dass der Adapter Parser auf dem IoBroker für die Zerstörung verantwortlich war. Hat da jemand Erfahrung? Ich hab diesen Adapter jetzt nicht installiert und es funktioniert alles einwandfrei.

    V.G

  • Ich habe die Befürchtung, dass der Adapter Parser auf dem IoBroker für die

    Nein, ich tippe eher auf Zufall. Eine Karte kannst Du mit frei erhältlichen Mitteln nicht zerstören, maximal „kaputtschreiben“. (außer die von RTFM in #5 genannten - da geh ich jetzt aber mal nicht von aus) Wenn Du den Parser nicht benötigst, warum sollte der permanent laufen?

  • Ich wollte ihn installieren, weil ich Daten von einer Webseite importieren wollte. Das hat auch sehr gut geklappt. Aber ich hatte auch wenige Videos oder Tutorials über den Adapter gefunden. Ab dem Zeitpunkt, wo ich ihn installiert habe, hat sich zum Beispiel der Objekte Tab nicht mehr öffnen lassen nur noch mit Rechtsklick in Neuem Tab und dann ziemlich lange warten. Ich kann mir das auch nicht erklären. Aber die Karte habe ich neu für den Raspberry Pi gekauft und die andere hatte ich in einer Kamera, wo sie ordnungsgemäß lief.

    V.G.