Adafruit_CircuitPython_DHT funktioniert nicht

  • Ist auch egal. Das Abrufen der Temperatur und der Luftfeuchtigkeit funktioniert jetzt jedenfalls.


    Vielen, vielen Dank für eure Hilfe!


    Soll der Thread auf "Erledigt" gestellt werden? Das eigentliche Thema wurde ja nicht gelöst, aber es funktioniert immerhin.

  • Moin Arcturus


    also bei mir geht deine, in Beitrag #1, Anleitung. Habe nur keinen DHT22 angeschlossen. Kann ich aber auch noch machen.

    Du hast irgendwo einen Fehler bei der Installation von CircuitPython gemacht.


    73 de Bernd


    //Edit

    So sieht es bei mir aus:

    Code
    pi@bernd-test-lite:~ $ python dht-test.py 
    DHT sensor not found, check wiring
    DHT sensor not found, check wiring
    DHT sensor not found, check wiring

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Du hast irgendwo einen Fehler bei der Installation von CircuitPython gemacht.

    Das glaube ich auch, allerdings wüsste ich nicht wo. Gut, ich habe am Anfang die veraltete Bibliothek von Github benutzt, dann falsch verkabelt, aber schlussendlich die Anleitung der Adafruit-Website befolgt. Diese funktioniert aber eben nicht :/ beißt sie sich vielleicht mit der veralteten Bibliothek oder einem anderen heruntergeladenen Paket? :/

  • Moin Arcturus,


    das kann ich dir nicht sagen. Ich hatte eine "reine"Installation von PI OS lite.


    73 de Bernd


    //Edit

    Rennt dieses Testscript denn bei dir?

    Ist von der Adafruit-Seite

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Jein. Ausgabe:


    Code
    Hello blinka!
    Traceback (most recent call last):
      File "/home/pi/Python/Alt oder Test/test.py", line 24, in <module>
        pin = digitalio.DigitalInOut(board.D4)
    AttributeError: module 'board' has no attribute 'D4'
  • Code
    AttributeError: module 'board' has no attribute 'D4'

    Der Fehler bleibt aus, wenn man die Anleitung GENAU befolgt. Was Du wirklich gemacht hast, wissen wir nicht. Du kannst natürlich auch mit einem neuen System beginnen.

  • Moin!


    Das ist die Ausgabe:

    Code
    pi@bernd-test-lite:~ $ python blinkatest.py 
    Hello blinka!
    Digital IO ok!
    I2C ok!
    SPI ok!
    done!

    Aber da bei Arcturus immer der Fehler module 'board' has no attribute 'D4' kann er nur bei der Installation einen Fehler gemacht haben. Weil dieser Test kommt nach dieser Installation :

    pi@bernd-test-lite:~ $ pip3 install adafruit-blinka


    Ev. hilft es ja diesen Teil nochmal zu machen..


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Ich habe jetzt folgendes gemacht:


    Code
    sudo pip3 uninstall adafruit-blinka

    (sudo da sonst Fehlermeldung - keine Berechtigung)


    dann

    Code
    pip3 install adafruit-blinka
    sudo pip3 install adafruit-blinka


    dann kommt bei einer Terminaleingabe folgendes:

    Code
    pi@raspberrypi:~ $ sudo python3 /home/pi/Python/sensor.py
    Unable to set line 4 to input

    Ohne sudo passiert dasselbe. Immerhin eine andere Fehlermeldung :P


    Ob im Skript jetzt "import adafruit_blinka" (in Zeile 4 übrigens) drinnen ist oder nicht, spielt keine Rolle; die Fehlermeldung bleibt gleich.



    Jedenfalls Gute Nacht miteinander....ich geh schlafen...

  • Moin Arcturus,


    es ist nun müssig festzustellen wo der Fehler ist.

    Fakt ist sowohl STF als auch ich haben festgestellt, das die Anweisungen von Adafruit funktionieren.


    Am Besten machst du dir eine SD-Karte neu fertig. Wenn alles grundsätzliche eingerichtet ist, dann ein Backup. Balena-Etch kann das nun auch.


    Dann nach der Anleitung vorgehen.


    73 de Bernd


    Schlaf gut!!

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • müssig festzustellen wo der Fehler

    Naja, vielleicht nicht.;)

    sudo da sonst Fehlermeldung - keine Berechtigung

    Bitte lies doch noch einmal nach, was sudo genau für Konsequenzen hat. Der unbedachte Einsatz birgt nicht unerhebliche Fehlerquellen, insbesondere, wenn man Fehlermeldungen so ignoriert wie oben. Und hyle hatte wie so oft den richtigen Riecher bereits in #11. :thumbup:

  • Am Besten machst du dir eine SD-Karte neu fertig. Wenn alles grundsätzliche eingerichtet ist, dann ein Backup. Balena-Etch kann das nun auch.


    Dann nach der Anleitung vorgehen.

    Werde ich mal machen, wenn die Zeit und Lust vorhanden sind ;) momentan ist beides eher knapp.


    Nenne die Datei mal blinkatest.py und nicht sensor.py.


    Dann zeige mal die Ausgaben

    Die Ausgaben: