X10 Medion

  • Da ich leider am verzweifeln bin wie ich die Fernbedienung zum laufen bekommen soll wende ich mich hiermit an euch. Und ich hoffe mir kann geholfen werden kann doch nicht so schwer sein die Fernbedienung zu benutzen. Nach einigen hin und her installieren kann ich es nicht mehr installieren, und auch nicht starten er sagt es ist die neuste Version installier doch /etc/lirc ist nichts ...


    sudo apt-get install lirc lirc-x xmacro


    lirc is already the newest version.
    lirc-x is already the newest version.
    xmacro is already the newest version.


    Was kann ich jetz machen ?

    • Official Post

    Hmm was kannst du machen? Zuerst mal dein Problem beschreiben. Welches OS setzt du ein? Was hast du bis jetzt gemacht? Was soll /etc/lirc sein? Meinst du /etc/lirc/hardware.conf?
    Vielleicht hilft dir das schon weiter.


    Deinstallieren kannst du übrigens mittels

    Code
    apt-get remove --purge lirc

    für den Fall das du es wirklich nochmal sauber installieren willst.

    Der Unterschied zwischen Genie und Wahnsinn definiert sich im Erfolg.

    Edited once, last by dbv ().

  • sudo apt-get install lirc lirc-x liblircclient0 inputlirc, habe gerade dieses hier neuinstalliert. Aber es kommt nicht der Bildschrim wo abgefragt wird welcher Snder verwendet werden soll etc. wie bei dieser Anleitung hier gesgat wird.


    http://wiki.ubuntuusers.de/Lirc


    EDIT:
    Habe hier noch eine etwas besser Anleitung gefunden, bin bei den Schritt angekommen wo die Ausgabe mit irg geprüft werden soll leider wenn ich irg starten will kommt nur "Connecton refused". Ich reboote gerade und hoffe das es dann funktioniert. Aber soweit war ich vorhin auch schon nur das ich bei irw rein gekommen bin aber keine Ausgabe erhalten habe.


    http://linuxundich.de/ubuntu/p…10-unter-ubuntu-mit-lirc/






    Und wie erwartet irw ohne Ausgabe, diese Ausgabe kommt wenn ich Lirc restarten will. Wie kann ich jetzt weiter verfahren ? Taste wird erkannt wenn ich die Config erstelle, füge diese auch in etc/lirc ein. Aber leider wenn ich im irw die Ausgabe überorüfen will kommt leider 0.

  • Ja also mein Empfänger war zur Fernbedienung dazu also USB, und ich habe mir dein Tut mal angesehen aber das geht wohl eher in richtung GPIO oder ? Bekomme jetz Lirc und Inputlirc gestartet. Irw kann ich auch starten mit folgender config für inputlirc


    /erc/default/inputlirc

    Code
    # Options to be passed to inputlirc.
    EVENTS="/dev/input/event*"
    OPTIONS=



    Leider liefert mir Irw keine Ausgabe, meine /etc/lirc/lirc.conf sieht so aus, habe ich per irrecord -H atilibusb ~/lircd.conf angelegt mit einer Taste.


    Habe auch in irg. einen Forum gelesen gehabt das es einen Bug gibt und man die Tasten doppelt belegen muss auch das habe ich ausprobiert


    Wenn ich per /etc/default/inputlirc folgendes angebe, lässt sich irw nicht mehr starten ich dachte so kann ich den input an lirc weiter geben aber fehlanzeige. EVENTS="/dev/input/by-id/usb-X10_Wireless_Technology_Inc_USB_Receiver-event-if00"

    Code
    OPTIONS="-g -d /var/run/lirc/lircd"


    Auch hiermit lässt sich irw nicht mehr starten


    Code
    # Options to be passed to inputlirc.
    EVENTS="/dev/input/event*"
    OPTIONS="-g -d /var/run/lirc/lircd"



    Mein Hauptproblem liegt jetz darin in irw eine Ausgabe zu bewerkstelligen leider weis ich nicht mehr weiter. Und hoffe ich habe soweit alles beantworten. Denn so viel ahnung von allem habe ich auch nicht und bin in den Gebiet ziemlich neu.
    [hr]
    Meine fresse keiner ne idee :/ dreh hier durch :(

  • Hier noch meine Hardware.conf, wenn ich

    Code
    DRIVER="default"


    auf atiusb stelle komme ich nicht in mehr in irw rein, "Connection blabl..." aber wenn ich es auf default lasse geht es nur halt keine Ausgabe.


  • stehe hier vor dem gleichen problem. :wallbash:


    mir irrecord konnte ich eine neue lircd.conf erstellen, aber ich habe kein plan wie ich lirc als treiber laden kann sodass das system die lircd.conf ausliest und eine ausgabe unter irw kommt.


    ich habe folgende module in der blacklist :

    Code
    [code]
    cat /etc/modprobe.d/lirc-blacklist.conf 
    #File automatically generated upon lirc install
    #Because a module had to be blacklisted. Don't
    #Modify by hand, but rather via
    #dpkg-reconfigure lirc
    
    
    blacklist lirc_atiusb
    blacklist ati_remote

    [/code]


    unter ubuntu läuft es damit super und debian beis ich mir da seit 3 Tagen die Zähne aus.