upgrade läuft auf Fehler

  • Liebe Wissende,


    habe das Problem, daß nach einem "sudo apt-get upgrade" die folgende Fehlermeldung ausgegeben wird.

    Bin neu im Forum, bitte um Nachsicht ;)

    Ja, ich habe schon gesucht im Netz gesucht :)


    cat /etc/os-release

    PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"

    NAME="Raspbian GNU/Linux"

    VERSION_ID="10"

    VERSION="10 (buster)"

    VERSION_CODENAME=buster

    ID=raspbian

    ID_LIKE=debian

    HOME_URL="http://www.raspbian.org/"

    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"

    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


    uname -a

    Linux raspberrypi3 5.4.72-v7+ #1356 SMP Thu Oct 22 13:56:54 BST 2020 armv7l GNU/Linux



    Folgende Informationen - Fehler:


    pi@raspberrypi3 ~ $ sudo apt-get upgrade

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Paketaktualisierung (Upgrade) wird berechnet... Fertig

    Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:

    libunistring0

    Verwenden Sie »sudo apt autoremove«, um es zu entfernen.

    Die folgenden Pakete sind zurückgehalten worden:

    alsa-utils apache2 apache2-bin apache2-data apache2-utils apt apt-utils aptitude aptitude-common aspell at bash bind9-host binutils build-essential cmake cmake-data comerr-dev cpp cpp-4.9 cpp-6 curl dash dconf-gsettings-backend

    dconf-service debian-goodies default-mysql-client default-mysql-server dialog dirmngr dpkg e2fslibs e2fsprogs firmware-ralink g++ g++-6 gawk gcc gcc-4.9 gcc-4.9-base gcc-6 gcc-6-base gdb git git-man glib-networking

    glib-networking-common glib-networking-services gnupg gnupg-agent groff-base hardlink i2c-tools icu-devtools info initramfs-tools initramfs-tools-core iptables isc-dhcp-client krb5-multidev libalgorithm-diff-xs-perl libaprutil1

    libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-inst2.0 libapt-pkg-dev libapt-pkg5.0 libarchive13 libasan1 libasan3 libaspell15 libatlas3-base libatomic1 libavcodec-dev libavformat-dev libavutil-dev libb-hooks-op-check-perl

    libbareword-filehandles-perl libblas3 libcaca0 libcc1-0 libchromaprint1 libclass-c3-xs-perl libclass-xsaccessor-perl libclone-perl libcomerr2 libcommon-sense-perl libcups2 libcurl3-gnutls libcurl4-openssl-dev libcwidget3v5

    libdatetime-format-strptime-perl libdatetime-locale-perl libdatetime-perl libdbd-mysql-perl libdbd-sqlite3-perl libdbi-perl libdconf1 libdevel-caller-perl libdevel-lexalias-perl libdevice-serialport-perl libdrm-amdgpu1 libdrm2

    libedit2 libegl1-mesa libenchant1c2a libevent-dev libfcgi-perl libfile-fcntllock-perl libgbm1 libgcc-4.9-dev libgcc-6-dev libgcc1 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgfortran3 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa

    libgnutls-dane0 libgnutls-openssl27 libgnutls28-dev libgnutls30 libgnutlsxx28 libgomp1 libgpg-error-dev libgpg-error0 libgpgme11 libgssapi-krb5-2 libgssrpc4 libhash-merge-perl libhtml-parser-perl libi2c-dev libicu-dev

    libimobiledevice6 libindirect-perl libio-interface-perl libio-socket-ssl-perl libip4tc0 libip6tc0 libiptc0 libjavascriptcoregtk-1.0-0 libjson-xs-perl libk5crypto3 libkadm5clnt-mit11 libkadm5srv-mit11 libkrb5-3 libkrb5-dev

    libkrb5support0 liblapack3 libldap-2.4-2 libldap2-dev libldb1 liblexical-sealrequirehints-perl liblist-moreutils-perl liblocale-gettext-perl libluajit-5.1-common libmoo-perl libmpc3 libmultidimensional-perl libncurses5

    libncurses5-dev libncursesw5 libnet-ssleay-perl libopenal-data libopenal1 libopenmpt0 libpackage-stash-xs-perl libpadwalker-perl libpam-systemd libparams-classify-perl libparams-util-perl libparted2 libpq-dev libpq5 libpython-all-dev

    libpython-dev libpython-stdlib libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libpython3-dev libpython3-stdlib libpython3.5 libpython3.5-dev libpython3.5-minimal libpython3.5-stdlib libreadline7 libruby2.3

    libscalar-list-utils-perl libsmbclient libsocket-perl libsocket6-perl libspecio-perl libsql-abstract-perl libss2 libssh-gcrypt-4 libstdc++-4.9-dev libstdc++-6-dev libstdc++6 libsub-identify-perl libsub-name-perl libswresample-dev

    libsystemd0 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtext-soundex-perl libtiff5 libtinfo-dev libtinfo5 libubsan0 libudev1 libvariable-magic-perl libvdpau-va-gl1 libwbclient0 libwww-perl libxml-parser-perl

    libxml2 libxml2-dev libxtables12 login luajit man-db mesa-va-drivers mesa-vdpau-drivers motion mount nano ncurses-base ncurses-bin ncurses-term nfs-common nodejs ntfs-3g ntp openssh-client openssh-server openssh-sftp-server parted

    perl perl-base php php-bz2 php-cli php-curl php-gd php-mbstring php-mysql php-tcpdf php-xml php-zip pinentry-curses procps psmisc python python-all python-all-dev python-bs4 python-cryptography python-dev python-keyring python-ldb

    python-minimal python-mysqldb python-openssl python-pip python-pip-whl python-requests python-rpi.gpio python-samba python-smbus python-urllib3 python2.7 python2.7-dev python2.7-minimal python3 python3-cffi-backend python3-crypto

    python3-cryptography python3-dbus python3-dev python3-gi python3-keyring python3-minimal python3-numpy python3-pip python3-pkg-resources python3-rpi.gpio python3-setuptools python3-smbus python3.5 python3.5-dev python3.5-minimal

    redis-server redis-tools rename rpcbind ruby ruby-xmmsclient s-nail samba samba-common samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules smbclient ssh systemd systemd-sysv udev usbutils util-linux vim-common vim-tiny

    wget wpasupplicant xml2rfc xorgxrdp xserver-xorg-core xterm

    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 323 nicht aktualisiert.

    6 nicht vollständig installiert oder entfernt.

    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.

    Möchten Sie fortfahren? [J/n] j

    raspberrypi-bootloader (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/start.elf zu /usr/share/rpikernelhack/start.elf durch rpikernelhack« wird entfernt

    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/start.elf.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-bootloader (--configure):

    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück

    raspberrypi-kernel (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/kernel.img zu /usr/share/rpikernelhack/kernel.img durch rpikernelhack« wird entfernt

    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/kernel.img.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-kernel (--configure):

    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 2 zurück

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi0:

    libraspberrypi0 hängt ab von raspberrypi-bootloader (= 1.20201201-1); aber:

    Paket raspberrypi-bootloader ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi0 (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-doc:

    libraspberrypi-doc hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-doc (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-dev:

    libraspberrypi-dev hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-dev (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-bin:

    libraspberrypi-bin hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-bin (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    Fehler traten auf beim Bearbeiten von:

    raspberrypi-bootloader

    raspberrypi-kernel

    libraspberrypi0

    libraspberrypi-doc

    libraspberrypi-dev

    libraspberrypi-bin

    E: Sub-process /usr/bin/dpkg returned an error code (1)


    Dann ist mir aufgefallen, daß /boot keine Dateien mehr enthält, ein Neustart führt in die Wüste, der Raspi bootet dann nicht mehr.

    Habe ein Backup zurückgespielt.




    Wer kann da helfen?

  • habe das Problem, daß nach einem "sudo apt-get upgrade" die folgende Fehlermeldung ausgegeben wird.

    ...

    Ja, ich habe schon gesucht im Netz gesucht :)

    Versuch mal mit:

    Code
    sudo dpkg --configure -a
    sudo apt-get upgrade --with-new-pkgs

    und wenn erfolgreich bzw. fertig, dann poste die Ausgaben von:

    Code
    sudo apt-get -f install
    uname -a


    EDIT:


    Siehe auch: Was bedeutet dieser SSH -Code?


    EDIT 2:


    BTW: Wann hast Du das Backup gemacht? War der Inhalt des /boot-Ordners zu dem Zeitpunkt auch so wie jetzt von dir gepostet?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Danke mal für die erste, schnelle Antwort


    Auch noch zur Info: Verwende eine SSD statt einer SD-Karte, vermute mal, das ist aber keine echtes Problem...



    Folgende Informationen:


    sudo apt-get upgrade --with-new-pkgs

    ...

    Entpacken von xml2rfc (2.15.5-1) über (2.5.1-1.1) ...

    Vorbereitung zum Entpacken von .../204-xterm_344-1_armhf.deb ...

    Entpacken von xterm (344-1) über (327-2) ...

    Fehler traten auf beim Bearbeiten von:

    /tmp/apt-dpkg-install-idkVJW/043-firmware-misc-nonfree_1%3a20190114-1+rpt10_all.deb

    /tmp/apt-dpkg-install-idkVJW/103-libegl1_1.3.0-7~bpo10+1_armhf.deb

    E: Sub-process /usr/bin/dpkg returned an error code (1)


    pi@raspberrypi3 ~ $ sudo apt-get upgrade --with-new-pkgs

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.

    Die folgenden Pakete haben unerfüllte Abhängigkeiten:

    firmware-ralink : Hängt ab von: firmware-misc-nonfree ist aber nicht installiert

    libegl1-mesa : Hängt ab von: libegl1 ist aber nicht installiert

    E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).



    pi@raspberrypi3 ~ $ sudo apt-get -f install

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:

    firmware-misc-nonfree firmware-ralink g++-4.6 gnupg-agent libbabeltrace-ctf1 libblas-common libboost-filesystem1.62.0 libboost-iostreams1.62.0 libboost-system1.62.0 libdns-export162 libevent-core-2.0-5

    libevent-extra-2.0-5 libevent-openssl-2.0-5 libevent-pthreads-2.0-5 libgfortran3 libhttp-parser2.8 libhunspell-1.4-0 libisc-export160 liblzo2-2 libncurses5-dev libntfs-3g871

    libpackage-deprecationmanager-perl libprocps6 libpython3.5 libpython3.5-dev libpython3.5-minimal libpython3.5-stdlib libruby2.3 libsndio6.1 libstdc++-4.9-dev libstdc++6-4.6-dev libtinfo-dev libunbound2

    libunistring0 python-certifi python-idna python-pyasn1 python-requests python-urllib3 python3-pyasn1 python3.5 python3.5-dev python3.5-minimal ruby2.3 xml-core

    Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.

    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 126 nicht aktualisiert.

    8 nicht vollständig installiert oder entfernt.

    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.

    raspberrypi-kernel (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/kernel.img zu /usr/share/rpikernelhack/kernel.img durch rpikernelhack« wird entfernt

    ^[[28~dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/kernel.img.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-kernel (--configure):

    »installiertes raspberrypi-kernel-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück

    raspberrypi-bootloader (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/start.elf zu /usr/share/rpikernelhack/start.elf durch rpikernelhack« wird entfernt

    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/start.elf.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-bootloader (--configure):

    »installiertes raspberrypi-bootloader-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi0:

    libraspberrypi0 hängt ab von raspberrypi-bootloader (= 1.20201201-1); aber:

    Paket raspberrypi-bootloader ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi0 (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libavcodec58:armhf:

    libavcodec58:armhf hängt ab von libraspberrypi0; aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libavcodec58:armhf (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libchromaprint1:armhf:

    libchromaprint1:armhf hängt ab von libavcodec58 (>= 7:4.0); aber:

    Paket libavcodec58:armhf ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libchromaprint1:armhf (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-doc:

    libraspberrypi-doc hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-doc (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-bin:

    libraspberrypi-bin hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-bin (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-dev:

    libraspberrypi-dev hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-dev (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    Fehler traten auf beim Bearbeiten von:

    raspberrypi-kernel

    raspberrypi-bootloader

    libraspberrypi0

    libavcodec58:armhf

    libchromaprint1:armhf

    libraspberrypi-doc

    libraspberrypi-bin

    libraspberrypi-dev

    E: Sub-process /usr/bin/dpkg returned an error code (1)



    pi@raspberrypi3 ~ $ uname -a

    Linux raspberrypi3 5.4.72-v7+ #1356 SMP Thu Oct 22 13:56:54 BST 2020 armv7l GNU/Linux




  • Hast Du mit dem aktuellen Inhalt des /boot-Verzeichnisses (siehe "ls -la /boot") aus dem backup) deinen Pi noch rebooten können? Wenn ja, dann reboote deinen PI jetzt und poste sofort nach dem rebooten, die Ausgaben von:

    Code
    ls -la /boot
    ls -la /tmp
    sudo apt-get -f install

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Nach dem Restore des Backups war das /boot noch gut gefüllt, nach dem apt-get upgrade wurde da offensichtlich zusammengeräumt.


    Wenn ich jetzt ein reboot mache, steht wahrscheinlich das ganze...


    Woher sollte der raspi booten?


    pi@raspberrypi3 ~ $ ls -la /boot

    insgesamt 49

    drwxrwx--- 5 root users 3584 Jan 1 1970 .

    drwxr-xr-x 25 root root 4096 Dez 27 09:30 ..

    drwxrwx--- 2 root users 512 Nov 9 19:52 '$RECYCLE.BIN'

    -rw-rw---- 1 root users 631 Nov 9 20:20 cmdline.txt

    -rw-rw---- 1 root users 1543 Nov 9 20:14 config.txt

    -rw-rw---- 1 root users 41 Jan 13 2019 .firmware_revision

    -rw-rw---- 1 root users 137 Jan 8 2014 issue.txt

    -rw-rw---- 1 root users 18974 Sep 25 2013 LICENSE.oracle

    drwxrwx--- 2 root users 17920 Dez 27 08:00 overlays

    drwxrwx--- 2 root users 512 Nov 1 2018 'System Volume Information'

    pi@raspberrypi3 ~ $ ls -la /tmp

    insgesamt 40

    drwxrwxrwt 10 root root 4096 Dez 27 09:50 .

    drwxr-xr-x 25 root root 4096 Dez 27 09:30 ..

    drwxrwxrwt 2 root root 4096 Dez 27 01:44 .font-unix

    drwxrwxrwt 2 root root 4096 Dez 27 01:44 .ICE-unix

    drwx------ 3 root root 4096 Dez 27 01:44 systemd-private-a23eeb30df7744ad864e6d61e65e47a5-apache2.service-xSNs5o

    drwx------ 3 root root 4096 Dez 27 09:38 systemd-private-a23eeb30df7744ad864e6d61e65e47a5-ntp.service-3Wjlsn

    drwx------ 3 root root 4096 Dez 27 09:43 systemd-private-a23eeb30df7744ad864e6d61e65e47a5-redis-server.service-WBjryo

    drwxrwxrwt 2 root root 4096 Dez 27 01:44 .Test-unix

    drwxrwxrwt 2 root root 4096 Dez 27 01:44 .X11-unix

    drwxrwxrwt 2 root root 4096 Dez 27 01:44 .XIM-unix


    pi@raspberrypi3 ~ $ sudo apt-get -f install

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:

    firmware-misc-nonfree firmware-ralink g++-4.6 gnupg-agent libbabeltrace-ctf1 libblas-common libboost-filesystem1.62.0 libboost-iostreams1.62.0 libboost-system1.62.0 libdns-export162 libevent-core-2.0-5 libevent-extra-2.0-5

    libevent-openssl-2.0-5 libevent-pthreads-2.0-5 libgfortran3 libhttp-parser2.8 libhunspell-1.4-0 libisc-export160 liblzo2-2 libncurses5-dev libntfs-3g871 libpackage-deprecationmanager-perl libprocps6 libpython3.5 libpython3.5-dev

    libpython3.5-minimal libpython3.5-stdlib libruby2.3 libsndio6.1 libstdc++-4.9-dev libstdc++6-4.6-dev libtinfo-dev libunbound2 libunistring0 python-certifi python-idna python-pyasn1 python-requests python-urllib3 python3-pyasn1

    python3.5 python3.5-dev python3.5-minimal ruby2.3 xml-core

    Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.

    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 126 nicht aktualisiert.

    8 nicht vollständig installiert oder entfernt.

    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.

    ^[[28~raspberrypi-kernel (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/kernel.img zu /usr/share/rpikernelhack/kernel.img durch rpikernelhack« wird entfernt

    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/kernel.img.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-kernel (--configure):

    ....

    usw

  • Nach dem Restore des Backups war das /boot noch gut gefüllt, nach dem apt-get upgrade wurde da offensichtlich zusammengeräumt.


    Wenn ich jetzt ein reboot mache, steht wahrscheinlich das ganze...


    Woher sollte der raspi booten?

    Ja. stimmt. Wenn Du jetzt ein Restore des Backups nicht mehr machen kannst, müsstest Du die fehlenden Dateien im /boot-Verzeichnis, manuell dort hin kopieren.

    Hast Du evtl. ein funktionierendes OS auf einer SD-Karte, für deinen PI?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • so, jetzt mal das /boot "repariert", alle Dateien von einem aktuellen Image kopiert.


    WICHTIG: außer config.txt und cmdline.txt, damit ich von der SSD booten kann.


    Dann einen Neustart - alles läuft wieder.

    ... aber wenn ich ein apt-get upgrade machen würde, wäre vermutlich wieder alles kaputt....


    also: System läuft


    wie geht´s jetzt weiter?


  • ... aber wenn ich ein apt-get upgrade machen würde, wäre vermutlich wieder alles kaputt....


    also: System läuft


    wie geht´s jetzt weiter?

    Ja, und ein "apt-get upgrade" sollst Du jetzt nicht machen.

    Poste nach einem:

    Code
    sudo apt-get update
    sudo dpkg --configure -a

    die Ausgaben (2. ist nur eine Simulation) von:

    Code
    sudo apt-get -f install
    apt-get -s upgrade --with-new-pkgs

    (in einem spoiler).

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Na dann weiter:


    pi@raspberrypi3 ~ $ sudo apt-get update

    OK:1 http://archive.raspberrypi.org/debian buster InRelease

    Holen:2 http://mirrordirector.raspbian.org/raspbian buster InRelease [15,0 kB]

    Es wurden 15,0 kB in 2 s geholt (6.468 B/s).

    Paketlisten werden gelesen... Fertig


    pi@raspberrypi3 ~ $ sudo dpkg --configure -a

    raspberrypi-kernel (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/kernel.img zu /usr/share/rpikernelhack/kernel.img durch rpikernelhack« wird entfernt

    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/kernel.img.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-kernel (--configure):

    »installiertes raspberrypi-kernel-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück

    raspberrypi-bootloader (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/start.elf zu /usr/share/rpikernelhack/start.elf durch rpikernelhack« wird entfernt

    ^[[28~dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/start.elf.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-bootloader (--configure):

    »installiertes raspberrypi-bootloader-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi0:

    libraspberrypi0 hängt ab von raspberrypi-bootloader (= 1.20201201-1); aber:

    Paket raspberrypi-bootloader ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi0 (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libavcodec58:armhf:

    libavcodec58:armhf hängt ab von libraspberrypi0; aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libavcodec58:armhf (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libchromaprint1:armhf:

    libchromaprint1:armhf hängt ab von libavcodec58 (>= 7:4.0); aber:

    Paket libavcodec58:armhf ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libchromaprint1:armhf (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-doc:

    libraspberrypi-doc hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-doc (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-bin:

    libraspberrypi-bin hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-bin (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-dev:

    libraspberrypi-dev hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-dev (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    Fehler traten auf beim Bearbeiten von:

    raspberrypi-kernel

    raspberrypi-bootloader

    libraspberrypi0

    libavcodec58:armhf

    libchromaprint1:armhf

    libraspberrypi-doc

    libraspberrypi-bin

    libraspberrypi-dev


    pi@raspberrypi3 ~ $ sudo apt-get -f install

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:

    firmware-misc-nonfree firmware-ralink g++-4.6 gnupg-agent libbabeltrace-ctf1 libblas-common libboost-filesystem1.62.0

    libboost-iostreams1.62.0 libboost-system1.62.0 libdns-export162 libevent-core-2.0-5 libevent-extra-2.0-5

    libevent-openssl-2.0-5 libevent-pthreads-2.0-5 libgfortran3 libhttp-parser2.8 libhunspell-1.4-0 libisc-export160 liblzo2-2

    libncurses5-dev libntfs-3g871 libpackage-deprecationmanager-perl libprocps6 libpython3.5 libpython3.5-dev

    libpython3.5-minimal libpython3.5-stdlib libruby2.3 libsndio6.1 libstdc++-4.9-dev libstdc++6-4.6-dev libtinfo-dev

    libunbound2 libunistring0 python-certifi python-idna python-pyasn1 python-requests python-urllib3 python3-pyasn1 python3.5

    python3.5-dev python3.5-minimal ruby2.3 xml-core

    Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.

    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 126 nicht aktualisiert.

    8 nicht vollständig installiert oder entfernt.

    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.

    raspberrypi-kernel (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/kernel.img zu /usr/share/rpikernelhack/kernel.img durch rpikernelhack« wird entfernt

    ^[[28~dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/kernel.img.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-kernel (--configure):

    »installiertes raspberrypi-kernel-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück

    raspberrypi-bootloader (1.20201201-1) wird eingerichtet ...

    »Umleitung von /boot/start.elf zu /usr/share/rpikernelhack/start.elf durch rpikernelhack« wird entfernt

    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/start.elf.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt

    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-bootloader (--configure):

    »installiertes raspberrypi-bootloader-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi0:

    libraspberrypi0 hängt ab von raspberrypi-bootloader (= 1.20201201-1); aber:

    Paket raspberrypi-bootloader ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi0 (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libavcodec58:armhf:

    libavcodec58:armhf hängt ab von libraspberrypi0; aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libavcodec58:armhf (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libchromaprint1:armhf:

    libchromaprint1:armhf hängt ab von libavcodec58 (>= 7:4.0); aber:

    Paket libavcodec58:armhf ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libchromaprint1:armhf (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-doc:

    libraspberrypi-doc hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-doc (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-bin:

    libraspberrypi-bin hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-bin (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-dev:

    libraspberrypi-dev hängt ab von libraspberrypi0 (= 1.20201201-1); aber:

    Paket libraspberrypi0 ist noch nicht konfiguriert.


    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-dev (--configure):

    Abhängigkeitsprobleme - verbleibt unkonfiguriert

    Fehler traten auf beim Bearbeiten von:

    raspberrypi-kernel

    raspberrypi-bootloader

    libraspberrypi0

    libavcodec58:armhf

    libchromaprint1:armhf

    libraspberrypi-doc

    libraspberrypi-bin

    libraspberrypi-dev

    E: Sub-process /usr/bin/dpkg returned an error code (1)


    pi@raspberrypi3 ~ $ apt-get -s upgrade --with-new-pkgs

    HINWEIS: Dies ist nur eine Simulation!

    apt-get benötigt root-Privilegien für die reale Ausführung.

    Behalten Sie ebenfalls in Hinterkopf, dass die Sperren deaktiviert

    sind, verlassen Sie sich also bezüglich des reellen aktuellen

    Status der Sperre nicht darauf!

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Paketaktualisierung (Upgrade) wird berechnet... Fertig

    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:

    firmware-misc-nonfree firmware-ralink g++-4.6 gnupg-agent libbabeltrace-ctf1 libblas-common libboost-filesystem1.62.0

    libboost-iostreams1.62.0 libboost-system1.62.0 libdns-export162 libevent-core-2.0-5 libevent-extra-2.0-5

    libevent-openssl-2.0-5 libevent-pthreads-2.0-5 libgfortran3 libhttp-parser2.8 libhunspell-1.4-0 libisc-export160 liblzo2-2

    libncurses5-dev libntfs-3g871 libpackage-deprecationmanager-perl libprocps6 libpython3.5 libpython3.5-dev

    libpython3.5-minimal libpython3.5-stdlib libruby2.3 libsndio6.1 libstdc++-4.9-dev libstdc++6-4.6-dev libtinfo-dev

    libunbound2 libunistring0 python-certifi python-idna python-pyasn1 python-requests python-urllib3 python3-pyasn1 python3.5

    python3.5-dev python3.5-minimal ruby2.3 xml-core

    Verwenden Sie »apt autoremove«, um sie zu entfernen.

    Die folgenden Pakete sind zurückgehalten worden:

    apache2 apache2-bin apache2-data apache2-utils bind9-host build-essential cmake cmake-data cpp-6 curl default-mysql-client

    default-mysql-server g++ g++-6 gcc-6 gcc-6-base git git-man krb5-multidev libalgorithm-diff-xs-perl libasan3 libavcodec-dev

    libavformat-dev libavutil-dev libb-hooks-op-check-perl libbareword-filehandles-perl libclass-c3-xs-perl

    libclass-xsaccessor-perl libclone-perl libcommon-sense-perl libcups2 libcurl3-gnutls libcurl4-openssl-dev libdatetime-perl

    libdbd-mysql-perl libdbd-sqlite3-perl libdbi-perl libdevel-caller-perl libdevel-lexalias-perl libdevice-serialport-perl

    libfcgi-perl libfile-fcntllock-perl libgcc-6-dev libgfortran3 libgl1-mesa-dri libgssapi-krb5-2 libgssrpc4

    libhtml-parser-perl libindirect-perl libio-interface-perl libio-socket-ssl-perl libjson-xs-perl libk5crypto3

    libkadm5clnt-mit11 libkadm5srv-mit11 libkrb5-3 libkrb5-dev libkrb5support0 libldb1 liblexical-sealrequirehints-perl

    liblist-moreutils-perl liblocale-gettext-perl libmultidimensional-perl libnet-ssleay-perl libopenmpt0

    libpackage-stash-xs-perl libpadwalker-perl libpam-systemd libparams-classify-perl libparams-util-perl libpq-dev libpq5

    libscalar-list-utils-perl libsmbclient libsocket-perl libsocket6-perl libspecio-perl libssh-gcrypt-4 libstdc++-6-dev

    libstdc++6 libsub-identify-perl libsub-name-perl libswresample-dev libsystemd0 libterm-readkey-perl libtext-charwidth-perl

    libtext-iconv-perl libtext-soundex-perl libudev1 libvariable-magic-perl libwbclient0 libxml-parser-perl motion nfs-common

    openssh-client openssh-server openssh-sftp-server perl perl-base php php-bz2 php-cli php-curl php-gd php-mbstring php-mysql

    php-xml php-zip python-ldb python-mysqldb python-samba rename rpcbind samba samba-common samba-common-bin samba-dsdb-modules

    samba-libs samba-vfs-modules smbclient ssh systemd systemd-sysv udev xorgxrdp xserver-xorg-core

    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 126 nicht aktualisiert.

    8 nicht vollständig installiert oder entfernt.

    Conf libraspberrypi-bin (1.20201201-1 Raspberry Pi Foundation:testing [armhf])

    Conf libraspberrypi-dev (1.20201201-1 Raspberry Pi Foundation:testing [armhf])

    Conf libchromaprint1 (1.4.3-3 Raspbian:stable [armhf])

    Conf libraspberrypi-doc (1.20201201-1 Raspberry Pi Foundation:testing [armhf])

    Conf raspberrypi-kernel (1.20201201-1 Raspberry Pi Foundation:testing [armhf])

    Conf raspberrypi-bootloader (1.20201201-1 Raspberry Pi Foundation:testing [armhf])

    Conf libavcodec58 (7:4.1.6-1~deb10u1+rpt1 Raspberry Pi Foundation:testing [armhf])

    Conf libraspberrypi0 (1.20201201-1 Raspberry Pi Foundation:testing [armhf])

  • Wie ist jetzt die Ausgabe von:

    Code
    apt-cache policy raspberrypi-kernel

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • OK, dann versuch mal ein reinstall:

    Code
    sudo apt-get install --reinstall raspberrypi-kernel

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • der will mich nicht ;)


    pi@raspberrypi3 ~ $ sudo apt-get install --reinstall raspberrypi-kernel

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:

    firmware-misc-nonfree firmware-ralink g++-4.6 gnupg-agent libbabeltrace-ctf1 libblas-common libboost-filesystem1.62.0

    libboost-iostreams1.62.0 libboost-system1.62.0 libdns-export162 libevent-core-2.0-5 libevent-extra-2.0-5

    libevent-openssl-2.0-5 libevent-pthreads-2.0-5 libgfortran3 libhttp-parser2.8 libhunspell-1.4-0 libisc-export160 liblzo2-2

    libncurses5-dev libntfs-3g871 libpackage-deprecationmanager-perl libprocps6 libpython3.5 libpython3.5-dev

    libpython3.5-minimal libpython3.5-stdlib libruby2.3 libsndio6.1 libstdc++-4.9-dev libstdc++6-4.6-dev libtinfo-dev

    libunbound2 libunistring0 python-certifi python-idna python-pyasn1 python-requests python-urllib3 python3-pyasn1 python3.5

    python3.5-dev python3.5-minimal ruby2.3 xml-core

    Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.

    0 aktualisiert, 0 neu installiert, 1 erneut installiert, 0 zu entfernen und 126 nicht aktualisiert.

    8 nicht vollständig installiert oder entfernt.

    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.

    E: Internal Error, No file name for raspberrypi-kernel:armhf

  • der will mich nicht ;)


    ...

    Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.

    Hmm, ... da ja ein backup vorhanden ist, versuch mal:

    Code
    sudo apt autoremove

    und danach:

    Code
    sudo apt-get upgrade --with-new-pkgs
    sudo apt-get -f install
    sudo dpkg --configure -a

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • flandste wenn Du bitte Terminal-Ausgaben in einem Codeblock postest, das ist das </>-Symbol im schwarzen Balken. Das spart Platz. Außerdem gehen führende Leerzeichen nicht verloren.

    Schönen Gruß, kle

  • pi@raspberrypi3 ~ $ sudo apt autoremove
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Die folgenden Pakete werden ENTFERNT:
    firmware-misc-nonfree firmware-ralink g++-4.6 gnupg-agent libbabeltrace-ctf1 libblas-common libboost-filesystem1.62.0
    libboost-iostreams1.62.0 libboost-system1.62.0 libdns-export162 libevent-core-2.0-5 libevent-extra-2.0-5
    libevent-openssl-2.0-5 libevent-pthreads-2.0-5 libgfortran3 libhttp-parser2.8 libhunspell-1.4-0 libisc-export160 liblzo2-2
    libncurses5-dev libntfs-3g871 libpackage-deprecationmanager-perl libprocps6 libpython3.5 libpython3.5-dev
    libpython3.5-minimal libpython3.5-stdlib libruby2.3 libsndio6.1 libstdc++-4.9-dev libstdc++6-4.6-dev libtinfo-dev
    libunbound2 libunistring0 python-certifi python-idna python-pyasn1 python-requests python-urllib3 python3-pyasn1 python3.5
    python3.5-dev python3.5-minimal ruby2.3 xml-core
    0 aktualisiert, 0 neu installiert, 45 zu entfernen und 125 nicht aktualisiert.
    8 nicht vollständig installiert oder entfernt.
    Nach dieser Operation werden 141 MB Plattenplatz freigegeben.
    Möchten Sie fortfahren? [J/n] j
    (Lese Datenbank ... 84643 Dateien und Verzeichnisse sind derzeit installiert.)
    Entfernen von firmware-ralink (1:20190114-1+rpt10) ...
    Entfernen von firmware-misc-nonfree (1:20190114-1+rpt10) ...
    Entfernen von gnupg-agent (2.2.12-1+rpi1+deb10u1) ...
    Entfernen von libbabeltrace-ctf1 (1.5.6-2+deb10u1) ...
    Entfernen von libblas-common (3.7.0-2) ...
    Entfernen von libboost-filesystem1.62.0:armhf (1.62.0+dfsg-10+b3) ...
    Entfernen von libboost-iostreams1.62.0:armhf (1.62.0+dfsg-10+b3) ...
    Entfernen von libboost-system1.62.0:armhf (1.62.0+dfsg-10+b3) ...
    Entfernen von libdns-export162 (1:9.10.3.dfsg.P4-12.3+deb9u7) ...
    Entfernen von libevent-extra-2.0-5:armhf (2.0.21-stable-3) ...
    Entfernen von libevent-pthreads-2.0-5:armhf (2.0.21-stable-3) ...
    Entfernen von libevent-openssl-2.0-5:armhf (2.0.21-stable-3) ...
    Entfernen von libgfortran3:armhf (6.3.0-18+rpi1+deb9u1) ...
    Entfernen von libhttp-parser2.8:armhf (2.8.1-1) ...
    Entfernen von libhunspell-1.4-0:armhf (1.4.1-2) ...
    Entfernen von libisc-export160 (1:9.10.3.dfsg.P4-12.3+deb9u7) ...
    Entfernen von liblzo2-2:armhf (2.10-0.1) ...
    Entfernen von libncurses5-dev:armhf (6.1+20181013-2+deb10u2) ...
    Entfernen von libntfs-3g871 (1:2016.2.22AR.1+dfsg-1+deb9u1) ...
    Entfernen von libpackage-deprecationmanager-perl (0.17-1) ...
    Entfernen von libprocps6:armhf (2:3.3.12-3+deb9u1) ...
    Entfernen von python3.5-dev (3.5.4-4) ...
    Entfernen von libpython3.5-dev:armhf (3.5.4-4) ...
    Entfernen von libpython3.5:armhf (3.5.4-4) ...
    Entfernen von python3.5 (3.5.4-4) ...
    Entfernen von libpython3.5-stdlib:armhf (3.5.4-4) ...
    Entfernen von python3.5-minimal (3.5.4-4) ...
    Unlinking and removing bytecode for runtime python3.5
    ^[[28~Entfernen von libpython3.5-minimal:armhf (3.5.4-4) ...
    Entfernen von ruby2.3 (2.3.6-2+rpi1+b1) ...
    Entfernen von libruby2.3:armhf (2.3.6-2+rpi1+b1) ...
    Entfernen von libsndio6.1:armhf (1.1.0-3) ...
    Entfernen von libstdc++-4.9-dev:armhf (4.9.4-2+rpi1+b19) ...
    Entfernen von libtinfo-dev:armhf (6.1+20181013-2+deb10u2) ...
    Entfernen von libunbound2:armhf (1.6.0-3+deb9u2) ...
    Entfernen von libunistring0:armhf (0.9.6+really0.9.3-0.1) ...
    Entfernen von python-requests (2.21.0-1) ...
    Entfernen von python-certifi (2018.8.24-1) ...
    Entfernen von python-idna (2.6-1) ...
    Entfernen von python-pyasn1 (0.4.2-3) ...
    Entfernen von python-urllib3 (1.24.1-1) ...
    Entfernen von python3-pyasn1 (0.4.2-3) ...
    Entfernen von xml-core (0.18+nmu1) ...
    Entfernen von libevent-core-2.0-5:armhf (2.0.21-stable-3) ...
    Entfernen von libstdc++6-4.6-dev (4.6.4-5+rpi1) ...
    Entfernen von g++-4.6 (4.6.4-5+rpi1) ...
    raspberrypi-kernel (1.20201201-1) wird eingerichtet ...
    »Umleitung von /boot/kernel.img zu /usr/share/rpikernelhack/kernel.img durch rpikernelhack« wird entfernt
    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/kernel.img.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist n icht erlaubt
    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-kernel (--configure):
    »installiertes raspberrypi-kernel-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück
    raspberrypi-bootloader (1.20201201-1) wird eingerichtet ...
    »Umleitung von /boot/start.elf zu /usr/share/rpikernelhack/start.elf durch rpikernelhack« wird entfernt
    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/start.elf.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt
    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-bootloader (--configure):
    »installiertes raspberrypi-bootloader-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi0:
    libraspberrypi0 hängt ab von raspberrypi-bootloader (= 1.20201201-1); aber:
    Paket raspberrypi-bootloader ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi0 (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libavcodec58:armhf:
    libavcodec58:armhf hängt ab von libraspberrypi0; aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libavcodec58:armhf (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libchromaprint1:armhf:
    libchromaprint1:armhf hängt ab von libavcodec58 (>= 7:4.0); aber:
    Paket libavcodec58:armhf ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libchromaprint1:armhf (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-doc:
    libraspberrypi-doc hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-doc (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-bin:
    libraspberrypi-bin hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-bin (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-dev:
    libraspberrypi-dev hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-dev (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    Trigger für mime-support (3.62) werden verarbeitet ...
    Trigger für libc-bin (2.28-10+rpi1) werden verarbeitet ...
    Trigger für man-db (2.8.5-2) werden verarbeitet ...
    Trigger für sgml-base (1.29) werden verarbeitet ...
    Fehler traten auf beim Bearbeiten von:
    raspberrypi-kernel
    raspberrypi-bootloader
    libraspberrypi0
    libavcodec58:armhf
    libchromaprint1:armhf
    libraspberrypi-doc
    libraspberrypi-bin
    libraspberrypi-dev
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    das mit "sudo apt-get upgrade --with-new-pkgs" habe ich noch nicht gemacht.....

  • Dann versuch jetzt mal:

    Code
    sudo apt-get update
    sudo apt-get upgrade --with-new-pkgs

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • pi@raspberrypi3 ~ $ sudo apt-get update
    OK:1 http://archive.raspberrypi.org/debian buster InRelease
    OK:2 http://mirrordirector.raspbian.org/raspbian buster InRelease
    Paketlisten werden gelesen... Fertig
    pi@raspberrypi3 ~ $ sudo apt-get upgrade --with-new-pkgs
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Paketaktualisierung (Upgrade) wird berechnet... Fertig
    Die folgenden Pakete sind zurückgehalten worden:
    apache2 apache2-bin apache2-data apache2-utils bind9-host build-essential cmake cmake-data cpp-6 curl default-mysql-client default-mysql-server g++ g++-6 gcc-6 gcc-6-base git git-man krb5-multidev libalgorithm-diff-xs-perl libasan3
    libavcodec-dev libavformat-dev libavutil-dev libb-hooks-op-check-perl libbareword-filehandles-perl libclass-c3-xs-perl libclass-xsaccessor-perl libclone-perl libcommon-sense-perl libcups2 libcurl3-gnutls libcurl4-openssl-dev
    libdatetime-perl libdbd-mysql-perl libdbd-sqlite3-perl libdbi-perl libdevel-caller-perl libdevel-lexalias-perl libdevice-serialport-perl libfcgi-perl libfile-fcntllock-perl libgcc-6-dev libgl1-mesa-dri libgssapi-krb5-2 libgssrpc4
    libhtml-parser-perl libindirect-perl libio-interface-perl libio-socket-ssl-perl libjson-xs-perl libk5crypto3 libkadm5clnt-mit11 libkadm5srv-mit11 libkrb5-3 libkrb5-dev libkrb5support0 libldb1 liblexical-sealrequirehints-perl
    liblist-moreutils-perl liblocale-gettext-perl libmultidimensional-perl libnet-ssleay-perl libopenmpt0 libpackage-stash-xs-perl libpadwalker-perl libpam-systemd libparams-classify-perl libparams-util-perl libpq-dev libpq5
    libscalar-list-utils-perl libsmbclient libsocket-perl libsocket6-perl libspecio-perl libssh-gcrypt-4 libstdc++-6-dev libstdc++6 libsub-identify-perl libsub-name-perl libswresample-dev libsystemd0 libterm-readkey-perl
    libtext-charwidth-perl libtext-iconv-perl libtext-soundex-perl libudev1 libvariable-magic-perl libwbclient0 libxml-parser-perl motion nfs-common openssh-client openssh-server openssh-sftp-server perl perl-base php php-bz2 php-cli
    php-curl php-gd php-mbstring php-mysql php-xml php-zip python-ldb python-mysqldb python-samba rename rpcbind samba samba-common samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules smbclient ssh systemd systemd-sysv udev
    xorgxrdp xserver-xorg-core
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 125 nicht aktualisiert.
    8 nicht vollständig installiert oder entfernt.
    Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren? [J/n] j
    raspberrypi-kernel (1.20201201-1) wird eingerichtet ...
    »Umleitung von /boot/kernel.img zu /usr/share/rpikernelhack/kernel.img durch rpikernelhack« wird entfernt
    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/kernel.img.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt
    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-kernel (--configure):
    »installiertes raspberrypi-kernel-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück
    raspberrypi-bootloader (1.20201201-1) wird eingerichtet ...
    »Umleitung von /boot/start.elf zu /usr/share/rpikernelhack/start.elf durch rpikernelhack« wird entfernt
    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/start.elf.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt
    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-bootloader (--configure):
    »installiertes raspberrypi-bootloader-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi0:
    libraspberrypi0 hängt ab von raspberrypi-bootloader (= 1.20201201-1); aber:
    Paket raspberrypi-bootloader ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi0 (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libavcodec58:armhf:
    libavcodec58:armhf hängt ab von libraspberrypi0; aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libavcodec58:armhf (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libchromaprint1:armhf:
    libchromaprint1:armhf hängt ab von libavcodec58 (>= 7:4.0); aber:
    Paket libavcodec58:armhf ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libchromaprint1:armhf (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-doc:
    libraspberrypi-doc hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-doc (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-bin:
    libraspberrypi-bin hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-bin (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-dev:
    libraspberrypi-dev hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-dev (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    Fehler traten auf beim Bearbeiten von:
    raspberrypi-kernel
    raspberrypi-bootloader
    libraspberrypi0
    libavcodec58:armhf
    libchromaprint1:armhf
    libraspberrypi-doc
    libraspberrypi-bin
    libraspberrypi-dev
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  • Möchten Sie fortfahren? [J/n] j


    raspberrypi-kernel (1.20201201-1) wird eingerichtet ...
    »Umleitung von /boot/kernel.img zu /usr/share/rpikernelhack/kernel.img durch rpikernelhack« wird entfernt
    dpkg-divert: Fehler: Eigentümer der Zieldatei »/boot/kernel.img.dpkg-divert.tmp« kann nicht geändert werden: Die Operation ist nicht erlaubt
    dpkg: Fehler beim Bearbeiten des Paketes raspberrypi-kernel (--configure):
    »installiertes raspberrypi-kernel-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück...

    ...

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Versuch jetzt mal mit:

    Code
    sudo apt-get dist-upgrade

    EDIT:


    Poste auch die Ausgaben von:

    Code
    ls -la /boot/*.tmp

    EDIT 2:


    Ich denke dpkg-divert kann auf der /boot-Partition mit dem Dateisystem vfat, nicht agieren. bzw. nichts ausrichten. Ein bug?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Hier der Rest von sudo apt-get dist-upgrade:

    Paket libavcodec-dev:armhf ist noch nicht konfiguriert.
    libavformat-dev:armhf hängt ab von libavformat58 (= 7:4.1.6-1~deb10u1+rpt1); aber:
    Paket libavformat58:armhf ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libavformat-dev:armhf (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    libnss3:armhf (2:3.42.1-1+deb10u3) wird eingerichtet ...
    php7.3-bz2 (7.3.19-1~deb10u1) wird eingerichtet ...

    Creating config file /etc/php/7.3/mods-available/bz2.ini with new version
    libisc1100:armhf (1:9.11.5.P4+dfsg-5.1+deb10u2) wird eingerichtet ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-doc:
    libraspberrypi-doc hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-doc (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    php-mbstring (2:7.3+69) wird eingerichtet ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-bin:
    libraspberrypi-bin hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-bin (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    perl (5.28.1-6) wird eingerichtet ...
    Removing obsolete conffile /etc/perl/sitecustomize.pl ...
    libpackage-stash-xs-perl (0.29-1) wird eingerichtet ...
    libref-util-perl (0.204-1) wird eingerichtet ...
    libsocket6-perl (0.29-1+b1) wird eingerichtet ...
    mariadb-client-10.3 (1:10.3.27-0+deb10u1) wird eingerichtet ...
    Neue Version der Konfigurationsdatei /etc/mysql/mariadb.conf.d/50-client.cnf wird installiert ...
    libgssapi-krb5-2:armhf (1.17-3+deb10u1) wird eingerichtet ...
    libvariable-magic-perl (0.62-1+b1) wird eingerichtet ...
    libb-hooks-op-check-perl (0.22-1+b1) wird eingerichtet ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libavdevice58:armhf:
    libavdevice58:armhf hängt ab von libavcodec58 (= 7:4.1.6-1~deb10u1+rpt1); aber:
    Paket libavcodec58:armhf ist noch nicht konfiguriert.
    libavdevice58:armhf hängt ab von libavfilter7 (= 7:4.1.6-1~deb10u1+rpt1); aber:
    Paket libavfilter7:armhf ist noch nicht konfiguriert.
    libavdevice58:armhf hängt ab von libavformat58 (= 7:4.1.6-1~deb10u1+rpt1); aber:
    Paket libavformat58:armhf ist noch nicht konfiguriert.
    libavdevice58:armhf hängt ab von libraspberrypi0; aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libavdevice58:armhf (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    libparams-util-perl (1.07-3+b3) wird eingerichtet ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libraspberrypi-dev:
    libraspberrypi-dev hängt ab von libraspberrypi0 (= 1.20201201-1); aber:
    Paket libraspberrypi0 ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes libraspberrypi-dev (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    libcups2:armhf (2.2.10-6+deb10u4) wird eingerichtet ...
    libsub-name-perl (0.21-1+b2) wird eingerichtet ...
    g++-8 (8.3.0-6+rpi1) wird eingerichtet ...
    libio-interface-perl (1.09-1+b4) wird eingerichtet ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von motion:
    motion hängt ab von libavcodec58 (>= 7:4.0); aber:
    Paket libavcodec58:armhf ist noch nicht konfiguriert.
    motion hängt ab von libavdevice58 (>= 7:4.0); aber:
    Paket libavdevice58:armhf ist noch nicht konfiguriert.
    motion hängt ab von libavformat58 (>= 7:4.1); aber:
    Paket libavformat58:armhf ist noch nicht konfiguriert.

    dpkg: Fehler beim Bearbeiten des Paketes motion (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    php-zip (2:7.3+69) wird eingerichtet ...
    libsord-0-0:armhf (0.16.0~dfsg0-1+b1) wird eingerichtet ...
    php7.3-cli (7.3.19-1~deb10u1) wird eingerichtet ...
    update-alternatives: /usr/bin/php7.3 wird verwendet, um /usr/bin/php (php) im automatischen Modus bereitzustellen
    update-alternatives: /usr/bin/phar7.3 wird verwendet, um /usr/bin/phar (phar) im automatischen Modus bereitzustellen
    update-alternatives: /usr/bin/phar.phar7.3 wird verwendet, um /usr/bin/phar.phar (phar.phar) im automatischen Modus bereitzustellen

    Creating config file /etc/php/7.3/cli/php.ini with new version
    libsratom-0-0:armhf (0.6.0~dfsg0-1) wird eingerichtet ...
    libhtml-parser-perl (3.72-3+b2) wird eingerichtet ...
    xorgxrdp (1:0.2.9-1) wird eingerichtet ...
    libgcc-6-dev:armhf (6.5.0-1+rpi1+b1) wird eingerichtet ...
    libfcgi-perl (0.78-2+b2) wird eingerichtet ...
    libcurl4:armhf (7.64.0-4+deb10u1) wird eingerichtet ...
    libisccc161:armhf (1:9.11.5.P4+dfsg-5.1+deb10u2) wird eingerichtet ...
    libtext-soundex-perl (3.4-1+b6) wird eingerichtet ...
    php-gd (2:7.3+69) wird eingerichtet ...
    libclass-xsaccessor-perl (1.19-3+b6) wird eingerichtet ...
    curl (7.64.0-4+deb10u1) wird eingerichtet ...
    libterm-readkey-perl (2.38-1) wird eingerichtet ...
    libsdl2-2.0-0:armhf (2.0.9+dfsg1-1+rpt1) wird eingerichtet ...
    php7.3-curl (7.3.19-1~deb10u1) wird eingerichtet ...

    Creating config file /etc/php/7.3/mods-available/curl.ini with new version
    liblilv-0-0:armhf (0.24.2~dfsg0-2) wird eingerichtet ...
    libalgorithm-diff-xs-perl (0.04-5+b1) wird eingerichtet ...
    libdbi-perl:armhf (1.642-1+deb10u1) wird eingerichtet ...
    libnet-ssleay-perl (1.85-2+b1) wird eingerichtet ...
    libssh-gcrypt-4:armhf (0.8.7-1+deb10u1) wird eingerichtet ...
    libdns1104:armhf (1:9.11.5.P4+dfsg-5.1+deb10u2) wird eingerichtet ...
    libtirpc3:armhf (1.1.4-0.4) wird eingerichtet ...
    libxml-parser-perl (2.44-4) wird eingerichtet ...
    systemd-sysv (241-7~deb10u5+rpi1) wird eingerichtet ...
    librados2:armhf (12.2.11+dfsg1-2.1+rpi1) wird eingerichtet ...
    php-curl (2:7.3+69) wird eingerichtet ...
    libzmq5:armhf (4.3.1-4+deb10u2) wird eingerichtet ...
    libdynaloader-functions-perl (0.003-1) wird eingerichtet ...
    libref-util-xs-perl (0.117-1+b1) wird eingerichtet ...
    libfile-fcntllock-perl (0.22-3+b4) wird eingerichtet ...
    libclone-perl (0.41-1+b1) wird eingerichtet ...
    libsub-identify-perl (0.14-1+b1) wird eingerichtet ...
    php-bz2 (2:7.3+69) wird eingerichtet ...
    openssh-client (1:7.9p1-10+deb10u2) wird eingerichtet ...
    Neue Version der Konfigurationsdatei /etc/ssh/ssh_config wird installiert ...
    liblist-moreutils-perl (0.416-1+b3) wird eingerichtet ...
    libscalar-list-utils-perl (1:1.50-1+b1) wird eingerichtet ...
    libsocket-perl (2.029-1) wird eingerichtet ...
    libdevice-serialport-perl (1.04-3+b5) wird eingerichtet ...
    libpq5:armhf (11.9-0+deb10u1) wird eingerichtet ...
    libcommon-sense-perl (3.74-2+b18) wird eingerichtet ...
    samba-libs:armhf (2:4.9.5+dfsg-5+deb10u1+rpi1) wird eingerichtet ...
    libnss-systemd:armhf (241-7~deb10u5+rpi1) wird eingerichtet ...
    First installation detected...
    Checking NSS setup...
    libbareword-filehandles-perl (0.006-1+b1) wird eingerichtet ...
    libpadwalker-perl (2.3-1+b1) wird eingerichtet ...
    libpq-dev (11.9-0+deb10u1) wird eingerichtet ...
    libcurl3-gnutls:armhf (7.64.0-4+deb10u1) wird eingerichtet ...
    rpcbind (1.2.5-0.3+deb10u1) wird eingerichtet ...
    Neue Version der Konfigurationsdatei /etc/init.d/rpcbind wird installiert ...
    Removing obsolete conffile /etc/init/portmap-wait.conf ...
    Removing obsolete conffile /etc/init/rpcbind.conf ...
    Removing obsolete conffile /etc/init/rpcbind-boot.conf ...
    insserv: warning: current start runlevel(s) (empty) of script `rpcbind' overrides LSB defaults (S).
    insserv: warning: current stop runlevel(s) (S) of script `rpcbind' overrides LSB defaults (0 1 6).
    rename (1.10-1) wird eingerichtet ...
    apache2-bin (2.4.38-3+deb10u4) wird eingerichtet ...
    libdevel-callchecker-perl (0.008-1) wird eingerichtet ...
    libclass-c3-xs-perl (0.14-1+b3) wird eingerichtet ...
    libdevel-caller-perl (2.06-2+b1) wird eingerichtet ...
    libcephfs2:armhf (12.2.11+dfsg1-2.1+rpi1) wird eingerichtet ...
    libindirect-perl (0.38-1+b1) wird eingerichtet ...
    nfs-common (1:1.3.4-2.5+deb10u1) wird eingerichtet ...
    nfs-utils.service is a disabled or a static unit not running, not starting it.
    insserv: warning: current start runlevel(s) (empty) of script `nfs-common' overrides LSB defaults (S).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6 S) of script `nfs-common' overrides LSB defaults (0 1 6).
    libglusterfs0:armhf (5.5-3) wird eingerichtet ...
    libgssrpc4:armhf (1.17-3+deb10u1) wird eingerichtet ...
    libreadonly-perl (2.050-1) wird eingerichtet ...
    liblexical-sealrequirehints-perl (0.011-2+b1) wird eingerichtet ...
    libspecio-perl (0.43-1) wird eingerichtet ...
    libdevel-lexalias-perl (0.05-2+b1) wird eingerichtet ...
    libcurl4-openssl-dev:armhf (7.64.0-4+deb10u1) wird eingerichtet ...
    libmultidimensional-perl (0.014-1+b1) wird eingerichtet ...
    libstdc++-6-dev:armhf (6.5.0-1+rpi1+b1) wird eingerichtet ...
    libdbd-mysql-perl:armhf (4.050-2) wird eingerichtet ...
    git (1:2.20.1-2+deb10u3) wird eingerichtet ...
    libsmbclient:armhf (2:4.9.5+dfsg-5+deb10u1+rpi1) wird eingerichtet ...
    smbclient (2:4.9.5+dfsg-5+deb10u1+rpi1) wird eingerichtet ...
    php-cli (2:7.3+69) wird eingerichtet ...
    g++ (4:8.3.0-1+rpi2) wird eingerichtet ...
    gcc-6 (6.5.0-1+rpi1+b1) wird eingerichtet ...
    libkdb5-9:armhf (1.17-3+deb10u1) wird eingerichtet ...
    libpam-systemd:armhf (241-7~deb10u5+rpi1) wird eingerichtet ...
    cmake (3.13.4-1) wird eingerichtet ...
    build-essential (12.6) wird eingerichtet ...
    libdbd-sqlite3-perl:armhf (1.62-3) wird eingerichtet ...
    libisccfg163:armhf (1:9.11.5.P4+dfsg-5.1+deb10u2) wird eingerichtet ...
    libkadm5srv-mit11:armhf (1.17-3+deb10u1) wird eingerichtet ...
    samba-dsdb-modules:armhf (2:4.9.5+dfsg-5+deb10u1+rpi1) wird eingerichtet ...
    libio-socket-ssl-perl (2.060-3) wird eingerichtet ...
    libdatetime-perl:armhf (2:1.50-1+b1) wird eingerichtet ...
    libgfxdr0:armhf (5.5-3) wird eingerichtet ...
    libjson-xs-perl (3.040-1+b1) wird eingerichtet ...
    libkadm5clnt-mit11:armhf (1.17-3+deb10u1) wird eingerichtet ...
    openssh-sftp-server (1:7.9p1-10+deb10u2) wird eingerichtet ...
    openssh-server (1:7.9p1-10+deb10u2) wird eingerichtet ...
    Neue Version der Konfigurationsdatei /etc/init.d/ssh wird installiert ...
    Neue Version der Konfigurationsdatei /etc/ssh/moduli wird installiert ...
    Replacing config file /etc/ssh/sshd_config with new version
    rescue-ssh.target is a disabled or a static unit, not starting it.
    Removing obsolete conffile /etc/init/ssh.conf ...
    Removing obsolete conffile /etc/network/if-up.d/openssh-server ...
    python-samba (2:4.9.5+dfsg-5+deb10u1+rpi1) wird eingerichtet ...
    ^[[28~samba-vfs-modules:armhf (2:4.9.5+dfsg-5+deb10u1+rpi1) wird eingerichtet ...
    apache2 (2.4.38-3+deb10u4) wird eingerichtet ...
    Neue Version der Konfigurationsdatei /etc/apache2/mods-available/deflate.conf wird installiert ...
    Neue Version der Konfigurationsdatei /etc/apache2/mods-available/mime.conf wird installiert ...
    Neue Version der Konfigurationsdatei /etc/logrotate.d/apache2 wird installiert ...
    insserv: warning: current start runlevel(s) (empty) of script `apache-htcacheclean' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `apache-htcacheclean' overrides LSB defaults (0 1 6).
    libparams-classify-perl (0.015-1+b1) wird eingerichtet ...
    libbind9-161:armhf (1:9.11.5.P4+dfsg-5.1+deb10u2) wird eingerichtet ...
    libapache2-mod-php7.3 (7.3.19-1~deb10u1) wird eingerichtet ...

    Creating config file /etc/php/7.3/apache2/php.ini with new version
    libapache2-mod-php7.3: php5 module already enabled, not enabling PHP 7.3
    g++-6 (6.5.0-1+rpi1+b1) wird eingerichtet ...
    samba-common-bin (2:4.9.5+dfsg-5+deb10u1+rpi1) wird eingerichtet ...
    Checking smb.conf with testparm
    WARNING: The "syslog" option is deprecated
    Load smb config files from /etc/samba/smb.conf
    WARNING: The "syslog" option is deprecated
    Loaded services file OK.
    Server role: ROLE_STANDALONE

    Done
    bind9-host (1:9.11.5.P4+dfsg-5.1+deb10u2) wird eingerichtet ...
    libgfrpc0:armhf (5.5-3) wird eingerichtet ...
    samba (2:4.9.5+dfsg-5+deb10u1+rpi1) wird eingerichtet ...
    Neue Version der Konfigurationsdatei /etc/init.d/nmbd wird installiert ...
    Neue Version der Konfigurationsdatei /etc/init.d/samba-ad-dc wird installiert ...
    Neue Version der Konfigurationsdatei /etc/init.d/smbd wird installiert ...
    Neue Version der Konfigurationsdatei /etc/logrotate.d/samba wird installiert ...
    Samba is not being run as an AD Domain Controller: Masking samba-ad-dc.service
    Please ignore the following error about deb-systemd-helper not finding those services.
    (samba-ad-dc.service already masked)
    Removing obsolete conffile /etc/init.d/samba ...
    Removing obsolete conffile /etc/init/nmbd.conf ...
    Removing obsolete conffile /etc/init/reload-smbd.conf ...
    Removing obsolete conffile /etc/init/samba-ad-dc.conf ...
    Removing obsolete conffile /etc/init/smbd.conf ...
    Failed to preset unit: Unit file /etc/systemd/system/samba-ad-dc.service is masked.
    /usr/bin/deb-systemd-helper: error: systemctl preset failed on samba-ad-dc.service: No such file or directory
    krb5-multidev:armhf (1.17-3+deb10u1) wird eingerichtet ...
    ssh (1:7.9p1-10+deb10u2) wird eingerichtet ...
    php7.3 (7.3.19-1~deb10u1) wird eingerichtet ...
    libkrb5-dev:armhf (1.17-3+deb10u1) wird eingerichtet ...
    libgfapi0:armhf (5.5-3) wird eingerichtet ...
    php (2:7.3+69) wird eingerichtet ...
    Trigger für man-db (2.8.5-2) werden verarbeitet ...
    Trigger für dbus (1.12.20-0+deb10u1) werden verarbeitet ...
    Trigger für menu (2.1.47) werden verarbeitet ...
    default-mysql-client (1.0.5) wird eingerichtet ...
    Trigger für libc-bin (2.28-10+rpi1) werden verarbeitet ...
    Trigger für libapache2-mod-php7.0 (7.0.33-0+deb9u10) werden verarbeitet ...
    mariadb-server-10.3 (1:10.3.27-0+deb10u1) wird eingerichtet ...
    Neue Version der Konfigurationsdatei /etc/init.d/mysql wird installiert ...
    Neue Version der Konfigurationsdatei /etc/mysql/debian-start wird installiert ...
    Neue Version der Konfigurationsdatei /etc/mysql/mariadb.conf.d/50-server.cnf wird installiert ...
    default-mysql-server (1.0.5) wird eingerichtet ...
    Trigger für initramfs-tools (0.133+deb10u1) werden verarbeitet ...
    Trigger für systemd (241-7~deb10u5+rpi1) werden verarbeitet ...
    Fehler traten auf beim Bearbeiten von:
    raspberrypi-kernel
    raspberrypi-bootloader
    libraspberrypi0
    libavfilter7:armhf
    libavcodec58:armhf
    libchromaprint1:armhf
    libavformat58:armhf
    libavcodec-dev:armhf
    libavformat-dev:armhf
    libraspberrypi-doc
    libraspberrypi-bin
    libavdevice58:armhf
    libraspberrypi-dev
    motion
    ^[[28~E: Sub-process /usr/bin/dpkg returned an error code (1)

    pi@raspberrypi3 ~ $ ls -la /boot/*.tmp
    ls: Zugriff auf '/boot/*.tmp' nicht möglich: Datei oder Verzeichnis nicht gefunden