Wiederherstellung Win32Disk Image schlägt fehl - Karte neu erkannt

  • Hallo zusammen,


    ich habe aktuell ein Problem, welches sich irgendwie nicht lösen lassen will :conf:

    Ich habe ein Backup meiner SD Karte aus dem Raspberry Pi 4 gezogen und muss jetzt ein Backup wiederherstellen, da ich etwas Unsinn auf der Konsole gebaut habe.


    Nun versuche ich mittels Win32Disk Image (auch mit Belena Etcher getestet) das Image wiederherzustellen und scheitere leider.

    Auf der SD Karte wurden immer 2 Partitionen angezeigt. Eine Boot und eine weitere.

    Wenn ich nun wiederherstelle fängt erst alles gut an, aber dann erkennt Windows nach einer Weile die Karte neu und die Wiederherstellung bricht ab mit der Meldung, dass die Ressource nicht mehr verfügbar ist.

    Ich habe dir Karte vorher komplett formatiert und beide Partitionen entfernt.

    Egal mit welchem Programm ich vorgehe, so bricht jeweils die Wiederherstellung mit der gleichen Ursache ab.

    Kann ich das Image irgendwie sauber wiederherstellen, so dass beide Partitionen wieder vorhanden sind und am Ende wieder der Pi losrennt?


    Besten Dank im Voraus!

    shirocko

  • Ich tippe auf eine defekte µSD Karte. Hast Du eine weitere, mit der Du das probieren kannst?

    Ich glaube irgendwie es liegt daran, dass Windows plötzlich eine weitere Partition erkennt und dieser einen Laufwerksbuchstaben verpasst und damit der Prozess plötzlich unterbrochen wird.


    Ich habe noch weitere SD Karten, aber die aktuelle ist eine 256GB Karte und meine anderen sind 32 oder 64 GB.

    Die Belegung der Karte ist nicht all zu groß, aber ich weiß nicht, ob ich den Inhalt irgendwie runter shrinken kann und damit auch eine kleinere Karte funktioniert.

  • Ich glaube irgendwie es liegt daran, dass Windows plötzlich eine weitere Partition erkennt und dieser

    Nein, das wäre das erste Mal, dass ich so etwas sehen würde. Sowohl Win32Imager als auch etcher bekommen eine SD ohne Windows Unterbrechung fertiggeschrieben. Und das auch, wenn die Meldung erscheinen sollte (kenne ich jedoch nur von Win32Imager)


    irgendwie runter shrinken kann

    Das richtige Wort hast Du ja verwendet, mit pishrink geht das.

  • Hi.


    Ich konnte keine Lösung für das W32DI Problem finden, aber ich habe das Image mit PiShrink komprimiert auf 12 GB und nun auf einer 32 GB Karte mittels DD wieder hergestellt und nun läuft der Pi zum Glück wieder.


    Danke an alle!