Desktop Icons auf beiden Monitoren gleich

  • Moin und noch ein frohes neues Jahr.


    Bin neu hier und hab ein Frage zum Raspberry Pi 4 B.


    Hab zwei Monitore angeschlossen. Das funktioniert auch einwandfrei.

    Ich kann auch ein geöffnetes Fenster von einem Monitor zum Anderen schieben.


    Nur die Desktop Icons werden immer auf beiden Monitoren angezeigt. Wenn ich auf einem Desktop eine

    neue Datei erstelle, tauch diese auch auf dem zweiten auf.


    Hat vielleicht jemand eine Ahnung, woran das liegen könnte?


    Ich sag schon mal Danke!!


    Gruß

    Stephan

  • Möglicherweise kannst Du mit dem freedesktop OpenDesktop Programm Deine gewünschte Einstellung vornehmen. Das ist unter Pi-OS zwar installiert, muss aber erst zur Menüanzeige freigeschaltet werden.


    Servus !

    RTFM = Read The Factory Manual, oder so

    Edited once, last by RTFM ().

  • Ich habe genau dasselbe Problem und keine Lösung gefunden. Es muss aber eine geben, denn das ist ja völlig unsinnig, dass auf einem erweiterten Bildschirm (2 Monitore nebeneinander ) die Icons dupliziert werden. Das ist nur sinnvoll, wenn der erste Monitor auf den zweiten gespiegelt werden soll (also auf beiden dasselbe Bild).

  • Es muss aber eine geben, denn das ist ja völlig unsinnig, dass auf einem erweiterten Bildschirm (2 Monitore nebeneinander ) die Icons dupliziert werden.

    Guck mal hier rein und lies mal bis zum Ende. Ich glaube, das löst Dein Problem. (Testen kann ich das nicht, ich hab derzeit keine zwei Montore hier)

  • Danke für den Link (ja, ich habe bis zum Ende gelesen :-)). Aber das dort behandelte Problem ist ein anderes (Der erste Bildschirm wurde dort komplett auf den zweiten gespiegelt - also keine Desktop-Erweiterung).


    Bei mir funktioniert die Bildschirmerweiterung einwandfrei. Ich kann z.b. ein Fenster auf den zweiten Bildschirm verschieben oder erweitern. Es geht vielmehr darum, dass alle Icons (und nur diese) auch auf dem zweiten Bildschirm angezeigt werden, was ziemlich unsinnig ist.


    Ein Stück bin ich aber weitergekommen: Bei den Einstellungen für den zweiten Bildschirm (rechte Maustaste usw.) kann man (muss man) einen Ordner angeben, der auf dem zweiten Bildschirm gezeigt wird. Und das ist Default-mäßig der Desktop-Ordner. Leider fehlt eine Einstellung "None". Ich habe einen anderen Ordner gewählt (z.B. externer USB-Stick). Das Icon liegt jetzt oben in der Ecke und stört nicht so sehr. Nicht perfekt, aber man kann wohl damit leben.

  • Problem ist ein anderes

    Nein, das Problem ist genau das. Dann solltest Du noch einmal genau lesen. Nur zwischendrin wurde das Spiegeln testweise einmal aktiviert, nur um zu sehen, ob das darauf folgende Deaktivieren einen Erfolg bringt..

    rechte Maustaste

    Der entscheidende Hinweis lautete jedoch anders. Hast Du dies nachvolkzogen?

  • STF

    Sorry, mit allem Respekt, aber mir scheint, jetzt solltest Du mal genau lesen. Es geht nicht (!) darum, dass der gesamte Bildschirm gespiegelt wird. Genau das Problem hatte der User, auf den Du verweist (lies seinen ersten Beitrag genau durch). Und er fand keine Möglichkeit mehr, das zu deaktivieren. Damit habe ich überhaupt kein Problem. Ich kenne alle diese Einstellmöglichkeiten.


    Dagegen beschreibt der User in diesem Thread hier, an dem ich mich angehängt habe, sehr präzise das Problem: Ausschließlich die Desktop-Icons werden dupliziert. nicht die geöffneten Fenster. Und das liegt daran, dass in den Appearance Settings für den zweiten Bildschirm (HDMI2) zwingend ein "Desktop Folder" angegeben werden muss. Und der steht Default-mäßig auf "Desktop". Man kann zwar einen anderen Folder angegeben, aber komplett leer scheint man den erweiterten (!) zweiten Bildschirm nicht zu bekommen. Es sein denn, in irgendeiner config kann man was einstellen. Das ist hier aber nicht beschrieben. Übrigens: Wer keine zwei Bildschirme hat, kann das Problem natürlich nicht nachvollziehen.