Raspberry Pi 2, mögliche Probleme mit PiHole?

  • Hallo liebe Community,

    ich benötige Hilfe bei meinem kleinen Projekt. Ich selbst bin im Umgang mit dem Pi ziemlich neu...
    Gestern habe ich mir zum ersten mal PiHole installiert und es funktionierte ganz hervorragend. Bis ich ein paar Stunden später danach sehen wollte und mir dann auffiel, dass das Web Interface nicht erreichbar ist. Also dachte ich mir gucke ich mal was mit dem Pi ist und versuche es mit SSH... "Habe dabei nur: ssh: connect to host 192.168.3.109 port 22: No route to host" rausbekommen. Danach las ich im Internet das dies wohl ein Fehler sei bei dem ich ausersehen wohl den Port geöffnet hätte und ich nur noch neuinstallieren kann. Also hab ich alles platt gemacht und neu installiert. Leider hab ich dann wieder angefangen PiHole zu installieren und zack bevor ich überhaupt loslegen konnte war das WebInterface down und über SSH kommt wieder mal nur: "ssh: connect to host 192.168.3.109 port 22: No route to host". Dazu sei gesagt der Pi selbst ist immer noch in Betrieb... Die Power LED leuchtet und auf dem Bildschirm sieht alles normal aus.

    Es wäre Super wenn mir da jemand helfen könnte :danke_ATDE::bravo2:
    Kurz zur Hardware: Ich habe einen PI 2 geschenkt bekommen weiß aber nicht ganz welcher es genau ist und er läuft mit einem Digitus W-LAN Stick

  • Ich denke nicht das es so ist, weil ich hab es auch schon mit Reboot probiert und auch wenn ich einfach mal alles ausgesteckt und liegen lassen hab (um ein Problem von Überhitzung auszuschließen) hat es dennoch nicht funktioniert :shy: . Das mit dem LAN funktioniert leider nicht, da ich auf ein 2. W-LAN beschränkt bin und ich dann nicht mehr auf den PI zugreifen könnte.

    • Official Post

    Die Power LED leuchtet und auf dem Bildschirm sieht alles normal aus.

    Das heist ja, dass der RPi läuft. Wenn Du versuchst Dich mit der IP per SSH am RPi anzumelden, dann ist Pi-hole auch nicht im Spiel. Das wäre nur der Fall, wenn Du Dich per hostname verbinden wölltest. Ergo bleibt da imho nicht viel übrig ausser dem WLAN-Stick oder das Mysterium. Appropos Mysterium... Was für ein Netzteil verwendest Du und was hängt noch alles am RPi?

  • Das heist ja, dass der RPi läuft. Wenn Du versuchst Dich mit der IP per SSH am RPi anzumelden, dann ist Pi-hole auch nicht im Spiel. Das wäre nur der Fall, wenn Du Dich per hostname verbinden wölltest. Ergo bleibt da imho nicht viel übrig ausser dem WLAN-Stick oder das Mysterium. Appropos Mysterium... Was für ein Netzteil verwendest Du und was hängt noch alles am RPi?

    Hm ja ist sinnig...ich verwende das Aukuru Power BS-522 mit 5V und 2A Output (hab ich so dazu bekommen).

    Eigentlich hängt da nichts dran wie gesagt nur der W-LAN Stick und installiert ist normal PiHole was anderes läuft nicht drauf oder hängt dran ^^

    • Official Post

    Aukuru

    =O  <X:@


    SCNR!


    Damals TM gab es öfters Probleme mit diesen Netzteilen Ladegeräten, deshalb läuft mir jetzt noch beim Lesen dieses Wortes der kalte Schweiß den Rücken runter.

    Hast Du etwas anderes brauchbares griffbereit? Wobei das offizielle Netzteil mit ca. 11€ auch nicht besonders teuer ist. https://www.raspberrypi.org/pr…i-universal-power-supply/


    Das Netzteil wäre eine mögliche Fehlerquelle, das WLAN sollte aber auch nicht aus den Augen verloren werden..

  • Sorry für die Späte Antwort :D
    Ja hab ein anderes gefunden irgendein NoName Ding mit der gleichen Power... Aber iwi funktionierts immer noch nd. Vielleicht wirklich der WLAN Stick abgerauscht

  • Nachtrag dazu: Der WLAN Stick kann es schlecht sein... auf dem Bildschirm sehe ich ja das der PI sich selbst bei Neu aufgesetztem System eine IP vom Router holt...

  • ... auf dem Bildschirm sehe ich ja das der PI sich selbst bei Neu aufgesetztem System eine IP vom Router holt...

    Wie sind auf dem Bildschirm des PI, die Ausgaben von:

    Code
    ip a
    route -n
    arp -av

    ? Poste von dem Gerät auf dem Du den ssh-Client benutzt hast, die Ausgabe von:

    Code
    nc -zv 192.168.3.109 22

    Wenn Du im Router den Port geöffnet hast, hast Du vorher das Passwort für deinen PI geändert?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden