Raspberry Pi 4b hängt beim Erstboot in schwarzem Bildschirm

  • Da war leider auch das gleiche Fehlerbild.

    Hast Du evtl. einen Freund, der Linux auf seinem PC/Laptop benutzt?

    Oder bist Du evtl. in der Lage die eine Linux-Live-CD/DVD bzw. einen USB-Stick mit Linux (als OS) zu benutzen?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • ne virtuelle Maschine könnte ich aufsetzen wenn es nicht anders ginge. Geht sowas auch dafür? Vielleicht habe ich Montag einen alten Raspberry 2 zum zusätzlichen Testen.

  • ne virtuelle Maschine könnte ich aufsetzen wenn es nicht anders ginge. Geht sowas auch dafür?

    Ja, mit einer VM geht das auch. Damit kannst Du dd zum flashen benutzen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wenn sich das Problem weiterhin hartnäckig behauptet (--> total nervig), wäre es i.d.T. das einfachste einen zweiten Raspberry 4b zur Hilfe zu nehmen.

    Ich habe einen hier und wohne Dormagen ... natürlich weiß ich nicht, ob das Dir zufällig weiterhilft.

    Oder man geht hin, und legt das Image in einen Cloud Storage, was aber stark von Deiner Upload-Rate abhängt :gk1:

  • Hmm, wenn mit verschiedenen Images und unterschiedlichen Speicherkarten immer wieder das gleiche Problem auftritt, ist doch irgendetwas grundlegend defekt. Vielleicht der SD-Karten-Slot? Vielleicht wäre ein Versuch, über USB zu booten, lohnenswert?

  • ... irgendetwas grundlegend defekt. Vielleicht der SD-Karten-Slot?

    Nein, denn mit Noobs hat es ja funktioniert. Siehe Beitrag #12:

    Quote


    Das interessante ist ja, das ich auch Noobs probiert habe. Das ist alles ohne Probleme durchgelaufen, er hatte da sogar wlan.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ich hätte da noch die Idee mit einer defekten SD-Karte ...

    Ich hätte da eher noch die Idee eines defekten RPi. Das hatten wir ja erst letztens, der TE hat ewig tausend Dinge daran herumprobiert, um letztlich festzustellen, dass der umgetauschte Pi sofort das tat, was er sollte. Wenn etcher und der Pi Imager mit verify versagen, dann ist es extrem unwahrscheinlich, dass ein mit dd auf dieselbe SD geschriebenes Image das rausreißt. (Ich hab gelesen, dass Noobs bootete. Läßt sich das wiederholen? Und lief der Pi dann tatsächlich stabil?)


    Natürlich sollten tatsächlich alle Quellen für so einen kapitalen Fehler ausgeschlossen sein:


    - SD Karte steckt auch wirklich im dafür vorgesehehen Slot

    - SD Karte wurde erfolgreich beschrieben/verifiziert

    - Netzteil ist OK

    - weitere potente Verbraucher gibt es keine

    - Adapter zum Bildschirm funktionieren/ Bildschirm wird ootb vom Pi unterstützt

  • Läßt sich das wiederholen? Und lief der Pi dann tatsächlich stabil?)

    Wie ich das verstanden habe, lief die Installation von NOOBS einwandfrei, aber der anschließende Start des OS nicht mehr.

    Das ist alles ohne Probleme durchgelaufen, er hatte da sogar wlan. Nur nach der Installation, wenn er das eigentliche Betriebssystem starten soll, bleibt er immer an dem Punkt mit dem schwarzen Bildschirm

  • Wow, vielen dank für die vielen Vorschläge! ich war leider nicht mehr am Freitag, Samstag dazu gekommen an der Sache groß weiterzumachen. Der fehler ist aber auch wirklich kurios. Habe eine Möglichkeit gefunden, dass ich heute einen zweiten Raspberry Pi 4b testen konnte, um einen Fehler in meiner Peripherie, also Speicherkarte, Image, Netzteil, HDMI kabel oder gar Bildschirm ausschließen zu können.

    Mit dem zweiten Pi funktioniert alles einwandfrei. Ich muss also davon ausgehen, das der erste Pi defekt ist.
    Somit werde ich wohl probieren den umzutauschen.


    An dieser Stelle nochmal vielen DANK an EUCH. Ihr seid hier echt ein tolles super hilfsbereites Forum :)


    Viele Grüße