raspibackup: Reboot im Anschluss ausführen?

  • Hallo zusammen,


    ich habe raspibackup erfolgreich auf meinem pi (Debian) eingerichtet und es läuft an sich ohne Probleme.

    Allerdings arbeiten manche Programme nach dem Backup temporär nicht mehr. Ich vermute, dass liegt an der Reihenfolge in der ich die Dienst ab- und anschalte.

    Ich habe leider kaum Ahnung und dachte man könnte einfach raspiBackup.sh editieren und eine letzte Zeile mit sudo reboot hinzufügen - funktioniert leider nicht.

    Hat jemand einen Hinweis?


    Danke euch!  :)

  • Willkomen im Forum. Wie ich sehe hast Du meine FAQ38 gelesen ;)


    Ein Reboot nach dem Backup ist wirklich die allerletzte Moeglichkeit die Du waehlen sollltest. Besser ist die Ursache zu finden. Kannst Du mal folgende Informationen zur Verfuegung stellen:


    1) Mit der Option --systemstatus wird ins Debuglog eine Liste der aktiven Services ausgegeben. Zeige uns diese bitte.

    2) Zeige uns die beiden Zeilen aus /usr/local/etc/raspiBackup.conf

    Code
    # Durch && getrennte Befehle, die vor dem Starten des Backups auszuführen sind
    DEFAULT_STOPSERVICES=""
    # Durch && getrennte Befehle, die nach dem Starten des Backups auszuführen sind
    DEFAULT_STARTSERVICES=""

    3) Welche Services arbeiten bei Dir nach dem Backup nicht mehr?

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Danke, ja in der Tat! :)


    1) raspiBackup.sh --systemstatus



    2)


    Code
    DEFAULT_STOPSERVICES="systemctl stop hassio-apparmor && systemctl stop fail2ban && systemctl stop redis-server && systemctl stop apache2 && sys$
    
    DEFAULT_STARTSERVICES="systemctl start ufw && systemctl start docker && systemctl start cron && systemctl start hassio-supervisor && systemctl $


    3) Alle Dienste die Docker brauchen, also PiHole und HomeAssistant Supervised.

  • 1) raspiBackup.sh --systemstatus

    Dann musst Du ins Debuglog reinsehen und nach systemstatus suchen. Die dann folgende Liste von Services moechte ich gerne sehen. Aber vermutlich brauche ich diese Info nicht mehr (s.u.

    3) Alle Dienste die Docker brauchen, also PiHole und HomeAssistant Supervised.

    Pihole ist kein Systemd Service. Dzu musst Du die Datei /usr/local/etc/raspibackup.conf mit einem Editor manuell aendern. bei mir steht z.B. drin

    Code
    # commands to stop services before backup separated by &&
    DEFAULT_STOPSERVICES="pihole disable"
    # commands to start services after backup separated by &&
    DEFAULT_STARTSERVICES="pihole enable"

    ich denke das ist mit HomeAssistant Supervised auch so. Du musst klaeren mit welchen Kommandos der gestoppt und gestartet wird und diese Befehle ebenso in der Konfig eintragen. Also z.b.

    Code
    # commands to stop services before backup separated by &&
    DEFAULT_STOPSERVICES="pihole disable && homeAssistent --stop"
    # commands to start services after backup separated by &&
    DEFAULT_STARTSERVICES="homeAssistent --start && pihole enable"

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

  • Vielen Dank für die schnelle Antwort.

    Sorry, ich habe gesehen, dass in 2) der Rest abgeschnitten ist.

    PiHole müsste ich tatsächlich manuell ergänzen allerdings stoppe und starte ich Home Assistant bereits, laut raspiBackup-conf (hassio-apparmor + hassio-supervisor).


    Insofern wundere ich mich warum Home Assistant nicht läuft ..


    Code
    DEFAULT_STOPSERVICES="systemctl stop hassio-apparmor && systemctl stop fail2ban && systemctl stop redis-server && systemctl stop apache2 && systemctl stop mariadb && systemctl stop php7.3-fpm && systemctl stop smbd && systemctl stop ssh && systemctl stop hassio-supervisor && systemctl stop cron && systemctl stop docker && systemctl stop ufw"
  • ... allerdings stoppe und starte ich Home Assistant bereits, ...

    Das erfolgreiche Stoppen und Starten von Services kannst Du mit oder auch raspiBackup machen. Entweder -F benutzen bei raspiBackup oder einfach den gesamten Befehlsstring von STOPPSERVICES und STARTSERVICES als root ausfuehren und dann testen ob alles OK ist. Wenn Dein home assistant nicht richtig startet wuerde ich mal in den Logs von homeassisten nachsehen ob Du da Fehlermeldungen findest die Dir helfen die Ursache zu finden.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)