Bildausgabe an unterschiedlichen Geräten - Ein Gerät hat ein Bild, das Andere nicht

  • Hallo zusammen,


    habe mir vor ein paar Tagen einen RPi4 4GB gekauft und Kodi (Libreelec) darauf gepackt.

    Leider erhalte ich keine Bildausgabe, wenn ich den RPi an meinen Beamer anschließe, Epson EB-U42 mit 1920x1200 Auflösung.

    Wenn ich den RPi an meinen 4k Monitor anschließe, dann erhalte ich ein Bild.


    Der Beamer soll lt. Spezifikationen auch 1920x1080 Signale verarbeiten, leider sehe ich vom RPi nichts.

    Habe bereits im config.txt die Auflösung von 1920x1200 vorgeben, leider hat es nicht dazu geführt, dass ich ein Bild sehen konnte.


    Hat jemand eine Idee, woran es liegen könnte?

  • Rastaberry4Pi

    Changed the title of the thread from “Bildausgabe an unterschiedlichen Geräten” to “Bildausgabe an unterschiedlichen Geräten - Ein Gerät hat ein Bild, das Andere nicht”.
  • Wie ist der RPi 4 mit dem Projektor verbunden (HDMI?)? Wie sieht deine config.txt aus? Falls noch nicht gelesen: https://www.raspberrypi.org/do…ation/config-txt/video.md

    Am RPi4 ist ein Adapter von Micro HDMI auf HDMI angebracht und dann über ein HDMI Kabel an den Beamer angeschlossen.

    So sieht meine config.txt aus:


    # SPDX-License-Identifier: GPL-2.0-or-later

    # Copyright (C) 2009-2014 Stephan Raue (stephan@openelec.tv)

    # Copyright (C) 2016-present Team LibreELEC (https://libreelec.tv)

    ################################################################################

    # Bootloader configuration - config.txt

    ################################################################################


    ################################################################################

    # Memory (System/GPU configuration )

    ################################################################################


    # Default GPU memory split - at least 288M is needed for some 4k HEVC files

    gpu_mem=320


    ################################################################################

    # For overclocking and various other settings, see:

    # https://www.raspberrypi.org/do…nfiguration/config-txt.md

    ################################################################################

    # Set 'force_turbo=1' to disable dynamic overclocking and enable overclocking always.

    force_turbo=0


    # Force HDMI even if unplugged or powered off

    hdmi_force_hotplug=1

    hdmi_drive=2


    ################################################################################

    # Settings for 1920x1200

    # hdmi_group=2

    # hdmi_mode=69

    ################################################################################


    # Doesn't sent initial active source message.

    # Avoids bringing CEC (enabled TV) out of standby and channel switch when

    # rebooting.

    hdmi_ignore_cec_init=1


    ################################################################################

    # End of default configuration

    ################################################################################


    ################################################################################

    # Include distribution specific config file if it exists.

    ################################################################################

    [all]

    include distroconfig.txt




    Den Link werde ich mir mal ansehen.

    Gibt es denn eine Vermutung, woran es liegen könnte, da ich bereits die config.txt auf die Ausgabe 1920x1200 angepasst hatte, diese Einstellung hat leider nicht zum Erfolg geführt.

  • # hdmi_group=2

    # hdmi_mode=69

    da ich bereits die config.txt auf die Ausgabe 1920x1200 angepasst hatte,

    Wenn Du die "#" jeweils am Angang der Zeilen löschst, dann sind diese auch aktiv. Vorher passiert da gar nichts. Die Werte sind korrekt für 1920x1200. gpu_mem erscheint mir sehr hoch. Brauchst Du das wirklich?

  • Wenn Du die "#" jeweils am Angang der Zeilen löschst, dann sind diese auch aktiv. Vorher passiert da gar nichts. Die Werte sind korrekt für 1920x1200. gpu_mem erscheint mir sehr hoch. Brauchst Du das wirklich?

    Die Einstellungen mit


    # hdmi_group=2

    # hdmi_mode=69


    hatte ich ausprobiert und dann im Anschluss mit einer Raute versehen, da diese Einstellung nichts gebracht hatte und ich diese für drin gelassen habe, weil ich es ggf. noch brauchen könnte.

    Der gpu_mem Wert ist ein Default-Wert, den hatte ich nicht verändert. Warum meinst du, dass dieser zu hoch ist?

  • da diese Einstellung nichts gebracht hatte

    Wenn das Kabel zum Projektor funktioniert, dann sollte es ein Bild geben.

    - Wer ist der Hersteller und welchen Typ Projektor hast Du?

    - Wie lang ist das Kabel? Ist es direkt (HDMI) angeschlossen oder gibt es Adapter?


    Der gpu_mem Wert ist ein Default-Wert, den hatte ich nicht verändert. Warum meinst du, dass dieser zu hoch ist?

    Deshalb finde ich das. Also jetzt nicht direkt ich. Eher die Doku so.

  • Wenn das Kabel zum Projektor funktioniert, dann sollte es ein Bild geben.

    - Wer ist der Hersteller und welchen Typ Projektor hast Du?

    - Wie lang ist das Kabel? Ist es direkt (HDMI) angeschlossen oder gibt es Adapter?

    Ich habe zwei verschiedene Kabel getestet, eines ist 5m und das andere 2m lang, mit dem RPi4 funktioniert es nicht, wenn ich mein Notebook oder die Nintendo Switch mit diesen Kabeln an den Beamer anschließe dann kommt ein Bild. Daher schließe ich aus, dass es sich um ein Kabelproblem handelt.

    Ich habe einen Micro HDMI zu HDMI Adapter angeschlossen, diesen Adapter habe ich auch an einem 4k Monitor verwendet, da funktioniert es und ich habe ein Bild, nur am Beamer nicht.

    Beim Beamer ist von Epson, ein EB-U42.

  • Ich vermute, dass das Aushandeln des richtigen Bildschirmmodus nicht funktioniert. Kannst du am Notebook, oder der Switch den Bildschirmstatus ermitteln wenn angeschlossen? Am RPi geht das mit /opt/vc/bin/tvservice -s. Ansonsten würde ich ein paar andere Auflösungen testen. Im Link von oben ist eine Liste und auch sonst alles beschrieben. Die eine oder andere Option könnte man noch testen.

  • Ich vermute, dass das Aushandeln des richtigen Bildschirmmodus nicht funktioniert. Kannst du am Notebook, oder der Switch den Bildschirmstatus ermitteln wenn angeschlossen? Am RPi geht das mit /opt/vc/bin/tvservice -s. Ansonsten würde ich ein paar andere Auflösungen testen. Im Link von oben ist eine Liste und auch sonst alles beschrieben. Die eine oder andere Option könnte man noch testen.

    Danke für deinen Hinweis, werde ich mal ausprobieren und berichten :)

  • Ich vermute, dass das Aushandeln des richtigen Bildschirmmodus nicht funktioniert. Kannst du am Notebook, oder der Switch den Bildschirmstatus ermitteln wenn angeschlossen? Am RPi geht das mit /opt/vc/bin/tvservice -s. Ansonsten würde ich ein paar andere Auflösungen testen. Im Link von oben ist eine Liste und auch sonst alles beschrieben. Die eine oder andere Option könnte man noch testen.

    Bekomme folgende Rückmeldung vom RPi:


    state 0x120001 [TV is off]


    Am Notebook konnte ich den Bildschirmstatus nicht ermitteln?
    Wie geht das, an einem Windows 10 Rechner?

  • Am Notebook konnte ich den Bildschirmstatus nicht ermitteln?

    Wenns funktioniert, dann ist es unerheblich. Ich wüsste jetzt auf die Schnelle kein Programm.


    Du könntest probieren, die größtmögliche Anzahl originaler Einträge in Deiner config.txt herzustellen, den Projektor eingeschaltet, auf den korrekten Eingang geschaltet den RPi zu starten.

    hdmi_force_hotplug=1

    #hdmi_drive=2

    hdmi_group=2

    hdmi_mode=69

    #hdmi_ignore_cec_init=1

    Welche Einträge gibt es in dieser Datei? distroconfig.txt

  • Wenns funktioniert, dann ist es unerheblich. Ich wüsste jetzt auf die Schnelle kein Programm.


    Du könntest probieren, die größtmögliche Anzahl originaler Einträge in Deiner config.txt herzustellen, den Projektor eingeschaltet, auf den korrekten Eingang geschaltet den RPi zu starten.

    Welche Einträge gibt es in dieser Datei? distroconfig.txt

    Probiere ich direkt mal aus! :)

    Folgende Einträge sind in meiner distroconfig.txt:


    # SPDX-License-Identifier: GPL-2.0-or-later

    # Copyright (C) 2019-present Team LibreELEC (https://libreelec.tv)


    # WARNING: DO NOT EDIT THIS FILE - IT WILL BE OVERWRITTEN WHEN UPGRADING!

    dtoverlay=vc4-fkms-v3d

    disable_overscan=1

  • Es sollten eigentlich beide funktionieren, wo ist der Adapter am RPi angeschlossen? Links / HDMI0?


    Sonst hab ich jetzt auch keine Ideen mehr, warum es in dieser Konfiguration nicht gehen sollte. Viel mehr als doch einmal das Kabel/Adapter tauschen oder es mit einem Standard Pi OS zu probieren, fällt mir da erstmal nicht ein.

  • Es sollten eigentlich beide funktionieren, wo ist der Adapter am RPi angeschlossen? Links / HDMI0?


    Sonst hab ich jetzt auch keine Ideen mehr, warum es in dieser Konfiguration nicht gehen sollte. Viel mehr als doch einmal das Kabel/Adapter tauschen oder es mit einem Standard Pi OS zu probieren, fällt mir da erstmal nicht ein.

    Ja, ist links am HDMI0 angeschlossen, direkt neben dem USB-C Anschluss.

    Den Adapter und die HDMI Kabel hätte ich auch in Frage gestellt, wenn es mit diesen auch nicht am Monitor geklappt hätte.
    Am Monitor läuft alles einwandfrei, nur am Beamer ist kein Bild vorhanden.....

    Werde mal eine andere KODI Distribution ausprobieren, vielleicht hilft das ja.

    Danke für deine Unterstützung!! :D

  • Konnte dein Projektor nicht auf der Epson Seite finden, aber der wird vermutlich auch andere Auflösungen unterstützen. Das sollte in der Anleitung stehen. Auch unterstützte Frequenzen vergleichen. Wie schon geschrieben, dann verschiedene Einstellungen probieren. Vielleicht reicht auch schon die HDMI Spannung zu erhöhen. Wenn das alles nichts hilft, dann kann man noch "alle" Parameter einzeln setzen. Nachzulesen im Link aus Beitrag 2.

  • Konnte dein Projektor nicht auf der Epson Seite finden, aber der wird vermutlich auch andere Auflösungen unterstützen. Das sollte in der Anleitung stehen. Auch unterstützte Frequenzen vergleichen. Wie schon geschrieben, dann verschiedene Einstellungen probieren. Vielleicht reicht auch schon die HDMI Spannung zu erhöhen. Wenn das alles nichts hilft, dann kann man noch "alle" Parameter einzeln setzen. Nachzulesen im Link aus Beitrag 2.

    Lt. Anleitung kann der Projektor andere Auflösungen unterstützen, hatte auch mal den Safe-Mode ausprobiert, auch ohne Erfolg.
    Versuche mal die HDMI Spannung zu erhöhen....

  • Konnte dein Projektor nicht auf der Epson Seite finden, aber der wird vermutlich auch andere Auflösungen unterstützen. Das sollte in der Anleitung stehen. Auch unterstützte Frequenzen vergleichen. Wie schon geschrieben, dann verschiedene Einstellungen probieren. Vielleicht reicht auch schon die HDMI Spannung zu erhöhen. Wenn das alles nichts hilft, dann kann man noch "alle" Parameter einzeln setzen. Nachzulesen im Link aus Beitrag 2.

    Wie setze ich denn die HDMI Spannung herauf, über welchen Parameter geht es?
    Stehe gerade leider auf dem Schlauch....

  • Wie setze ich denn die HDMI Spannung herauf,

    Geht beim Pi4 nicht.

    Quote

    config_hdmi_boost

    Configures the signal strength of the HDMI interface. The minimum value is 0 and the maximum is 11.

    ....

    This option is ignored on the Raspberry Pi 4.

    Was mir gerade auffällt. Der richtige mode (1920x1080) für Deinen Projektor müsste nicht 69, sondern 68 sein.


    Abgesehen davon, kannst Du versuchen, alle Parameter selbst zu setzen. Im Link unter custom mode zu finden.