Hilfe!!! Remotedesktopverbindung geht nicht

  • Hallo Community,

    ich bin ziemlich frustriert : (

    Nachdem ich mein Passwort des Users pi geändert habe, kann ich mich via Remotedesktop zwar noch einloggen, danach erscheint aber einfach nur ein blauer Bildschirm.

    Was kann das Problem sein?

    Ich freue mich auf eure Antworten : )

    Vielen Dank.

  • Wow, ungeduldig nach nur 4,5h!?

    Ich kenne das Problem nicht, aber ich würde mich per SSH anmelden und das Password von Pi wieder zurücksetzen auf das vorherige.

    Wobei es mich überraschen würde, wenn die Passwordänderung die Ursache wäre.


    Gruss

  • Nachdem ich mein Passwort des Users pi geändert habe, kann ich mich via Remotedesktop zwar noch einloggen,

    Diese Annahme ist möglicherweise nicht richtig, wenn noch irgendwo am PC das alte Passwort hinterlegt ist.

    Schau mal in die Logfiles des Pi ( /var/log/syslog, /var/log/auth.log u.A.).


    Wird denn ein Remote Login auf der Textkonsole auch abgelehnt ?



    Servus !

    RTFM = Read The Factory Manual, oder so

  • Wird denn ein Remote Login auf der Textkonsole auch abgelehnt ?

    Komischerweise kann ich mich via Putty mit meinem neuen Passwort einloggen.

    Die Remotedesktopverbindung geht, wie auch die Anmeldung an meinem Bildschirm, nicht. : (

    Schau mal in die Logfiles des Pi ( /var/log/syslog, /var/log/auth.log u.A.).

    Was soll ich denn da machen?
    Bin noch ein Anfänger : )

  • was hast denn für nen sever auf dem rpi laufen

    realvnc ? xrdp ? oder was sonst ?

    :)

    Mhhhh... wenn ich das wüsste...

    Es hat eigentlich alles so schön funktioniert. Doch seit ich versucht habe einen Webserver mit Apache und PhP (programmiert mir Wordpress) zu erstellen ,geht gar nichts mehr.
    Kann es vllt daran liegen?

  • leonello565

    Logo kanns daran liegen

    Für sowas hat man ja auch immer eine kopie vom system auf ner ersatz SD

    oder wenigstens ein image gesichert

    kannst dich denn per ssh einloggen ?

    dann zeigt dir ps -ef nämlich welcher server da läuft und ob überhaupt

    vieleeicht hat der garnicht gestartet.

    ;)

  • Gestern habe ich im Tutorial nachgelesen und mir den TightVNC Server heruntergeladen und es hat auch geklappt : ) juhu

    Die Passworteingabe, die auch nicht funktioniert, habe ich mit

    Code
    sudo chown -R pi:pi /home/pi

    umgangen.

    Heute geht die Remoteverbindung allerdings schon wieder nicht....

    Bei der Eingabe der IP Adresse(natürlich mit Port 5901) auf dem TightVNC Viewer auf meinem Laptop leitet mich das Programm auf den Port 1 weiter, wo natürlich die Verbindung mit dem Raspberry nicht funktioniert.

    Hast du eine Idee an was das liegen könnte?

  • schätze mal das wird das hier sein

    https://www.elektronik-kompend…/raspberry-pi/2011021.htm

    oder du hast den tightVNC auf dem pi nicht gestartet

    mit ssh einloggen und mit ps -ef | grep vnc

    oder grep VNC

    weiss nicht mehr ob das gr od klein is

    Ausserdem hast du für den tightVNC ein passwort angegebn soviel ich weiss liegt da eine Datei in deinem home/pi verzeichnis. Das passwd brauchst du für die Verbindung von deinem vnc client zum pi

    und nicht das passwd von dem pi-user

    sonst steht alles in dem link den ich dir gegebn hab

    gibts bestimmt auch alles hier aber ich hatte kein bock zu suchen.

    könn dir die anderen hier bestimmt sagen.

    :)