Raspberry Pi 433MHz fehlerhaftes senden

  • Hallo,


    für ein bisschen automatisierung mit dem Raspberry möchte ich Funksteckdosen ansteuern. Aber wenn ich etwas wie folgt sende, meldet das revice Script andere Daten :huh:.


    Also ich sende (Script siehe: https://github.com/milaq/rpi-r…aster/scripts/rpi-rf_send)

    Bash
    $ python3 send.py -g 17 -p 101 -t 3 769612
    
    2021-03-04 20:20:27 - [INFO] send: 769612 [protocol: 3, pulselength: 101, length: default, repeat: 10]

    aber das receive Script meldet (nach 3 Versuchen) (Script siehe: https://github.com/milaq/rpi-r…er/scripts/rpi-rf_receive)

    Code
    2021-03-04 20:22:19 - [INFO] revice: 8 [pulselength 521, protocol 5]
    2021-03-04 20:22:22 - [INFO] revice: 32768 [pulselength 520, protocol 5]
    2021-03-04 20:22:25 - [INFO] revice: 524288 [pulselength 518, protocol 5]
    2021-03-04 20:22:25 - [INFO] revice: 4096 [pulselength 518, protocol 5]
    2021-03-04 20:22:27 - [INFO] revice: 561152 [pulselength 519, protocol 5]
    2021-03-04 20:22:28 - [INFO] revice: 1024 [pulselength 517, protocol 5]

    Das ganze läuft etwa wie hier gezeigt: https://www.youtube.com/watch?v=Xe5Bj_N4Crw


    Die Verkabelung sieht wie folgt aus:


    Woran könnte das liegen??? :/

  • Physik kaputt... Wenn du Signale um 20:20:27 schickst und die Ergebnisse um 20:22:19 empfangen werden, dann stimmt da was nicht :)


    Spaß beiseite: Wenn deine Verkabelung ok ist, ist vermutlich das Empfangsmodul Schrott. Der Typ definitiv. Ob dieses eine tatsächlich hinüber ist, lässt sich aus der Entfernung schwer sagen. Such mal nach superheterodynen Receivern. Habe mit RXB6 ganz gute Erfahrungen gemacht.

    Die Dinger, die du da hast, werden meist im Paar verkauft: Der Sender ist g'scheit genug, aber die Empfangsmodule kann man meist direkt in die Tonne hauen.


    Grüße

    ghmartin77

  • Ich hatte noch ein weiteres Sende Modul da, da funkioniert es "fast":


    Bash: senden
    $ python3 send.py -g 17 -p 101 -t 3 769612
    
    2021-03-05 07:38:49 - [INFO] send: 769612 [protocol: 3, pulselength: 101, length : default, repeat: 10]
    Bash: empfangen
    2021-03-05 07:38:49 - [INFO] revice: 48716 [pulselength 520, protocol 5]
    2021-03-05 07:38:49 - [INFO] revice: 721416 [pulselength 522, protocol 5]
    2021-03-05 07:38:49 - [INFO] revice: 769100 [pulselength 520, protocol 5]
    2021-03-05 07:38:49 - [INFO] revice: 769544 [pulselength 519, protocol 5]

    Ich hab allerdings noch keine Antenne dran gemacht an das 2. sende Modul.

  • Also mit Antenne läuft es auch nur fast. Das Protokoll ist irgendwie immer falsch (und Puls Länge auch):


    Bash: senden
    $ python3 send.py -g 17 -p 101 -t 3 769612
    
    2021-03-05 09:08:53 - [INFO] send: 769612 [protocol: 3, pulselength: 101, length: default, repeat: 10]
    Bash: empfangen
    2021-03-05 09:08:53 - [INFO] revice: 769612 [pulselength 515, protocol 5]