USB-WLAN Stick auf Pi2 unter Buster installieren geht nicht

  • Hallo Gemeinde

    Ich habe auf meinem Raspberry Pi 2 Model B Rev 1.1 die neueste Version buster 5.10.11-v7+ installiert und versuchen nun meinen Edimax USB Adapter EW-7811Un einzurichten. Die "alten" Methoden funktionieren nicht mehr. Ich habe einiges versucht, jedoch ohne Erfolg. Auch mit der graphischen Oberfläche lässt sich kein WLAN finden.

    Gibt es eine Lösung? Auf meinem Pi 4 (mit eingebautem WLAN) klappt das prima.

    Danke für eine Lösung.

    • Official Post

    Hallo Snowcobra,


    willkommen im Forum! ;)


    Die "alten" Methoden funktionieren nicht mehr. Ich habe einiges versucht, jedoch ohne Erfolg.

    Wenn Du mit den "alten" Methoden /etc/network/interfaces Datei meinst, dann gebe ich Dir recht. Was genau hast Du bereits erfolglos versucht?


    Folgendes (z.B.) auch? https://www.rogersteen.de/software-raspberry-pi.php?page=02

  • Welche Version hast du Installiert, eine mit Desktop oder eine Lite version ohne Desktop?

    Bei der Version mit Desktop, wird nach Einstecken der Stromversorgung UND vorher eingesteckter WLAN Karte, automatisch nach passenden WLAN Netzten gesuch werdent, nachdem das LAND, Tastaturlayout etc. ausgewählt ist.

    Es sollte aber KEIN LAN-Kabel gesteckt sein!

    Also nur der PI mit gesteckter WLAN-Karte, ohne LAN-Kabel an das Netzteil hängen und Starten.

    Am Besten vorher ein frisches Image auf die SD-Card ziehen.


    Ich habe es mit meinem Pi 2B mit einer frischen SD-Card und der WLAN-karte getestet, klappte sofort!

    Edited once, last by Thomas H ().

  • Besten Dank für die raschen Rückantworten. Ich habe die neueste Version mit Desktop installiert und danach sofort updates gemacht.

    Die Vorgehensweise nach der https://www.rogersteen.de/software-raspberry-pi.php?page=02 ist bei raspi-config (neueste Version) anders:

    Menu 2 sind Displayoptionen

    Menu 5 gibt’s L4 Wlan Country da erhalte ich die Meldung No wireless interface found, gefolgt von There was an error running option L4 WLAN Country


    Die wpa-Supplicant-Konfigurationsdatei habe ich gem. Vorgabe ausgeführt, jedoch ohne Erfolg. Ich sehe mit sudo lshw den WLAN-Stick

    *-usb:3 UNCLAIMED

    description: Generic USB device

    product: Edimax N150 Adapter

    vendor: Realtek

    physical id: 5

    bus info: usb@1:1.5

    version: 0.00

    serial: 08BEAC13C15C

    capabilities: usb-2.00

    configuration: maxpower=500mA speed=480Mbit/s


    aber nicht unter sudo ifconfit. Dort sehe ich nur eth0 und lo


    Nun habe die Edimax USB Adapter EW-7811Un durch eine Edimax USB-Adapter EW-7612UAN V2 ersetzt und siehe da... es läuft auf Anhieb. Ich kann ihn auch im Desktop finden und einstellen.


    In einer alten Konfig unter Wheezy läuft die EW-7811Un bestens.


    Evtl. habe ihr mir noch einen Tip um die EW-7811Un zum Laufen zu bringen.


    Danke und Gruss






    Mein neuester Versuch war die mit dem Editor nano bearbeiten:

  • Wie gesagt, der Edimax EW-7811Un hat einen Chipsatz, dessen Treiber im System bereits integriert ist!

    Da braucht man nichts Einstellen oder Installieren, oder in eine wpa-Supplicant eintragen, das macht das System Automatisch!

    Der EW-7811Un und der EW-7612UAN V2 gehören zu den wenigen WLAN Sticks, die vom System IMMER Automatisch erkannt werden, weil der Treiber dafür bereits im System implementiert ist!

    Der EW-7612UAN V2 ist übrigens ein 300MB/s Stick, der EW-7611 kann nur 150MB/s.

    Edited once, last by Thomas H ().

  • Danke für die Rückmeldung und sorry für den Zitat-Eintrag, der mir unerklärlich ist wie und warum der immer erscheint. Ich hoffe, das passiert nicht mehr. Sorry

  • Moin Snowcobra,


    und du bist dir sicher das der EW-7811Un auch erkannt wird?


    Zieh mal den Stick ab und starte in einem Terminal folgendes: journalctl -f.

    Nun den Stick einstecken und auf die Ausgabe schauen.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.