Raspi 3 B+ stört Router

  • Ich behaupte jetzt mal, wenn Du diese Installation (bzw. diese SD Karte), auf die ursprünglich benutzte SD klonst, ist der Fehler auch verschwunden.

    Warum? Das sind die Geheimnisse der Bits und Bytes...ich habe mir die Logs nicht angesehen, aber wenn ich lese was andere dort gefunen haben... :stumm:


    Gruss

  • Also liegt es an der anderen Karte?

    Schon mal den Router in Betracht gezogen? Selbst ein ammoklaufendes Gerät am Router, sollte diesen normalerweise nicht derart aus dem Tritt bringen, dass er die DSL Verbindung trennt.


    Lg

    Günther

    1. Raspberry Pi 4B / 4GB / Orig.Netzteil / Orig.Gehäuse. (uname: -v: 5.10.17-v7l+ #1414 SMP Fri Apr 30 13:20:47 BST 2021)

    2. Raspberry Pi 3B+ / Orig.Netzteil / 3,5" LCD Display. (uname: -v: 5.10.17-v7+ #1414 SMP Fri Apr 30 13:18:35 BST 2021)

    OS: Raspbian GNU/Linux 10 (buster)

  • Hmm naja der Router ist ein Leihgerät vom Anbieter. Ansonsten ist per LAN noch der TV und mein HTPC angeschlossen

    Hab mich wohl zu früh gefreut. Hab den Raspi jetzt am Desktop laufen lassen, und schon fingen wieder die Probleme an. Aber immerhin wurde die DSL Synchronisierung behalten.

    Werde es jetzt nochmal mit der cleanen SD Karte probieren, ob es da auch auftritt.

  • Hab den Raspi jetzt am Desktop laufen lassen, ...


    ... der cleanen SD Karte probieren, ...

    was genau meinst Du mit "den Raspi jetzt am Desktop laufen lassen" und mit "der cleanen SD Karte"?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Naja einfach nur eingeschalten laufen lassen. Ohne irgendwelchen offenen fenstern.

    Mit cleanen SD meinte ich die frische Raspi OS installation ohne welche änderungen.

  • Mit cleanen SD meinte ich die frische Raspi OS installation ohne welche änderungen.

    OK, _nach_ dem Test ohne Änderungen, teste auch mit folgenden Änderungen:

    Code
    dtparam=tx_lpi_timer=10000
    dtparam=eee=off

    in der /boot/config.txt (... aber Achtung nicht in der Section für PI4) und mit gleichzeitig deaktiviertem WLAN auf deinem PI3.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ohne irgendwelchen offenen fenstern.

    Ich weiß, das das jetzt gaaaanz weit hergeholt ist, aber wie weit sind Fritte und Monitor auseinander?

    Grund der Frage: ich hatte in den letzten Tagen ein gutes, altes UKW Radio direkt neben einem TFT -TV, den ich als Monitor nutze, Entfernung ca. 30-50cm.

    Je nach Fenster/Pop-Up, gab es derartige Störungen, das ein Empfang nicht mehr möglich war.

    Falls die Fritte also sehr nah am Monitor steht...?


    Gruss

    • Official Post

    Ich würde mittlerweile behaupten, dass die "alte" SD genau so funktioniert wie die cleane SD und es nichts damit zu tun hat. Den Unterschied macht vermutlich das Bewegen des RPi beim Kartenwechsel, bei dem der Lötspritzer oder das Kabelfragment oder der Kabelbruch seine Position verändert. :geek:


    Das ist hier mal eine echt harte Nuss, aber auch gleichermaßen spannend! :bravo2: Ich hoffe wirklich sehr, dass Du Prototyp206 dran bleibst bis der Fehler gefunden wird und nicht vorher schon aufgibst.

  • Hmm naja der Router ist ein Leihgerät vom Anbieter.

    Auch Leihgeräte können kaputt gehen. Selbst eine geliehene FritzBox ist kein Garant für eine unbegrenzte Lebensdauer.

    Aber immerhin wurde die DSL Synchronisierung behalten.

    Die DSL Synchronisierung ja, allerdings fand eine Geschwindigkeitsanpassung auf der DSL Seite statt (siehe Dein Bild). Diese Meldung allein sorgt schon für ein aufrichten meiner Nackenhaare.


    Kannst Du noch feststellen, was auf dem RPi genau zu dem Zeitpunkt der einzelnen Logeinträge von Deiner FritzBox passierte (Logfileausschnitte)?


    Und noch ein paar spezielle Fragen, die ich Dich bitte auch so präzise wie möglich zu beantworten:

    1. Welche FritzBox ist es?
    2. Welche Firmwareversion?
    3. DSL Anschluss über einen Splitter oder direkt an der TAE?
    4. Wie alt ist die TAE/DSL Dose ungefähr?
    5. DSL Kabel lose oder fest verlegt?
    6. Wie weit sind die FritzBox und der RPi voneinander entfernt?
    7. Welche Kabel der FritzBox und des RPi kreuzen sich eventuell bzw liegen nebeneinander?
    8. Was für Kabel verwendest Du bei LAN Verkabelung (deiner restlichen Geräte)
    9. Bei WLAN: 2,4 oder 5GHz? Welcher Kanal?
    10. Kannst Du mal ein 24h Protokoll der Fritzbox erstellen, ohne das der RPi eingeschaltet oder angeschlossen ist?

    Lg

    Günther

    1. Raspberry Pi 4B / 4GB / Orig.Netzteil / Orig.Gehäuse. (uname: -v: 5.10.17-v7l+ #1414 SMP Fri Apr 30 13:20:47 BST 2021)

    2. Raspberry Pi 3B+ / Orig.Netzteil / 3,5" LCD Display. (uname: -v: 5.10.17-v7+ #1414 SMP Fri Apr 30 13:18:35 BST 2021)

    OS: Raspbian GNU/Linux 10 (buster)

  • Wenn ich weiß, welches Logfile ich genau auslesen muss, ists kein Problem. Jedoch habe ich zum Zeitpunkt wo das Internet weg war, den Raspi nicht aktiv verwendet. Er hatte also eigentlich nichts zu tun, außer den Plex und Samba Server im Hintergrund laufen zu lassen.


    1. Fritzbox 7530

    2. Firmware 7.21

    3. Direkt an TAE

    4. Hmm, etwa 10-15 Jahre

    5. Lose

    6. Etwa 50 cm

    7. Hmm, das LAN Kabel vom TV, HTPC, HDMI zum TV, USB Kabel zur HDD, Netzteil zur HDD.

    8. CAT 6

    9. Nutze nur 5GHz, Kanal 44 (bin der einzige im 5GHz W-Lan)

    10. Ja kann ich.


    An einen Wackelkontakt habe ich auch schon gedacht, und alles bewegt was es gibt. Hat keinen Einfluss.
    Seit gestern Abend läuft der Raspi mit der Cleanen SD jedoch durch, ohne den Router gestört zu haben.

    Gerade jetzt höre ich über den Raspi auch Youtube Musikvideo, seit genau 15 Minuten. Keine Ausfälle derweil.

    Also doch ein Software Problem ?!?!

    Denn vom Setup (Verkabelung etc.) habe ich nichts geändert. Wie gesagt, nur die SD Karte getauscht. Die mit der cleanen Installation ist eine SanDisk mit 16GB und die andere eine Transcend mit 32GB.

  • Seit gestern Abend läuft der Raspi mit der Cleanen SD jedoch durch, ohne den Router gestört zu haben.

    Gerade jetzt höre ich über den Raspi auch Youtube Musikvideo, seit genau 15 Minuten. Keine Ausfälle derweil.

    Also doch ein Software Problem ?!?!

    Teste mal den PI und den Router, mit einem Download auf dem PI nach /dev/null, mit z. B.:

    Code
    wget -4 -c -O /dev/null http://speedtest.belwue.net/100G

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Download läuft seit ner Std. ohne Probleme mit ca. 5 MB/s

    Poste jetzt mal die Ausgaben von:

    Code
    ip a
    ethtool eth0

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Code
            Link partner advertised pause frame use: Symmetric Receive-only
            Link partner advertised auto-negotiation: Yes
            Link partner advertised FEC modes: Not reported
            Speed: 1000Mb/s
            Duplex: Full
            Port: MII
            PHYAD: 1
            Transceiver: internal
            Auto-negotiation: on

    OK, dann kannst den Download abbrechen mit strg C.

    Poste noch die Ausgabe von:

    Code
    ethtool -k eth0

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Code
    pi@raspberrypi:~ $ ethtool -k eth0
    Features for eth0:
    ...
    ...

    Diese Ausgaben (von "ethtool -k eth0") könntest Du mit den Ausgaben bei Benutzung der anderen SD-Karte (mit der Du das Problem hast), mal vergleichen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden