Raspi 3 B+ stört Router

  • Ist ein gratis Leih-router vom Anbieter. Aber Firmware & Co kann man selber updaten.

    Hardware-Beschleunigung oder Paketbeschleunigung finde ich nirgends. Auch in der Hilfe nicht.

    ABER seit Gestern ist die Fritzbox NICHT neu gestartet. Auch kein Ausfall vom Internet oder sonstigem. :bravo2:

    Was auch immer dieser Befehl gemacht hat, scheint funktioniert zu haben.

  • Hardware-Beschleunigung oder Paketbeschleunigung finde ich nirgends.

    Ist etwas versteckt.

    In der linken Seitenleiste ganz unten auf "Inhalt".




    Dann unten auf "Fritz Box Support"




    Folgende Einstellungen sind standardmässig eingestellt


  • Hardware-Beschleunigung oder Paketbeschleunigung finde ich nirgends. Auch in der Hilfe nicht.

    Was auch immer dieser Befehl gemacht hat, scheint funktioniert zu haben.

    Siehe in der FritzBox:

    Quote

    Im FritzBox-WEB-Interface links unten auf "Inhalt" klicken, dann runter scrollen und auf "FRITZ!Box Support" klicken und dort findest Du den Punkt Paketbeschleunigung.

    Bzgl. Befehl: https://www.kernel.org/doc/htm…egmentation-offloads.html

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • ... gefunden, beides ist aktiv.

    OK, wenn Du weiter Lust hast zu testen, dann deaktiviere temporär beides in der FritzBox und teste mit deinem PI3B+ (ohne den aktiven ethtool-Befehl).

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ja, kann ich machen, falls es irgendwie hilft? Werde bis morgen mal sehn, obs weiter so läuft.

    Irgendwo sollte was ja trotzdem nicht stimmen, da bei der frisch aufgesetzten sd karte es auch ohne diesem kommando geht.

  • Irgendwo sollte was ja trotzdem nicht stimmen, da bei der frisch aufgesetzten sd karte es auch ohne diesem kommando geht.

    Ja, aber dafür müsste man wissen welches Image das war, das Du auf die alte SD-Karte geflasht hast.

    ich denke es ist ein Hardware- und ein Software-Problem mit dem PI3B+ und ein Problem mit der FritzBox, weil sie rebootet.


    EDIT:


    Hast Du die Möglichkeit, deinen PI3B+ mit der alten SD-Karte, an einer anderen FritzBox (z. B. bei einem Freund) bzw. an einem anderen Internetanschluss zu testen?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited 2 times, last by rpi444 ().

  • Naja, 2x das gleiche:

    OK, dann kann es ja nur der Unterschied in der Konfiguration bzw. die zusätzlich installierte Software, zwischen alter und neuer SD-Karte, sein.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Okey, dann teste ich dass mal am Wochenende.
    Derzeit gabs noch immer keine Probleme.

    Mal sehn, ob ich in der Zwischenzeit das Passwort geändert bekomme :conf::lol:

  • sudo raspi-config

  • Funktioniert nicht.

    Teste mal ob Du auf deinem PI (alte SD-Karte) einen neuen user anlegen kannst und wenn ja, ob dessen Passwort übernommen wird (d. h. persistent ist).

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ja, konnte einen neuen User anlegen, und mich mit dessen Passwort auch per SSH anmelden nach einem Neustart.
    Aber das Passwort von Pi war schon wieder weg. :conf:


    Achja, der Router läuft noch immer ohne Probleme. :bravo2: Sobald ich zeit habe, teste ich mal dass mit der Paketbeschleunigung abschalten. :^^:

  • Schön langsam geht mir dieser Raspberry echt auf die nerven. :wallbash:

    Da ich ihn wegen dem neuen Benutzer anlegen neu gestartet habe, ist der Router schon wieder innerhalb von 15 Minuten 3x gecrasht.

    Und dass obwohl in /etc/rc.local der Befehl drin ist:
    #!/bin/sh -e

    /opt/P4rvt1gw

    /sbin/ethtool -K eth0 rx off tx off sg off gso off gro off

    exit 0


    Habe dann auch im Router die Paketbeschleunigung abgeschalten. Hat nichst verändert, ist trotzdem gecrasht. Die Paketbeschleunigung aktiviert sich dann nach Neustart von selbst wieder, soweit ich gesehen hab.

    Habe jetzt den ethtool Befehl wieder über die Kommandozeile eingegeben, hoffe es läuft wieder Problemlos weiter.

    Eine direkter Fehler in e2fsck wird glaube ich nicht gelistet.

    Naja gute Nacht mal fürs erste ...

  • Da ich ihn wegen dem neuen Benutzer anlegen neu gestartet habe, ist der Router schon wieder innerhalb von 15 Minuten 3x gecrasht.

    Und dass obwohl in /etc/rc.local der Befehl drin ist:

    /sbin/ethtool -K eth0 rx off tx off sg off gso off gro off

    BTW: Es könnte auch sein, dass nach dem reboot der Befehl nicht wirksam werden könnte, weil das eth0-Interface vielleicht noch nicht zur Verfügung gestanden hat.

    Wenn man es genau machen will, sollte man eine service-unit und eine timer-unit schreiben, die z. B. ca. 30 Sekunden _nach dem Booten_, prüft ob das eth0-Interface vorhanden ist und wenn ja, erst danach den Befehl mit ethtool ausführt.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • e2fsck von #116 weist auf ein korruptes Filesystem hin, das im Bootprozess nicht mehr automatisch repariert werden kann.

    Im /var/log/syslog sollte auch Hinweis enthalten sein, mit der Aufforderung "run fsck manually".


    Servus !

    RTFM = Read The Factory Manual, oder so

    Edited once, last by RTFM ().