LibreELEC / Kodi 18.9 auf Raspberry 3B+ nicht genügend Ressourcen(?)

  • Moin Moin Ich komme direkt gleich auf den Punkt:


    Ich habe seit über einer Woche das neue LibreELEC 9.2.6 / KODI 18.9 auf einem Raspberry 3B+ installiert. Meine Bibliothek liegt auf einem NAS Server. Das läuft auch alles soweit wie gewohnt.

    Das Problem, nicht alle Videos laufen durchgehend. Viele stürzen einfach bei der Wiedergabe ab und KODI braucht ewig um zu reagieren. Wenn gar nichts mehr geht, und das kommt sehr sehr oft vor, muss ich Hard resetten. Bei dem x.265er Codec kann ich es ja noch nachvollziehen, dass nicht jeder Encode reibungslos läuft ist klar, da der Raspberry ja nicht auf x.265er ausgelegt ist.

    Aber selbst bei einigen SD Formaten, die den x.264 besitzen, bleiben einfach stehen oder bricht die Wiedergabe einfach plötzlich ab.

    Die meisten Videos sind aber in 1080p.

    Wobei ich sagen muss, bei KODI 17.x lief alles bestens. Selbst meine stärksten x265 Encodes mit 10bit liefen reibungslos auf dem RPi 3B+...

    Aber seit dem ich Kodi 18 hab, fallen mir schwere Performance Probleme auf.

    Auch hab ich gelesen, dass KODI 18 bessere Performance für x.265 bieten soll..

    Bei mir leider Fehlanzeige.

    Meine halbe Bibliothek besteht aus 265er Encodes. Alle liefen perfekt.

    Jetzt geht die Hälfte meiner Sammlung nicht mehr :(


    Das geilste ist auch, es wird nicht mal die ganze Leistung des CPUs genutzt, was ich überhaupt nicht nachvollziehen kann. So wie auch beim Arbeitsspeicher.


    Full HD - x.264 - CPU Auslastung: 8-29%

    Speicher: 54%


    Full HD - x.265 - CPU Auslastung: 17-40%

    Speicher:58%


    Bestes Beispiel, und hier ist es am ausgeprägtesten; Das PLEX Plugin.

    Auch hier gingen alle Videos auf KODI 17.x.

    Und jetzt heißt es bei jeder x265er Datei:

    Transcoding unmöglich, nicht genügend CPU Ressourcen..

    Aber das System hat immer mehr und mehr zu kämpfen, obwohl da eigtl genügend Ressourcen zur Verfügung stehen, die eigtl genutzt werden könnten. Passiert aber nicht.


    Und ich habe auch das Gefühl, dass es mit jedem Update schlimmer wird/wurde.


    Auch mehrmaliges neuinstallieren bringt leider nichts. Immer das gleiche verhalten mit den Videos und der CPU


    Ich bin mittlerweile soo frustriert, weil es anscheinend (Achtung, ich verallgemeiner es jetzt und muss mich kurz auskotzen) den Entwicklern auch scheißegal ist, ob ein System richtig läuft oder nicht..

    Sowas kenn ich eigtl nur von Großkonzernen:

    Erschaffen und kaputtentwickeln.

    Sorry dass ich das sagen muss. Aber ich hab nur solche Probleme auf sämtlichen Systemen, Programme, und Spiele... Gravierend und unnötig

    Da steckt einfach keine Leidenschaft mehr drin. Kein Herz und auch keine Seele mehr.

    Hauptsache da ist irgendwas neues "cooles", aber NIE wird was zu Ende entwickelt oder fertiggestellt.. oder gar getestet..

    Hätte mir aber nie denken können, dass es jetzt auch in der Free-Software angekommen ist.


    Wenn die neuen Versionen nicht mehr auf älteren Systemen laufen (sollen), warum die neuen Updates überhaupt noch für spezielle Systemen veröffentlichen und sich die Mühe machen?!?!?

    Testen die ihre eigene Software überhaupt noch oder ist es schon wie bei EA?! Hauptsache da ist irgendwas, egal ob es läuft oder nicht..

    Bin wirklich von dieser Art von Schlamperei echt müde und erschöpft.

    Denn.Jedes.Mal.Muss.Man.Nachfragen.

    Wie und Warum das so ist.. und was man da machen kann..

    Und man bekommt dann nur halbwegs gute oder total unnötige Antworten.

    Möchte ungern jemanden auf die Füße treten, möchte einfach nur als Enduser meine eigenen Aufnahmen flüssig genießen können, ohne sich immer den Kopf zu zermatern, warum aus dem Nichts irgendwas nicht richtig funktioniert oder andauernd abkackt.

    An Fehlermeldungen, die genauesten beschrieben werden, mangelt es extrem.

    Nur ein Log-File der einem selbst nicht weiterhilft.


    Was mich aber noch mehr verwundert ist, warum hat das Team von LibreELEC für den RPi 3B+ keine eigenständige Version parat, statt das RPi2.arm Image?


    Ich liebe KODI aber es entwickelt sich immer mehr zum Hass, je mehr sich das entwickelt.

    Denn einzig wo ich KODI vollkommen nutzen kann ist am PC :(


    So.. ich hab mich jetzt auch genug aufgeregt und ausgekotzt.

    Hoffe, dass ich niemanden mit meiner harten Kritik nicht persönlich angegriffen habe.

    Und wenn entschuldige ich mich wirklich aufrichtig im vorraus.

    Aber ich musste es einfach mal rauslassen!


    Nur eine letzte Frage:

    Was ist sinnvoller, abwarten bis KODI 19 für den RPi rauskommt und hoffen dass sich die Performance verbessert oder sollte ich doch ein downgrade auf die ersten der 17er Versionen machen, wo alles Hand in Hand ging?


    Danke fürs lesen und für die eventuelle Hilfe.

    Und ich bitte noch mals um Entschuldigung, für meine raue Art!


    Mit diesen Worten wünsche euch trotz alle dem einen schönen Sonntag und einen guten Start in den Tag.


    Cornelius

  • Moin und Willkommen im Forum,

    Klingt zwar "doof" und bringt Dich in keinster weise Vorwärts, aber wenn es unter der 17er Version reibungslos läuft

    würde ich diese Version nutzen.

    Ich kenne sowas von einer Warenwirtschaftssoftware (die ich seit 2012 nutze), neues Update rausgebracht, alle stürzen sich drauf und dann liest man im Forum dazu alle möglichen Fehlermeldungen. Deshalb warte ich immer bei neuen Dingen/Updates, eine gewisse Zeit ab bevor ich irgendwas Update.


    Zu dem Problem allgemein kann ich nicht viel Beitragen, ich nutze zwar die 18er Version aber Hauptsächlich für Muzik (mp3) und damit bin ich Zufrieden. Filme schaue ich nicht außer mal nen Muzikvideo oder Konzertmitschnitt und das stelle ich kein solches Verhalten fest wie im ersten Beitrag beschrieben.


    Mfg.

    ~*~ Es tat NiVEA als beim ersten Mal ~*~