tx und rx Serial

  • Ich wollte auf dem Raspi 4 die Serielle Schnittstelle rx und tx ( BCM 14 und 15) freigeben, dafür habe ich folgende Einträge in der /boot/config.txt gemacht:

    Code
    enable_uart=1
    dtoverlay=disable-bt
    dtoverlay=uart0,txd0_pin=14
    dtoverlay=uart0,rxd0_pin=15

    Leider gibt es beim Auslesen ("/dev/ttyAMA0") wirres Zeug aus.

    Bei dem Raspi 2 hat es wunderbar funktioniert.

    Jetzt die allgemeine Frage, wie steuert man die Serielle Schnittstelle tx und rx (BCM 14 und 15) beim Raspi 4 richtig an?

  • wie es im /boot/overlays/README steht

    Ja das sollte doch der Abschnitt sein:

    Code
    Name:   uart0
    Info:   Change the pin usage of uart0
    Load:   dtoverlay=uart0,<param>=<val>
    Params: txd0_pin                GPIO pin for TXD0 (14, 32 or 36 - default 14)
    
            rxd0_pin                GPIO pin for RXD0 (15, 33 or 37 - default 15)
    
            pin_func                Alternative pin function - 4(Alt0) for 14&15,
                                    7(Alt3) for 32&33, 6(Alt2) for 36&37

    Nur habe ich es ja so konfiguriert,

  • enable_uart=1 gibt es bei mir nicht (mehr).

    Beachte auch <The base DTB > im README,

    Name: disable-bt samt N.B.


    Servus !

    RTFM = Read The Factory Manual, oder so

    Edited once, last by RTFM ().

  • Code
    sudo systemctl disable hciuart

    habe ich ausgeführt und

    Code
    dtoverlay=disable-bt

    habe ich in der config.txt eingetrgen (natürlich anschl. reboot durchgeführt).

    Hat alles nichts gebracht.

    Mein relaise ist:

    Code
    cat /etc/os-release
    PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="10"
    VERSION="10 (buster)"
    VERSION_CODENAME=buster


    Edit: original sollte die Ausgabe des Serials's es so aussehen (auf dem pi 2):

    2 v=3060&c=147&t=1980&h=0&f=1&sy=1&rssi=-445&fo=5310&be=0

    aber die Ausgabe auf dem Pi 4 sieht so aus:

    =3036&c=205&t=252&h=50&f=1&sy=&rssi=-510&fo=55&be=0


    also stimmt hinten und vorne nicht, ich habe noch etwas über die Takt-Frequenz gelesen... das man da etwas machen muss(?)

    Hier geht es nicht um die exakten Werte wie "t=1980" sondern das auch einfach Zahlen fehlen.

    Edited 2 times, last by matze1 ().

  • Also das mit dem "Serial read" lasse ich mal lieber, die Ursachen scheinen etwas tiefgründiger zu sein, ich habe mal zu Testzwecken in der config.tx

    das

    Code
    core_freq=250

    eingetragen, das brachte etwas Besserung, aber keine wesentliche.

    Ich betreibe es jetzt mit einen FTDI USB Adapter, das funktioniert wenigstens.