VLC-Player startet nach 58 Sek. den rtsp-Stream neu

  • Hallo,


    ich bin neu hier Forum. Ich habe bereits nach rtsp bzw. Stream gesucht. Bin aber nicht fündig geworden. Ich bin ziemlicher Anfänger in Sachen Raspberry Pi und Linux. Ich hatte bisher aber eine Lösung, die funktioniert hat. Jetzt plötzlich funktioniert es leider nicht mehr und ich weiß nicht woran es liegen könnte. Ich hoffe daher auf eure Hlfe.


    Ich habe mehrere Pi Zero W zusammen mit der PiCam im Einsatz, um meine Terrarientiere im RTSP-Stream beobachten zu können. Diese zeige ich mir mit dem VLC-Player an.

    Vor 2 Tagen habe ich einen neuen Pi Zero W fertig gemacht, um wie gewohnt das Kamerabild zu streamen. Leider läd der VLC-Player den Stream nach 56 Sekunden neu. So als hätte man den VLC-Player gerade erst gestartet. Kurzer schwarzer Bildschirm. Der Dateiname (in meinem Fall die RTSP-Quelle) wird eingeblendet. Wenn das Fenster vorher in der Taskleiste minimiert war, kommt es wieder an die letzet Position mit der letzten Fenstergröße zurück. Insgesamt sehr störend. Dasselbe bei einem bisher funktionierenden Zero W, der plötzlich hängen geblieben ist. Habe ebenfalls alles neue eingerichtet und jetzt plötzlich dasselbe Problem.


    Ich starte die Streams auf den Pis mit folgendem Befehl:

    raspivid -o - -t 0 -n -w 960 -h 540 -fps 15 -rot 180 | cvlc -vvv stream:///dev/stdin --sout '#rtp{sdp=rtsp://:8000/}' :demux=h264 --h264-fps=15


    OS auf den Zeros ist bei allen buster (Raspbian GNU/Linux 10). Der Kernel hat sich allerdings geändert. Beim funktinierenden ist es:

    Linux 5.4.72+

    Bei den neu eingerichteten und jetzt nicht mehr funktionierenden beiden ist der Kernel:

    Linux 5.10.17+


    ich habe den Kernel mit dem Befehl hosnamectl herausgefunden. Andere Unterschiede sehe ich über diesen Befehl nicht.


    In der Konsole der nicht funktionierenden Zeros wird alle paar Sekunden folgende Meldung ausgegeben:

    [0074f570] pulse audio output debug: changing sink 0: auto_null (Dummy Output)


    das passiert 12x.

    Dann kommt folgende Meldung:

    [b3a06b18] main stream out debug: net: connecting to [192.168.0.95]:65304

    [b3a06b18] main stream out debug: net: connecting to [192.168.0.95]:65305 from [192.168.0.122]:44244


    192.168.0.95 ist die IPv4-Adresse des empfangenden Notebooks (Windows 10).

    192.168.0.122 ist die IPv4-Adresse des sendenden Pi Zero W.


    dann wieder 12x die Meldung von oben und dann wieder eine ähnliche Meldung:

    [b3a06b18] main stream out debug: net: connecting to [192.168.0.95]:63642

    [b3a06b18] main stream out debug: net: connecting to [192.168.0.95]:63643 from [ 192.168.0.122]:52654


    Wechselt er den Port? Warum? Hat das mit dem nicht funktionierenden Audio Output zu tun? Wie kann ich das unterbinden?


    Entschuldigt bitte den langen Post. Aber ich bin nicht sicher was relevant ist und was nicht.


    Viele Grüße

    Gastuevian

  • Dann schalte einmal im VLC Player Audio auf OFF, oder hast Du im Terrarium auch ein Mikrofon, um die Tiere abzuhören ?


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Danke für deine Antwort.


    Ich habe kein Mikrofon. Von daher benötige ich tatsächlich keinen Ton.


    Hast du mir dafür nen Befehl, damit ich nur Bild streamen kann? Wenn ich den VLC-Player mute, ändert sich leider nichts.

  • Ich hab Raspbian lite aufgesetzt. Hier kommt die Meldung

    [0074f570] pulse audio output debug: changing sink 0: auto_null (Dummy Output)

    nicht.

    Trotzdem kommt nach ca. 1min30sek (also jetzt plötzlich ein längerer Zeitraum) diese Meldung

    [b3a06b18] main stream out debug: net: connecting to [192.168.0.95]:63642

    [b3a06b18] main stream out debug: net: connecting to [192.168.0.95]:63643 from [ 192.168.0.122]:52654

    Dies führt beim VLC-Player zu einem Neustart.

    Jemand eine Idee warum die Ports gewechselt werden?