USB Arcade-Controller Probleme

  • Hallo!ich habe mir folgenden USB-Arcade-Controller bestellt und korrekt verkabelt.


    http://www.ultracabs.co.uk/usb…ct-joystick-set-110-p.asp


    Das ganze per Retropie eingebunden.Soweit ok.Aber beim ersten Aufruf von retropie erkennt er bei BEIDEN joysticks nur die bewegungen "runter" und "rechts".Oben und links wird bei beiden Joysticks nicht erkannt.alle anderen bewegungen und buttons funktionieren einwandfrei.ich schliesse somit eine fehlerhafte verkabelung aus und habe auch alles 10mal überprüft.:mad_GREEN: wo könnte das problem liegen?


    wäre euch für sämtliche lösungsvorschläge sehr dankbar!:D



    EDIT: Bin mal auf die glorreiche idee gekommen das ganze Interface mal am Windows PC laufen zu lassen mit nem SNES Emulator.Da läuft alles TOP!Muss also an der Software des Raspberry liegen (Treiber?Retropie?) Hat da einer ne idee?

  • so.bin jetzt schon ne ecke weiter.ist ein bekanntes problem.liegt am treiber.für alle die mal das gleiche problem haben sollten:


    http://ithink.ch/blog/2013/09/…er_on_a_raspberry_pi.html


    leider habe ich nach der ganzen prozedur ein neues problem:das usb interface wird nicht mehr erkannt und da ich leider ein absolter noob auf diesem gebiet bin wollte ich euch jetzt nochmal um hilfe bitten.beim booten habe ich mehrer fehler (siehe bild) könnt ihr damit was anfangen?


    800x600

  • so.nachdem ich das ganze nochmal kompiliert habe läufts endlich!:bravo2::D kann jedem nur empfehlen der auf dem gebiet linux neu ist, das ganze per copy and paste über putty zu machen...hatte beim ersten anlauf anscheinend tippfehler drin oder was auch immer...trotzdem vielen dank!

  • Das scheint ja eine feine Lösung für mich zu sein. Ich möchte ebenfalls Arcade Joysticks / -Buttons am Raspberry betreiben. Erkennen die Emulatoren denn auch beide Joysticks und alle Buttons? Also ich meine nicht nur Mame sondern die MD / SNES / AMIGA Emulatoren unter RetroPie?