Kein Zugriff auf RPi3B

  • Hallo,

    einige Wochen habe ich meinen RPi3 in meinem WLAN-Netzwerk in Betrieb. Ich hatte das Octoprint image auf der SD-Karte installiert. Von einem auf den anderen Moment war er nicht mehr erreichbar.

    Ich habe jetzt auf die SD-Karte mit etcher das image nochmal neu geflasht. Aber mein Pi ist weder im LAN, WLAN oder SSH (PuTTY) erreichbar.


    Ist der raspberry nun defekt? Kann mir vielleicht jemand weiterhelfen?


    Danke!

  • ... das Octoprint image auf der SD-Karte installiert. ...


    Ist der raspberry nun defekt?

    Ob der PI defekt ist, könntest Du mit einem aktuellen RasperryPI-OS-lite-Image (statt dem Octoprint-Image) testen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hallo rpi444,


    kannst du mir bitte etwas mehr dazu sagen? Das RasperryPI-OS-lite ist doch ein Betriebssystem. Muss ich dann Tastatur und Bildschirm an den Pi anschliessen? oder wie äussert sich dann, ob der PI noch funktioniert?

  • Muss ich dann Tastatur und Bildschirm an den Pi anschliessen?

    Nicht zwingend. Man kann ssh und WLAN auch für die Nutzung ohne Bildschirm und Tastatur konfigurieren.

    Siehe z. B.:

    https://www.raspberrypi.org/do…tion/wireless/headless.md


    https://www.raspberrypi.org/do…mote-access/ssh/README.md

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hallo,


    habe das RPI-OS-lite-Image auf die SD-Karte geflasht. Leider mit dem selben Ergebnis. Weder LAN, WLAN noch SSH-Verbindung möglich. Was kann ich noch versuchen?


    AxelH

  • habe das RPI-OS-lite-Image auf die SD-Karte geflasht. Leider mit dem selben Ergebnis.

    Diese Informationen sind zu dürftig.

    Hast Du deinen PI per arp-scan (oder gleichwertig), in deinem (W)LAN sehen können?

    Wie ist mit der SD-Karte, auf einem geeigneten Gerät, die Ausgabe von:

    Code
    ls -la /boot

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hast du die leere SSh Datei erzeugt und auf das boot Menü kopiert beim frisch installierten RasperryPI-OS-lite

    Edited once, last by RPI52 ().

  • Hast du die leere SSh Datei ...

    Lt. "sshswitch.service" wird ja nach ssh und ssh.txt geschaut:

    Code
    ExecStart=/bin/sh -c "systemctl enable --now ssh && rm -f /boot/ssh ; rm -f /boot/ssh.txt"

    Hast Du es schon mit SSh probiert und wenn ja, funktioniert es? ... weil Du es hier so angegeben hast?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

    Edited once, last by rpi444 ().

  • Lt. "sshswitch.service" wird ja nach ssh und ssh.txt geschaut:

    Code
    ExecStart=/bin/sh -c "systemctl enable --now ssh && rm -f /boot/ssh ; rm -f /boot/ssh.txt"

    Hast Du es schon mit SSh probiert und wenn ja, funktioniert es? ... weil Du es hier so angegeben hast?

    Habe ich bei meinen Post leider nicht gesehen waren ziemlich gleich dran SORRY

  • Bitte entschuldigt meine dürftigen Angaben.


    - rote LED brennt (Stromversorgung OK), grüne LED blinkt beim Booten

    - SSH-Datei ohne Dateiendung ist auf der SD-Karte

    - in der Fritz!box wird der Rasperry nicht erkannt (WLAN)

    - Wenn ich die bisherige IP-adresse in Putty eingebe kommt nur ein schwarzes Fenster

  • Bitte entschuldigt meine dürftigen Angaben.

    Wenn Du überhauptnicht auf den RPI kommst, dann können die Angaben auch nur recht dürftig sein.

    - in der Fritz!box wird der Rasperry nicht erkannt (WLAN)

    Hast Du noch einen weiteren Rechner (PC, Smatphone etc) im gleichen Netz laufen? Dann könntest Du mit einem Portscanner (zB Angry Port Scanner) Dein gesamtes Netz (von xxx.xxx.xxx.0 bis xxx.xxx.xxx.255) nach sich meldenden Geräten abscannen. Mitunter tut sich die FritzBox etwas schwer, ein neues Gerät anzuzeigen. Der Portscanner liefert da dann eindeutigere Ergebnisse. Die alte IP Adresse muss nicht unbedingt mehr gültig sein. Am besten auch LAN mit anschliessen. Der RPI sollte dann bei 2 IPs auftauchen.


    Wenn Du auch da kein Ergebnis erhältst, weder über WLAN noch über LAN, dann ist zumindest die (W)Lan Schnittstelle mindestens nicht aktiviert. Das heißt nicht automatisch dass sie kaputt ist. Es kann auch sein, dass der RPI beim Booten gar nicht so weit kommt, sondern bei irgendeinem Fehler stehen bleibt.


    Auf jeden Fall solltest Du nach einer Möglichkeit schauen, zumindest per HDMI temporär einen Bildschirm anschließen zu können. Notfalls tuts auch ein TV Gerät. Dann kannst Du schon mal sehen, wie weit der RPI beim Booten überhaupt kommt. Eine (USB)-Tastatur könnte im weiteren Verlauf auch hilfreich sein.


    Eine Maus ist nicht zwingend erforderlich. Im Textmodus nützt sie eh nichts und auch die GUI kann man problemlos mit der Tastatur bedienen.


    Lg

    Günther

    1. Raspberry Pi 4B / 4GB / Orig.Netzteil / Orig.Gehäuse. (uname: -v: 5.10.17-v7l+ #1414 SMP Fri Apr 30 13:20:47 BST 2021)

    2. Raspberry Pi 3B+ / Orig.Netzteil / 3,5" LCD Display. (uname: -v: 5.10.17-v7+ #1414 SMP Fri Apr 30 13:18:35 BST 2021)

    OS: Raspbian GNU/Linux 10 (buster)

  • So, habe nun einen Bildschirm angeschlossen und kann verfolgen, wie der RPI bootet.

    Am Schluß erscheint die Zeile: raspberry login:


    Aber weder "pi" und "paspberry" noch "pi" und <mein vergebenes Passwort> funktionieren. Es erscheint: "Login incorrect"



    AxelH

  • Ich habe schon mehrere Varianten versucht. Es hilft nicht.


    Es wird zuerst auch nicht nach "User" gefragt sondern nach "raspberrypi login"

  • Ja, genau so habe ich es schon mehrfach versucht.


    Ich kann mir das einfach nicht erklären. Seit der Erstanmeldung und dem Ändern meines Passwortes habe ich nichts mehr daran geändert. Ich konnte mich mit SSH immer mit meinem Passwort anmelden.

  • Das ist korrekt. Bei raspberrypi login: kann ich ich sehen, was eingegeben wird. Bei Password sehe ich nur den blinkenden Unterstrich und keine Eingabe.