grocy - neue Probleme mit altem Zeugs

  • Ja, Buster kommt mit 7.3, die "7.4" stammt aus #43. Warum auch immer Fremdrepo ohne Grundkenntnisse.

    Menschen die keine Ironie verstehen finde ich super!

  • Ich habe den Wechsel nicht freiwillig gemacht. Ich musste es, weil die neue Version nicht auf 7.4 läuft. Aber dank deiner Hilfe klappt es nun. Zuerst habe ich im Terminal a2enmod php7.4 und danach a2dismod php7.3. So klappt nun alles. Danke vielmals :)

  • Ist es unangebracht an dieser Stelle mit viel grundlegenderen Problemen zu kommen? Ich bin ganz ehrlich, ich habe mich nie so richtig für den PI und dessen Anwendungen / Bedienung interessiert; daher bin ich auch maximal fachfremd. Das Konzept von Grocy hat es mir leider angetan. Also habe ich mir sone kleine Maschine angeschafft und mit den einfachen Übungen aus dem zugehörigen Buch angefangen. Das wird aber schnell langweilig und eigentlich möchte ich auch nur grocy. Da habe ich mir gedacht "how hard can it be". Leider scheitere ich bereits bei der simplen Installation und verfluche die Kiste mittlerweile. Ich bin der Anleitung aus #21 Punkt für Punkt gefolgt und scheitere beim entpacken (Befehl 9). Da werden mir einige Funktionen von unzip angezeigt, aber das war es dann auch schon. Schaue ich in die Ordnerstruktur, ist da auch nichts entpacktes zu finden. Daher wundert es mich kaum, dass der nächste Befehl chown -R.... auch nicht mehr als eine Fehlermeldung hervorruft. Kann mir jemand irgendeinen hilfreichen Tipp / eine Anweisung geben? Bitte? Ich habe auch bereits alle youtube-Anleitungen und zwei weitere Anleitungen aus Foren nachgestellt, generiere aber ausschließlich Fehlermeldungen. Vielen lieben Dank im Voraus

  • Danke Manul! Das erste kleine Erfolgserlebnis :)

    Leider wird mir jetzt folgende Fehlermeldung im Browser ausgegeben:

    Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.4.0".

    Ich denke, das sollte sich sicherlich beheben lassen. Morgen lese ich mich erstmal in die einzelnen Optionen von unzip ein. So langsam möchte ich doch ganz gerne die Zusammenhänge in dieser Maschine verstehen und nicht nur blind Befehle Copy-pasten. :)


    :danke_ATDE:

  • Ich habe mich um php7.4.16 gekümmert. Leider verschwindet die Fehlermeldung Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.4.0". nicht aus dem Browser. Also habe ich die SD Karte formatiert, alles von neu installiert und php7.4 vor der Installation von grocy aufgespielt. An der Fehlermeldung ändert sich leider nichts. Hat jemand zufällig eine Idee?

  • Cantate

    Du kannst in /var/www/html/ eine Datei phpinfo.php erstellen und folgendes eintragen:

    PHP
    <?php
    phpinfo();
    ?>

    Dann kannst du das mit 127.0.0.1/phpinfo.php aufrufen, dann bekommst du Informationen zu PHP.

    Ansonsten erstell einen eigenen Thread mit aussagekräftigen Informationen und nicht mit Prosa, wie "Ich habe mich um php7.4.16 gekümmert."

  • Das sieht bei mir bis auf die Uhrzeit nahezu identisch aus.

    Warum wird mir so oft php7.3 ausgegeben und bei folgender Eingabe sieht es anders aus?

    Code
    pi@raspberrypi:/var/www/html $ php --version
    PHP 7.4.16 (cli) (built: Mar  5 2021 08:36:10) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
        with Zend OPcache v7.4.16, Copyright (c), by Zend Technologies
  • Warum wird mir so oft php7.3 ausgegeben und bei folgender Eingabe sieht es anders aus?

    Weil php-cli was anderes als php (im Webserver) ist und nicht zwingend die gleiche Version haben muss.

    Menschen die keine Ironie verstehen finde ich super!

  • Code
    sudo apt install apache2 php7.4 sqlite3 php7.4-sqlite3 unzip php-gd
    sudo a2enmod rewrite
    sudo systemctl restart apache2

    bringt mich leider auch nicht nach vorne; erzeugt aber auch keine Fehlermeldungen.

  • Man könnte fast meinen, dass es so klappen könnte. Ich habe auch artig folgendes eingetippt:

    Code
    sudo nano /etc/apt/sources.list
    deb http://rasbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
    sudo apt-get update && sudo apt-get upgrade -y
    dpkg -l |grep php
    sudo apt-get remove '^php.*'
    sudo apt-get install php7.4-cli php7.4-common php7.4-curl php7.4-gd php7.4-json php7.4-mbstring php7.4-mysql php7.4-opcache php7.4-readline php7.4-xml
    service apache2 restart

    Leider erhalte ich jetzt unter <ip>/grocy/public den Quellcode von aus index.php angezeigt. Meine Laienhafte Vermutung sagt mir: irgendwas ist bei dieser PHP-Geschichte schief gelaufen....

  • ok, ich habe grade durch Zufall gesehen, dass grocy nur bei Zugriff im Browser des Raspberrys selber diesen Fehler erzeugt. Bei anderen Geräten scheint das kein Problem zu sein. Das ist doch im Prinzip eine "Lösung" :)

  • Hallo zusammen

    Ich wollte Grocy auf meinem RPI aktualisieren.

    Nun habe ich das Problem, dass wenn ich localhost aufrufe, die Meldung erscheint:Unable to run grocy: PHP module 'intl' not installed, but required..

    Nun wollte ich die intl- Erweiterung mit Hilfe von sudo apt-get install php7.4-intl installieren. Da kommen dann diese Meldungen (ich benutze php7.4.13):

    Das scheint ja nicht zu funktionieren. Daher wollte ich einmal ein update machen, weil es vorgeschlagen wurde, aber das scheint auch nicht zu gehen, oder?

    Kann mir jemand helfen die Probleme zu lösen?


    LG Bern

  • https://packages.sury.org/php buster InRelease:

    taucht bei mir während eines Updates nicht auf, da hast Du selbst etwas zusammengebastelt.

    Vielleicht helfen Dir die Anweisungen hier weiter: https://deb.sury.org/


    Mit Buster wird die 7.3er intl-Version ausgeliefert.


    Es ist auch möglich, das der Server/Webseite wg. Wartungsarbeiten down ist, versuch es später noch einmal.


    Ich habe grocy derzeit nicht installiert, bin daher keine große Hilfe.


    MfG


    Jürgen

  • Hallo Jürgen Böhm

    Danke für die schnelle Antwort.

    Ich habe mir die Links angeschaut, aber leider hilft mir das nicht weiter, da ich leider so gut wie keine Ahnung davon habe.

    Mit Buster wird die 7.3er intl-Version ausgeliefert.

    Aber die 7.3er Version funktioniert ja nicht für die 7.4er Version oder? Das müsste ja sicher eine eigene Erweiterung sein..?

    Es ist auch möglich, das der Server/Webseite wg. Wartungsarbeiten down ist, versuch es später noch einmal.

    Das wäre möglich aber eher unwahrscheinlich, da ich es am Freitag, Sonntag und gerade eben noch einmal probiert habe und es leider immer noch nicht geht.


    LG Bern

  • Nun habe ich das Grocy Update wieder Rückgängig gemacht (Image vor Update geladen), weil ich schauen wollte, was mir das sudo apt-get update zurückgibt. Das gibt zwar nicht genau dasselbe zurück wie nach dem Update aber etwas ähnliches:


    Danach habe ich das hier gemacht (der Beitrag von Hofei)


    dann erschien das als ich apt-get update --allow-releaseinfo-change eingegeben habe :


    Das klingt nicht so wie es klingen sollte, oder?