Funtastatur und Maus schleichen verzögert

  • Hallo zusammen,

    mir ist jetzt ein Phänomen mit Funkmäusen und Tastaturen untergekommen. Die Maus schleicht verzögert und ganz langsam über den Bildschirm. Die Tastatur hinkt auch der ganzen Sache hinterher und kann schnellen Eingaben nicht folgen. Das habe ich mit drei verschiedenen Geräten und mit dem PI 3 getestet. Stecke ich das an einen Windows PC läuft alles normal. Auch an meinem Linux Mint PC läuft alles normal. Schließe ich ein kabelgebundenes Gerät an den PI ist auch alles normal.

    Jetzt die Frage: Was kann ich machen damit ich vernünftig arbeiten kann? Die Variante mit Kabeln scheidet aus, dafür ist kein Platz.


    Gruß, Gunter

  • So ein Problem hatte ich auch. Gelöst habe ich es, in dem ich quasi vor dem RPI mit der Funktastatur (billig Marke) saß, denn weiter ging das Signal nicht. Bluetooth, WLAN usw. können die Funksignale stören. Ein Gehäuse aus Metall kann z.B. die Sendeleistung des WLAN-Moduls erhöhen, da das ankommende Signal auch an Leistung verliert. D.h. falls es in einem Metallgehäuse ist und du WLAN nutzen musst, dann probiere mal den RPI ohne Gehäuse laufen zu lassen.

    Eine andere Möglichkeit wäre es auf Bluetooth zu wechseln. Das habe ich bis jetzt nicht selbst probiert, aber es gibt Kombinationen aus Maus + Tastatur mit Dongle und integriertem Bluetooth. Da ich gestern meinen Dongle wieder gefunden habe, werde ich mal probieren, ob es Unterschiede zwischen dem proprietären 2,4 GHz Protokoll und Bluetooth gibt.

  • Möglicherweise hast Du zuviele Stromverbraucher dem Pi zugemutet, sodass er in die Unterspannungsstrategie fällt. Schau mal in den Logfiles nach (z.B. /var/log/syslog ).


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Das habe ich total vergessen zu schreiben. Die Geräte sind alle mit eigenem Empfänger (kleiner USB-Stecker).

    Wegen dem Strom glaube ich nicht, denn wenn ich die Kabelmaus dazu stecke geht der Mauspfeil mit Kabel normal und über Funk verzögert.

    RTFM Den Tipp werde ich morgen testen, muss jetzt erst mal auf Arbeit.

  • Ich verwende wegen der gleichen Problematik ein kurzes Verlängerungskabel, welches den Dongle der Funktastatur vor den Pi verlegt. Direkt in den USB2- Anschluss gesteckt hatte ich auch Probleme, jetzt nicht mehr. Die USB3-Buchsen können wohl stören.

  • Ist das nicht ne ganz alte Sache? :


    /boot/cmdline.txt editieren, Folgendes am Ende anfügen: usbhid.mousepoll=0

    "Volt, Watt, Ampere, Ohm, ohne mich gibts keinen Strom"

    Der Elektrolurch (Guru Guru)

  • Heinrich: Die Datei habe ich um die Zeile erweitert und den PI neu gestartet. Leider keine Verbesserung.

    Urs-1956 : Eine Verlängerung hilft auch nicht und der PI 3 hat noch keine USB 3 Buchsen.

    RTFM : In der Datei ist zu sehen wie die Maus gefunden wird. Was soll ich noch schlimmes finden?

  • Die Verlängerung bringt den Dongle generell etwas vom Pi weg, so dass Störungen durch den Pi reduziert werden. Dabei ist der Pi erst mal egal ;)

  • RTFM : In der Datei ist zu sehen wie die Maus gefunden wird. Was soll ich noch schlimmes finden?

    Ich bin nicht in der Lage, Dir alle möglichen Hinweise aus den Logfiles hier aufzuzählen.

    Wenn Du nichts erkennen kannst, dann beobachte wenigstens die Kernelmeldungen beim Dongle-Anstecken und der Verwendung der Maus, und vergleiche die mit dem PC.

    Laut < man dmesg > kannst Du die aktuellen Meldungen aus dem Kernel Ring Buffer mit < dmesg --follow > oder < dmesg -w > anzeigen lassen. [Abbruch mit Cztl-C ]


    < top > könnte auch einen Hinweis liefern.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • Wegen dem Strom glaube ich nicht, denn wenn ich die Kabelmaus dazu stecke geht der Mauspfeil mit Kabel normal und über Funk verzögert.

    Natürlich könnte es sein, dass die Funkttechnologie einen höheren Strombedarf hat als die Kabelgebundene Lösung.

    Das ganze könntest du mit einen aktiven Hub testen.

  • Heinrich: Die Datei habe ich um die Zeile erweitert und den PI neu gestartet. Leider keine Verbesserung.

    Hi mycrobit,

    Du sollst da keine neue Zeile machen, das wird dann nicht mehr gelesen weil das 'ne Parameterliste ist,

    es wird einfach nur nach einem Leerzeichen hinter dem letzten Wort (bei mir ist das dort "rootwait"), in der ersten und einzigen Zeile,

    die da in /boot/cmdline.txt steht, angefügt.

    Dahinter kannst Du dann noch einen Zeilenumbruch machen.


    --kostet ja nicht viel Zeit, das nochmal zu probieren.

    Bei mir hat das mit allen kabellosen Mäusen funktioniert

    und die haben sich alle erstmal so benommen, wie Du das auch beschreibst.



    Das ist ein sehr altes Problem(chen). Guck mal hier:

    "Volt, Watt, Ampere, Ohm, ohne mich gibts keinen Strom"

    Der Elektrolurch (Guru Guru)

    Edited 2 times, last by Heinrich ().

  • Problem gelöst :D

    Danke an Heinrich das war die Lösung. Software ist nicht so mein Ding, ich habe lieber den Lötkolben in der Hand.

    Um der Sache mit dem Stromverbrauch auf den Grund zu gehen habe ich mir den PI 4 raus gekramt und es damit getestet. Genau das gleiche Phänomen und das Netzteil ist sehr ausreichend. Also die Lösung wie Heinrich beschrieben.

  • Hey, bin Anfänger und habe mir nach der normalen Desktop Raspberry Pi Installation das Ubuntu Betriebssystem installiert. Ich habe bei dem alten Betreibssystem die Mausverzögerung behoben bekommen, doch auf dem Ubuntu sytsem funktioniert dies nicht und ich finde nicht den richtigen Fad zur Datei wo ich den „usbhid.mousepoll=0“ Befehl anfügen kann. Kann mir bitte jemand weiterhelfen?