Ausschließlich W-Lan-Verbindung möglich. Kein Ethernet bei RPi4

  • Hey,


    vorweg: Bitte entschuldigt, dass ich ein absoluter Noob bin. Ich find Linux, die Raspberry, Programmieren im Allgemeinen und Co. zwar mega interessant, hab aber nicht die Zeit (bzw. hab sie mir nie genommen), um mich damit intensiv auseinander zusetzen. Heißt: Irgendwelche Befehle in der Konsole tippe ich idR nach Anleitung ab. Weiß zwar im groben was passiert, könnte aber keine selbstständig ausführen. Ich bin absoluter Windows-User und das operieren am Computer per Konsole ist mir ziemlich fremd. Kurz: Ich bin ein schwer Fall und brauche quasi eine Anleitung zum lösen des Problems... :|


    Nutze die Raspberry Pi mehr als Tool, um ein paar "coole" Projekte umzusetzen (z.B. RetroPi, PiHole, Kodi, Steam Link). Weil ich auf einem System sowohl Kodi, als auch PiHole laufen lassen wollte, habe ich diese auf einer Pi 4 unter dem normalen Raspberry Pi OS installiert. Habe drauf geachtet die SD-Karte richtig zu formatieren, habe eingestellt, dass ich per Putty Zugriff auf die Pi habe. Hatte im Wohnzimmer noch kein Lan-Kabel verlegt und habe die gesamte Konfiguration per WLAn gemacht.

    Nun liegt das Lan-Kabel, die Pi ist angeschlossen, bleibt weiterhin (selbst beim Reboot) ausschließlich per WLan verbunden. Auch in Router ist das zu erkennen.

    Was mache ich falsch? Was muss ich umstellen?

    Im Netz und im Forum finde ich dazu keine zufriedenstellenden Lösungen...


    Vielen Dank im Voraus.


    MfG Achim

  • Sicher, das das Kabel auch in Ordnung ist?

    Welcher Router?

    Ist am Pi an der Status LED der LAN Buchse ein Link zu sehen?

    Der Router hat einen DHCP Server und der Pi ist auch auf dem LAN Interface als DHCP CLient eingerichtet?

    Deine Vorhaben sind als Linux Noob - gelinde gesagt - ziemlich anspruchsvoll. ;)


    Ich würde mich da erst an einfacheren Dingen versuchen.

    Aber wie heißt der tolle Spruch den alle Chefs der Welt zitieren: "der Mensch wächst mit seinen Aufgaben..." :P


    Gruss

  • ..., dass ich per Putty Zugriff auf die Pi habe. Hatte im Wohnzimmer noch kein Lan-Kabel verlegt und habe die gesamte Konfiguration per WLAn gemacht.

    Nun liegt das Lan-Kabel, die Pi ist angeschlossen, bleibt weiterhin (selbst beim Reboot) ausschließlich per WLan verbunden. Auch in Router ist das zu erkennen.

    Was mache ich falsch? Was muss ich umstellen?

    Welchen Router hast Du?

    Poste mal von deinem PI, mit zusätzlicher LAN-Kabel-Verbindung zwischen PI und Router, die Ausgaben von:

    Code
    ip a
    route -n
    arp -av

    , in code-blocks und nicht als Screenshot.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Das Kabel ist definitiv in Ordnung. Es handelt sich um eine Fritz-Box.

    Die Status-LED an der LAN Buchse der Pi leuchtet!

    Das mit dem DHCP Server ist die Frage... Die Fritz-Box hat ja definitiv einen DHCP Server. Ob die Pi als DHCP Client eingerichtet ist weiß ich nur nicht. Wie erkenne ich das?


    Vielen Dank für deine Antwort :)

  • Welchen Router hast Du?

    Poste mal von deinem PI, mit zusätzlicher LAN-Kabel-Verbindung zwischen PI und Router, die Ausgaben von:

    Code
    ip a
    route -n
    arp -av

    , in code-blocks und nicht als Screenshot.

    Wie gesagt bin ein Noob :(

    Weiß nicht ob ich die MAC-Adresse posten kann/sollte. Deshalb zensiert. Falls wichtig bitte einfach sagen.

    Code
    ? (192.168.178.1) auf xx:xx:xx:xx:xx:xx [ether] auf wlan0
    Einträge: 1 Ignoriert: O Gefunden: 1
  • Poste doch bitte mal die /etc/dhcpcd.conf.

    Oder schau selbst nach, ob dort DHCP für eth0 aktiviert ist. Bei reinem Pi OS müsste eigentlich DHCP eingestellt sein.


    Gruss

  • Poste doch bitte mal die /etc/dhcpcd.conf.

    Oder schau selbst nach, ob dort DHCP für eth0 aktiviert ist. Bei reinem Pi OS müsste eigentlich DHCP eingestellt sein.


    Gruss

    Ist mir echt etwas peinlich. Kann damit wenig anfangen... Sind halt die statischen IP-Adressen, die ich eingestellt habe und die DNS-Server die ich für das Pi-Hole konfiguriert habe.

    Bei den restlichen Einträgen der Datei ist alles mit einer "#" versehen, was wenn ich richtig liege, ja nur Hinweise sind und keine Befehle ausführen.

    Code
    interface wlan0
    static ip_adress=192.168.178.35/24
    static routers=192.168.178.1
    static domain_name_servers=9.9.9.9 149.112.112.112
    static domain_search=
    
    interface eth0
    inform 192.168.178.36/24
    static routers=192.168.178.1
    static domain_name_server=9.9.9.9 149.112.112.112
  • Anstelle der Zeile mit "inform" würde ich auch eine statische IP vergeben.

    Die WLAN Adresse liegt übrigens auch im DHCP Bereich der FritzBox (.20 - .200).

    Ich würde für beide Interfaces eine IP ausserhalb DHCP nehmen.

    Die WLAN IP aber erst verändern, wenn die LAN IP klappt.


    Gruss

  • ... Befehle ausführen.

    Code
    static ip_adress=192.168.178.35/24

    Warum postest Du nicht die Ausgaben von:

    Code
    ip a
    route -n

    ?

    Im Beitrag #4 hast Du geschrieben:

    Quote


    Ob die Pi als DHCP Client eingerichtet ist weiß ich nur nicht. Wie erkenne ich das?

    Das passt nicht zu deiner dhcpcd.conf.

    Btw: "ip_adress" ist falsch. Richtig wäre "ip_address". Ich weiß nich was Du mit deinem Thread beabsichtigst.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wie AchimClemens anmerkte, befinden sich beide IPs im DHCP-Bereich der F!B.

    bei dir kann es sein, dass irgend ein anderes Geräte die 192.168.178.36 verwendet, und deshalb der IP drüber nicht erreichbar ist.


    Der DHCP-freie Bereich der F!B liegt von .2 bis .19, die IP-Adressen ab .200 sind für die VPN-Einwahl über die F!B-VPN-Lösung gedacht und sollten nur verwendet werden, wenn man garantiert nie eine Verbindung mittels der in der F!B realisierten VPN-Möglichkeit nutzt.


    (Den DHCP-Bereich der F!B kann man in der Netzwerkeinstellung verändern, also auch einschränken, doch das sollte man machen, wenn kein anderes Gerät mit der F!B verbunden ist, da die Geräte nach der Änderung des DHCP-bereich (teilweise) neue IPs bekommen.)

    Selber denken,
    wie kann man nur?

  • Wer hat es angemerkt?

    Ja, nur das Problem war, dass Du es zu früh im Thread, angemerkt hast. So springt man hin und her, denn der TE weiß ja i. d. R. nicht was wichtig bzw. was weniger wichtig ist. Ob hier die IP-Adressen in der dhcp-Range liegen oder außerhalb liegen, ist erstmal nicht relevant (evtl. lediglich ein Schönheitsfehler).

    Man kann mit einem dhcp-Client auch statische IP-Adressen, die sich in der dhcp-Range befinden, zuweisen. Und man kann mit der FritzBox (DHCP-Server), manuell(/durch konfiguration) auch statische IP-Adressen zuweisen, die sich nicht in der dhcp-Range der FritzBox befinden. In allen Fällen muss die verwendete Syntax aber die richtige sein.

    BTW: Wenn man "inform" benutzt, geht es auch um eine statische IP-Adresse. Die Frage ist nur die, muss diese IP-Adresse schon im Vorfeld der Mitteilung durch den Client an den Server, dem Interface manuell (oder gleichwertig) zugewiesen sein, oder macht der dhcpcd diese Zuweisung? Aber der TE wird sich ja etwas gedacht haben, wenn er hier gezielt (als Noob?) "inform" benutzen will.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Die Frage nach dem "Wer" war nur Spass ;) .

    BTW: Wenn man "inform" benutzt, geht es auch um eine statische IP-Adresse. Die Frage ist nur die, muss diese IP-Adresse schon im Vorfeld der Mitteilung durch den Client an den Server, dem Interface manuell (oder gleichwertig) zugewiesen sein, oder macht der dhcpcd diese Zuweisung?

    Da bin ich mir auch nicht ganz sicher. Laut manpage:

    Daher gehe ich davon aus, das die IP nicht über den DHCP Server vergeben wird.


    Gruss

  • Daher gehe ich davon aus, das die IP nicht über den DHCP Server vergeben wird.

    Durch den Server nicht, ... der Server soll zur Kenntnis nehmen, dass diese IP-Adresse vergeben (reserviert) ist _und_ der Server soll dem dhcp-Client (der das DHCPINFORM gesendet hat) Informationen bzgl. DNS-Server, NTP-Server, etc. via DHCPACK & Co. zukommen lassen.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Okay sorry, ich bin super stupid. Ich ging davon aus, dass wie bei Windows die Ethernet-Verbindung präferiert wird. Tatsächlich verbindet er sich nur per Ethernet, wenn ich die WiFi-Verbindung ausschalte... Jetzt funktioniert alles!

  • Wundert mich. Bei meinen ersten Gehversuchen hatte ich sowohl auf der WLAN als auch auf der LAN Schnittstelle eine per DHCP zugewiesene IP.


    Mittlerweile hat das LAN eine über die dhcpcd.conf eingerichtete statische IP, WLAN erhält immer noch eine IP via Router DHCP.

    Das sich also LAN nur bei deaktiviertem WLAN verbindet ist falsch. Irgendwo musst Du da noch eine Einstellung haben, die nicht passt.


    Gruss

  • Hab gerade das ganze extra nochmal mit einer Neuinstallation getestet. Scheint bei Raspbian Standard zu sein, dass WLAN "Vorzug" hat.