Raspi 4 - kein Zugriff auf gemountetes NAS

  • Moin zusammen,


    ich habe mir vor Kurzem meinen ersten Raspi gekauft, auf dem LMS installiert und auf die Mediathek auf meiner DS218+ zugegriffen werden soll. Zur Zeit kämpfe ich aber noch mit der Verbindung zum NAS.



    Ausgangslage:


    • Raspi 4 mit 8GB
    • Original Netzgerät
    • aktuelles "Buster" ist installiert
    • ssh und VNC laufen problemlos
    • keine weiteren Pakete installiert
    • Mountpoint ist /mnt/nas/music


    • Auf der DS wurde Nutzer "pi" mit Benutzer-Home-Dienst sowie lesendem und schreibendem Zugriff auf gemeinsamen Ordner eingerichtet
    • gemeinsamer Ordner freigegeben, NFS-Berechtigung eingerichtet, Mountpfad ist /volume1/music



    Problem:


    Mit sudo mount -t nfs 192.168.36.xx:/volume1/music /mnt/nas/music klappt zumindest die Verbindung, df -BG ergibt schon mal


    Dateisystem 1G-Blöcke Benutzt Verfügbar Verw% Eingehängt auf

    /dev/root 29G 7G 21G 26% /

    devtmpfs 4G 0G 4G 0% /dev

    tmpfs 4G 0G 4G 0% /dev/shm

    tmpfs 4G 1G 4G 1% /run

    tmpfs 1G 1G 1G 1% /run/lock

    tmpfs 4G 0G 4G 0% /sys/fs/cgroup

    /dev/mmcblk0p1 1G 1G 1G 20% /boot

    tmpfs 1G 1G 1G 1% /run/user/1000

    192.168.36.xx/:volume1/music 2679G 380G 2300G 15% /mnt/nas/music


    Wenn ich in /mnt allerdings mit tree arbeite, dann kommt die erste Fehlermeldung


    pi@RPi4:/mnt $ tree

    .

    └── nas

    └── music [error opening dir]



    Wenn ich über VNC auf den Desktop gehe, dann werden mir im Dateimanager u.a. folgende Verzeichnisse angezeigt:


    1. homes auf homeserver.local -> Homeverzeichnisse sämtlicher Nutzer auf der NAS, lesender und schreibender Zugriff auf Home "pi" möglich
    2. Zwei Homeserver (Dateifreigabe) mit Zieldatei smb://Homeserver.local:445/ bzw afp://Homeserver.local:548/ -> hier werde ich bei jedem Verzeichnis nach den Anmeldedaten von User "pi" gefragt. Beim Verzeichnis music, für das ich auf der DS ja die Freigabeberechtigung verteilt habe und das auch im Mountbefehl angesprochen wird, heißt es dann jedes Mal Der angegebene Ort ist nicht eingehängt.


    Ich stehe gerade ziemlich auf dem Schlauch. Einerseits wird bei df das Verzeichnis music erkannt (müsste dann doch auch eingehängt sein, oder?), andererseits behauptet der Dateimanager genau das Gegenteil. Das da irgendwas schief ist, kann man ja bei tree sehen. Aber was? Warum habe ich auf das Home-pi Zugriff, auf das eigentlich freigegebene music aber nicht?


    Könnt Ihr mir da etwas auf die Sprünge helfen?


    Schon mal :danke_ATDE:.


    Viele Grüße


    zeitig

    Edited 2 times, last by zeitig ().

  • zeitig

    Changed the title of the thread from “Raspi 4 - kein Zu” to “Raspi 4 - kein Zugriff auf gemountetes NAS”.
    • Official Post

    Vorab, ich habe nur kurz überflogen, man möge mir das verzeihen.

    Mountpoint ist /mnt/nas/music

    Der Mountpoint ist nicht gut gewählt, weil /mnt für kurzzeitige Mounts des Systemadministrators angedacht war/ist. Besser geeignet wäre als Mountpoin für den User pi /media/pi/<Mountpoint>


    Wenn Du Samba verwendest, dann sollte die Option -t nicht nfs, sondern cifs sein. So wirklich habe ich nicht verstanden, was Du nun wirklich verwendest.

  • Die Einrichtung eines NFS Client (am Pi) und eines NFS Server (am NAS) ist unter Network File System (NFS) von https://www.raspberrypi.org/documentation/configuration/ ganz passabel dokumentiert. Da Du den Pi als eigenen, eigenständigen Host mit eigenem Linux BS betreibst, brauche Du kein weiteres Home-Dir im Netz, das würde ich am NAS gleich einmal abschalten.


    Sowohl NAS, als auch der Pi haben eine eigene User- und Gruppenverwaltung, die nur je am eigenen Host funktioniert, solange die nicht gemeinsam über NIS/LDAP verwaltet werden. Dabei wird im Localnet zwischen den Hosts nicht der Username, sondern die UID (User pi UID=1000 am Pi) und eine andere UID für den User pi am NAS wahrscheinlich verwendet.


    Wenn Du die User-/Gruppenrechte mit tree ansehen willst, steht dafür < tree -pug /mnt > zur Verfügung.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • hyle

    Ich will eigentlich kein Samba verwenden, von daher war die Option -t nfs schon bewußt gewählt. Die smb-Freigabe habe ich auf der DS jetzt abgeschaltet.


    RTFM

    Danke für den Link. Damit werde ich mich mal beschäftigen. Das Home auf dem NAS habe ich rausgenommen. Wenn ich Dich richtig verstehe, dann wird es ohne NIS/LDAP immer Probleme geben? Wo sollte denn die der LDAP-Server am Besten laufen? Auf dem NAS oder auf dem Raspi?

  • Ich greife über meinen Pi auf eine QNAP zu und habe damit keine Probleme.

    Mit Syno habe ich keine Erfahrung. Wie sehen denn die Freigaben auf der Syno aus?

    Welche nfs Version benutzt Du, v3 oder v4?


    Gruss

  • Nein, Du brauchst kein NIS/LDAP. Jeder Linux Host hat dann seine eigene User-/Group-Verwaltung.

    Die User/Groups werden am Host in den Files sowieso nicht mit dem angezeigten Namen, sondern mit der (vorzeichenlosen) Ganzzahl (UID) gespeichert und übertragen.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • @all

    Sorry, das ich mich erst jetzt wieder melde.


    RTFM

    Ich habe mich jetzt mal hiernach http://www.raspbian.org/Raspbi…o_I_mount_an_NFS_share.3F gerichtet.


    Nach einem manuellen Mount ergibt sudo ls -l /mnt/nas/music/ schon mal das


    pi@RPi4:~ $ sudo ls -l /mnt/nas/music/

    insgesamt 28

    -rw-r--r-- 1 1024 users 3697 Sep 7 2016 6.m3u

    -rw-r--r-- 1 1024 users 6270 Jan 16 2017 98.m3u

    -rw-r--r-- 1 1024 users 2046 Nov 13 2016 '9<.m3u'

    -rw-r--r-- 1 1024 users 165 Jan 21 2012 infobrowser.opml

    drwxrwsrwx 1 1026 users 110 Apr 1 2014 Interviews

    drwxrwsrwx 1 1026 users 322 Apr 24 14:58 iTunesDS

    -rw-r--r-- 1 1024 users 2161 Okt 31 2016 ' .m3u'

    drwxrwxrwx 1 root root 244 Nov 28 2016 'Mobile Applications'

    -rw-rw-rw- 1 1026 users 172 Aug 7 2016 music

    drwxrwsrwx 1 1026 users 40 Aug 26 2013 'Rio (2011)'


    FSC830

    Auf der DS habe ich NFSv4.1 aktiviert. Der Nutzer "pi" hat lesenden und schreibenden Zugriff auf den gemeinsamen Ordner. Bei der NFS-Regel für den gemeinsamen Ordner habe ich folgende Einstellungen gemacht:


    Hostname: IP vom Raspi

    Privileg: Lesen und schreiben

    Squash: keine Zuordnung

    Sicherheit: AUTH_SYS

    Asynchron aktivieren

    Benutzer Zugriff auf bereitgestellte Unterordner gewähren




    Jetzt kommen aber zwei Punkte, an denen ich bislang nicht weitergekommen bin.


    Kann ich mir z.b.auch den Inhalt von /mnt/nas/music/iTunesDS/ (also den Inhalt eines Unterverzeichnisses anzeigen lassen? Wenn ja, wie? Auf der Konsole wird der Zugriff Mangels Berechtigung verweigert. Im Dateimanager wird im Stammverzeichnis zwar /mnt/nas/music angezeigt, allerdings ohne Inhalt. Auf der DS hatte ich den Zugriff auf Unterordner ja aber gewährt. :conf:


    Ich habe zwischenzeitlich auch den LMS installiert. Grundsätzlich läuft er, wenn ich ihm jedoch den Ablageort der Mediathek (also meinen Mountpoint /mnt/nas/music) angeben will, dann wird im LMS nur /mnt/nas/ angezeigt.


    Mache ich da jetzt nur einen (kapitalen) Denkfehler oder ist da im System noch was krumm?


    Gruß


    zeitig

  • Tu dir einen Gefallen und vergiss nfs, wenn du im Netzwerk nicht einheitliche UID/GID für die User benutzen kannst/willst.

    nfs4 (auth_sys) kann zwar mit User-/Gruppennamen umgehen und diese über verschiedene Rechner hinweg per idmapping angleichen, die Berechtigungen werden aber weiterhin per RPC über uid/gid gesteuert.

    Das führt dann dazu, dass du ein File mit dir als Owner und Schreibrecht siehst, es aber trotzdem nicht ändern kannst "permission denied". Das zu umgehen benötigt dann z.B. Kerberos.

    Also entweder UIDs/GIDs netzweit angleichen (händisch lokal, oder z.B. per ldap) oder lieber, so blöd es ist, cifs nutzen.

    Menschen die keine Ironie verstehen finde ich super!

  • Weder sudo, noch chmod 777 ist ein Allerheilmittel, das alle Zugriffsprobleme beseitigt. Ganz im Gegenteil.


    Deshalb ist "sudo ls" sinnlos, wenn der Pi User pi auf NFS Dateien zugreifen soll.

    Imho sind auch Dateinamen die nicht mit einem alphanumerischen Zeichen, oder einem Punkt beginnen in Unix/Linux verpönt. Da hat vermutlich Apple einige Hochkommas reingeschummelt.


    Du musst zuerst den NFS Server ohne Sicherheitsfeatures konfigurieren, dass der Pi4 (ohne User pi) Zugriff hat, über die IP. Wenn der bisherige Link dazu nicht reich, orientiere Dich an https://wiki.ubuntuusers.de/NFS/


    Servus !

    RTFM = Read The Factory Manual, oder so

  • So, ich glaube, jetzt hab´ ich es!


    In der NFS-Regel für den freigegebenen Ordner hatte ich bei Squash: Keine Zuordnung eingetragen. Das habe ich jetzt mal in Alle Benutzer zu Admin zuordnen geändert und siehe da, alle Verzeichnisse sind da. Im Dateinmanager kann ich problemlos in allen Unterverzeichnissen stöbern und es werden alle Dateien angezeigt. Gleiches beim LMS!


    Das Problem ist also gelöst. Jetzt muss ich nur noch sehen, dass das Mount bestehen bleibt bzw. bei einem Reboot automatisch vorgenommen wird. Aber das ist ein neues Thema.


    Vielen Dank an Alle, die mir hier geholfen haben! :danke_ATDE: