[Gelöst] RP4B bootet nicht von USB-SSD

  • Hi @ all,


    ich bin gerade etwas am verzweifeln: mein Rasberry Pi 4B will nicht von der USB-3.0-SSD booten. ;( Die SSD schießt sogar den Raspi im Desktop-Modus ab, wenn ich sie nach dem Booten mit einem USB-Stick oder SDCard direkt an den USB-3.0-Port des Raspi oder einen daran angeschlossenen aktiven USB-3.0-Hub anschließe. Sie wirft sich dann selbst aus dem System und reisst dabei das OS mit sich.


    USB-3.0-Gehäuse: Raidsonic IB-1822MF-C31 (Affiliate-Link)

    SSD: Crucial P5 CT250P5SSD8 (250 GB), NVME (Affiliate-Link)


    Der RP4B erhält seinen Strom vom Standardnetzteil oder vom sehr starken USB-Ladegerät Anker PowerPort Atom III. An Energie sollte es eigentlich nicht mangeln.


    An meinem PC oder Notebook funktioniert die externe SSD tadellos. ?(


    Wo ist der Haken? Zieht die SSD für einen RP4B etwa zuviel Energie? ?(

    Edited once, last by R-Type ().

  • Hi hyle :),


    das wir uns hier nicht missverstehen: Ich hab eine m.2-SSD in einem USB-3.0-Gehäuse. Da ist kein Kabeladapter dazwischen. ;)

    Im Gehäuse steckt ein ASMedia-Chip (ID 174c:2362).

    Sowohl Gehäuse als auch der Chip mit dieser ID tauchen in der Magische USB-SATA Adapter Liste leider nicht auf ... ;(

  • Und ein Ladegerät kann noch so stark sein, es bleibt ein (langsam regelndes) Ladegerät und wird kein Netzteil.

    Noch weniger, wenn quickcharge draufsteht.


    Servus !

    RTFM = Read The Factory Manual, oder so

  • RTFM danke für den technischen Background, aber das hilft mir jetzt nicht so wirklich weiter. ;)


    Ich frag mich halt, warum die SSD-Gehäuse-Combi ohne Extranetzteil an meinem PC und Notebook funktioniert, am Raspi direkt oder indirekt via aktivem USB-Hub nicht. Sie wird ja vom Raspi erkannt, aber lässt ihn im Desktop-Betrieb abstürzen. Auf der Shell dagegen nicht.

    • Official Post

    Raidsonic IB-1822MF-C31

    Ist ja letztendlich nichts anderes als ein Adapter von M.2 auf USB3. ;)


    Mit "Standardnetzteil" meist Du das offizielle Netzteil für den RPi4 oder? Was hängt noch alles am RPi?


    wenn ich sie nach dem Booten mit einem USB-Stick oder SDCard

    Die SD stekt dann aber direkt im RPi oder verwendest Du an diesem Punkt einen USB-Cardreader?

  • Wenn Du Dir ein richtiges Netzteil holst, hilft Dir das weiter.

    Klar hilft Dir das jetzt nicht, aber eine andere Chance hast Du nicht.


    Hier sind schon viele Leute (ähnlich wie Du) mit einem ähnlichen Problem aufgeschlagen,

    in den meisten Fällen war es ein Ladenetzteil das rumzickte.


    Das mit den Ladenetzteilen funktionierte noch bei den RPis der ersten-dritten Generation,

    danach wurden die RPis wesentlich anspruchsvoller.


    MfG


    Jürgen

  • Ist ja letztendlich nichts anderes als ein Adapter von M.2 auf USB3. ;)


    Mit "Standardnetzteil" meist Du das offizielle Netzteil für den RPi4 oder? Was hängt noch alles am RPi?


    Die SD stekt dann aber direkt im RPi oder verwendest Du an diesem Punkt einen USB-Cardreader?

    Yepp, das offizielle Netzteil für den RPi4. Am RPi4 hängt nur noch eine Tastatur und eine Maus. Aber selbst wenn ich die wegtue und per Putty auf ihn zugreife, bootet er von der SSD nicht.

  • Ok, hast du dann eine konkrete Empfehlung?

    Wobei langsam löst sich gefühlt die Idee eines stromsparenden Musikservers (ich lass da Moode drauf laufen) in Luft auf ... ;(

  • Yepp, das offizielle Netzteil für den RPi4.

    Dann hat sich das Netzteil erstmal erledigt.

    Ok, hast du dann eine konkrete Empfehlung?

    Im Einsatz habe ich diese hier: https://www.reichelt.de/schalt…0608913cdc555b052b3acf2b2

    15W und 90W (für jeweils 4 RPi3B/RPi4B)


    Dazu kommen noch: https://www.reichelt.de/schalt…0608913cdc555b052b3acf2b2

    12W/15W für RPi1B/RPi2B

    Mein Webserver und PiHole hängen zusammen an einem 50W Netzteil.


    Alle diese Netzteile sind justierbar.


    MfG


    Jürgen

  • Dann ist imho der Adapter das Problem... oder ggf. das USB-Kabel. :conf:


    Btw. Urs-1956 Hatte heute einen anderen Adapter als gut bezeichnet: RE: Magische USB-SATA Adapter und wo sie zu finden sind vielleicht kannst Du ja noch umtauschen.

    Ungeeignet für mich. Weil zum einen nur SATA-SSD-Support und kein TRIM-Support, zum anderen keine Kühlung. Die SSD in dem Billiggehäuse wird nie auf Touren kommen, weil die Temperatursensoren sie immer drosseln. Und irgendwann wird die SSD dann den Geist aufgeben. Würde die Finger von dem Gehäuse lassen.

  • Ähh, ich bin kein Elektriker ;) . Also wenn man für ein simples Projekt wie einen Musikserver mit externer SSD und HDD so ein Netzteil benötigt, dann geb ich das ganze Raspberry-Projekt auf. Kann ja wohl nicht sein. Andere haben das ja auch ohne diese Art von Netzteilen geschafft. ;)

  • Andere haben das ja auch ohne diese Art von Netzteilen geschafft.

    Aber nicht sehr viele. Allein eine HDD zieht während des Anlaufs soviel Strom, das auch das Netzteil der Foundation in die Knie geht.

    Meine HDDs haben ein extra Netzteil und laufen über eien USB3.0-Hub


    MfG


    Jürgen

  • Stromhungrige Sachen an den USB zu stecken kann schon zu Problemen führen.

    Ich habe bei mir ein USB-Kabel aufgetrennt und vor dem Anschluss Elkos in die 5-Volt-Leitung gehängt, jetzt kann ich auch eine externe 2,5"-Festplatte dranhängen, ohne dass der Pi abstürzt. Zudem bin ich an der USB-C-Stromversorgung auf 3,4 Volt hoch.

  • bootet die ssd von einem usb2? Hast Du die Tests mal alle mit usb2 gemacht?

    Es gibt einen USB3-Adapter der nur von USB2 startet,

    Aber ob meine USB3-Adapter auch von USB2 starten habe ich nicht ausprobiert, wäre aber mal eine Idee


    Aber er könnte mal von der SD-Karte booten und dann die SSD dranhängen.

    Wenn man tail -f /var/log/syslog vorher startet, kann man die Meldungen sehen, die dabei entstehen.

    Wenn man die dann in einem Codefenster postet, kann man die sogar vernünftig auswerten.

    R-Type Die Platte wird normalerweise unter /media/pi/ eingehängt, kopier etwas von der Platte herunter

    (nicht auf) und gib uns auch mal die eventuell entstehenden Meldungen.


    Aber bitte in einem Codefenster, es erleichtert das Suchen nach Fehlern enorm.


    MfG


    Jürgen

  • Danke erstmal für eure Mühen und Hilfen. Ich hab nach etwas suchen und rumprobieren leider feststellen müssen, dass es aufgrund der eingeschränkten Stromversorgung der USB-Ports beim Raspberry Pi noch nicht möglich ist, an ihme eine NVMe-SSD in einem USB-Gehäuse zu betreiben. Vielleicht geht das mal am Raspberry Pi 5.


    Ich hab darum das Projekt abgebrochen, Case und SSD zurückgeschickt und mir diesen USB-3.2-Stick (Affiliate-Link) (mit integrierter SSD) geholft. Damit klappt das Booten vom USB-3.0-Port auf Anhieb. :)

  • R-Type

    Changed the title of the thread from “RP4B bootet nicht von USB-SSD” to “[Gelöst] RP4B bootet nicht von USB-SSD”.