SSH schläft ein wenn nichts läuft

  • Die Ausgabe von nping..

    Und die Ausgabe zum 1. nping von tcpdump;

    D. h., in diesem Fall hat tcpdump die Funktion von htop übernommen, denn es hat ja kein packet loss gegeben.


    Hast Du die Möglichkeit, die Verbindung für tcpdump, von einem anderen Client-Gerät herzustellen, damit von dem Client-Gerät von dem der nping erfolgt, nur eine einzige Verbindung zustande kommt?

    Poste mal von deinem Linux PC die Ausgaben von:

    Code
    dig -x 192.168.178.48 +short
    dig -x 192.168.178.48 +short @192.168.178.1
    arp -av

    BTW: Brauchst Du auf deinem PI den avahi-daemon und triggerhappy?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hast Du die Möglichkeit, die Verbindung für tcpdump, von einem anderen Client-Gerät herzustellen, damit von dem Client-Gerät von dem der nping erfolgt, nur eine einzige Verbindung zustande kommt?

    Ich weiß nicht ob ich das jetzt richtig verstanden habe. Hab jetzt das tcpdum auf dem zu prüfenden Pis gestartet (192.168.178.48, DOOP2) und das Ping von einem anderen Pi (192.168.178.45. DOOP). Beide Pis spreche ich vom PC aus an. Ist das richtig so? Dann sieht die Ausgabe so aus:


    nping zum 1. Pi:

    und tcpdum auf dem 2. Pi:

  • Poste mal von deinem Linux PC die Ausgaben von:
    Code dig -x 192.168.178.48 +short dig -x 192.168.178.48 +short @192.168.178.1 arp -av

    BTW: Brauchst Du auf deinem PI den avahi-daemon und triggerhappy?

    Sorry, hier der 2. Teil:


    Zu Avahi und trigger happy kann ich keine Aussage machen. Ich habe es nicht installiert. Zumindest kann ich mich nicht daran erinnern.

  • Hab jetzt das tcpdum auf dem zu prüfenden Pis gestartet (192.168.178.48, DOOP2) und das Ping von einem anderen Pi (192.168.178.45. DOOP). Beide Pis spreche ich vom PC aus an.

    Auch jetzt noch kein packet loss.

    Hast Du mit dem anderen PI (192.168.178.45) auch diese Probleme mit der ssh-Verbindung (vom Linux PC als ssh-Client)?

    Funktioniert eine 1. ssh-Verbindung (d. h. ohne htop) vom anderen PI (192.168.178.45) auf den "Problem-PI" (192.168.178.48)?

    Code
    ssh -v pi@192.168.178.48

    ?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Sorry, hier der 2. Teil:


    Zu Avahi und trigger happy kann ich keine Aussage machen. Ich habe es nicht installiert. Zumindest kann ich mich nicht daran erinnern.

    OK, DNS und rDNS im (W)LAN der FritzBox funktioniert.

    Dann deinstalliere mal avahi bzw. th:

    Code
     sudo apt-get purge avahi-daemon triggerhappy
    sudo apt autoremove
    sudo apt-get -f install

    EDIT:


    Du hast auch einen 3. PI (.24). Hast Du damit auch dieses ssh-Problem?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Hast Du mit dem anderen PI (192.168.178.45) auch diese Probleme mit der ssh-Verbindung (vom Linux PC als ssh-Client)?

    Funktioniert eine 1. ssh-Verbindung (d. h. ohne htop) vom anderen PI (192.168.178.45) auf den "Problem-PI" (192.168.178.48)?
    Code ssh -v pi@192.168.178.48

    Ja, auch der andere Pi hat diese Problem, allerdings erst seit einer Woche von heute auf morgen, nach dem sichern seiner SD Karte und dem damit verbundenen Neustart.

    Auch wenn ich mich vom einen Pi auf den anderen draufschalte habe ich das "Schlafproblem".

    Wenn ich aus dieser Verbindung wieder rausgehe bekomme ich aber eine Meldung die ich auf dem PC noch nicht hatte:

    Code
    pi@DOOP2:~/nfc $ exit
    logout
    debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
    debug1: client_input_channel_req: channel 0 rtype eow@openssh.com reply 0
    debug1: channel 0: free: client-session, nchannels 1
    Connection to doop2 closed.
    Transferred: sent 2664, received 4672 bytes, in 57.9 seconds
    Bytes per second: sent 46.0, received 80.7
    debug1: Exit status 0
    pi@DOOP:~ $ 

    Nachtrag: Nein auf dem 3. Pi (das ist eine alter, da läuft noch ein Jessie drauf) gibt es keine Probleme, der reagiert ganz normal.

  • Ja, auch der andere Pi hat diese Problem, allerdings erst seit einer Woche von heute auf morgen, nach dem sichern seiner SD Karte und dem damit verbundenen Neustart.

    Die Meldungen nach exit sind OK und das kommt von der (-v) verbose-Option des ssh-Client.


    Was passiert beim sichern der SD-Karte? Wie hast Du diese Sicherung gemacht?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Was passiert beim sichern der SD-Karte? Wie hast Du diese Sicherung gemacht?

    Pi runterfahren, Karte entfernen und auf dem PC mit dd das Image runtergezogen. Anschließend mit pishrink verkleinert.

    Aufspielen einer Imagedatei auf die SD Karte mach ich mit der USB-Abbildherstellung die ich im Kontextmenü von Nemo bei Rechtsklick auf das Image vorgeschlagen bekomme.


    Das deinstallieren von Avahi und Trigger-happy hat leider auch keine Veränderung gebracht.

  • Aufspielen einer Imagedatei auf die SD Karte mach ich mit der USB-Abbildherstellung die ich im Kontextmenü von Nemo bei Rechtsklick auf das Image vorgeschlagen bekomme.

    Bei der Sicherung einer SD-Karte, werden die auf der SD-Karte vorhandenen Daten ja nicht verändert.

    Versuch mal mit einer "neuen" SD-Karte und der Sicherung von der "alten" SD-Karte.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Versuch mal mit einer "neuen" SD-Karte und der Sicherung von der "alten" SD-Karte.

    Gerne, dauert allerdings ein paar Tage, da ich keine mehr übrig habe. Bestelle gleich eine.

    Bis dahin Pause?

    Nachtrag: Geht schnell, ist bereits morgen da :)

  • Hallo,

    neue SD Karten sind angekommen. SanDisk Class10.

    Gleich mal ausprobiert. Image drauf, gleiches Spiel.

    Gut, dann holen wir uns doch mal die neueste Download Version Pi OS lite. Runtergeladen, headless Dateien hinzugefügt (ssh, Wlan), gestartet und

    .

    .

    .

    Gleiches Spiel :conf:


    update und upgrade gemacht, keine Änderung :wallbash:


    Sollte es tatsächlich an der Hardware liegen? Aber wieso funktioniert das wenn in einer 2. Verbindung htop oder watch -n1 iwconfig z. B. läuft? Das wiederum kann doch nichts mit Hardware zu tun haben.


    Ist das einfach ein Übel mit dem ich leben muss? Ich meine außer auf die ssh Verbindung scheint sich das ja auf nichts auszuwirken. Die Programme laufen ja stabil und reagieren auch direkt.

  • He he he, ich muss mich noch mal zu Wort melden. Da war ich mit meinem letzten Post zu voreilig.

    Ich habe auf beiden Karten den gleichen Hostnamen vergeben. Nachdem ich jetzt nochmal die alte Karte einlegte und über die Linuxkonsole (nicht über Putty) eine Verbindung herstellen wollte, bekam ich eine Meldung, dass für diesen Host bereits ein Schlüssel vergeben sei den ich erst löschen solle, was ich dann auch tat.

    Danach wurde wohl ein neuer Schlüssel erstellt und jetzt schläft das System auf der alten Karte auf einmal nicht mehr ein.

    Kann so etwas tatsächlich die Ursache gewesen sein?

    Hab grad bei der Google Suche die Meldung entdeckt, an die ich mich erinnere:

    Allerdings stand bei mir dann noch eine Zeile wie ich den Key lösche


    Falls das wirklich die Lösung ist würde ich das gerne bei meinem "Tür-Pi" auch machen. Leider habe ich mir die Zeile jetzt nicht gemerkt, mit der ich diesen Key gelöscht hatte. Im Netz habe ich diese gefunden:

    ssh-keygen -R hostname [-f known_hosts_file]leider funktioniert diese Zeile weder wenn ich "hostname" mit dem entsprechenden Hostnamen noch mit der IP ersetze. Und irgendetwas scheint grad auch mit der Forensoftware nicht zu stimmen, im Editor sieht das noch richtig aus

  • Du benutzt den Inline-Code anstelle von Code.


    Die Zeile, die da stand, bekommst du in der History mit

    Code
    history | grep ssh-keygen

    Da müsste dann im Ergebnis etwa Folgendes kommen:

    Code
    sudo ssh-keygen -f "/home/kubunt/.ssh/known_hosts" -R "meinraspberrypi.lan"
  • Du benutzt den Inline-Code anstelle von Code.

    Ich wollte den Inlinecode verwenden, aber nur für die eine Zeile und dann hat er im Editor egal was ich machte das Codefenster aufgemacht. und in der Vorschau stand dann der komplette Text mit drin obwohl der /tt Tag weiter oben gesetzt war... Sehr merkwürdig alles. :shy:



    history | grep ssh-keygen

    Da müsste dann im Ergebnis etwa Folgendes kommen:
    Code sudo ssh-keygen -f "/home/kubunt/.ssh/known_hosts" -R "meinraspberrypi.lan"

    Jepp genau das kam. Habs eben auf dem anderen Pi gemacht. Neuer Key wurde bei der Anmeldung gesetzt und...


    Aaah! Das scheint also tatsächlich daran gelegen zu haben.


    Hängt das jetzt tatsächlich mit den gleichen Hostnamen zusammen? Dann gewöhne ich mir das ab.


    rpi444 und Tigerbeere : Danke für eure Hilfe! Besonders natürlich dir rpi444, du hast dich da ja richtig rein gekniet.


    :danke_ATDE:

  • Aaah! Das scheint also tatsächlich daran gelegen zu haben.


    Hängt das jetzt tatsächlich mit den gleichen Hostnamen zusammen?

    Das habe ich mir auch direkt abgewöhnt. Jedes frische Image erhält bei mir einen eigenen Hostnamen, bevor die MicroSD-Karte in den Raspberry kommt.

  • Hängt das jetzt tatsächlich mit den gleichen Hostnamen zusammen? Dann gewöhne ich mir das ab.

    Du hast aber keine identische Hostnamen auf deinen PIs gehabt-

    Lt. Beitrag #23 waren die schon unterschiedlich:

    Code
    DOOP.fritz.box (192.168.178.45) auf b8:27:eb:8c:dd:b1 [ether] auf enp7s0
    DOOP2.fritz.box (192.168.178.48) auf b8:27:eb:a9:73:ee [ether] auf enp7s0
    raspberrypi.fritz.box (192.168.178.24) auf b8:27:eb:54:88:6c [ether] auf enp7s0

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Du hast aber keine identische Hostnamen auf deinen PIs gehabt-

    Nicht direkt, die stammen aber alle vom gleichen Image, da ist immer der gleiche Hostname drauf, den ich jedesmal nach dem Erststart abändere, und dann hatte ich auch mal die beiden Karten getauscht gehabt. Während ich am 3 Pi (Hostname Raspberrypi) nichts gemacht hatte. Und der ja auch dieses Problem nicht hatte.

  • Nicht direkt, die stammen aber alle vom gleichen Image, ...

    Was genau meinst Du mit, "die stammen aber alle vom gleichen Image"? Hast Du den Inhalt der SD-Karte kopiert/dupliziert und nicht geflasht?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Was genau meinst Du mit, "die stammen aber alle vom gleichen Image"? Hast Du den Inhalt der SD-Karte kopiert/dupliziert und nicht geflasht?

    Ich versuch es mal zu erklären.

    Ich habe 2 Pi Zeros. Der eine hängt an meiner Tür und dreht am Rad Schlüssel und der andere ist mein "Test"-Pi.

    Die "Schliess-Anlage" habe ich schon länger, die hat vorher der 3. Pi über 2 lange Lankabel bis an die Tür mitbedient. Hat dieses Jahr einen Kabelbruch gegeben, da beschloss ich die Tür Geschichte separat mit eine Zero zu machen.

    Der Tür-Pi ist also recht frisch im Einsatz, da hatte ich beim Installieren und konfigurieren der nötigen Software so einige Probleme. Deshalb hatte ich mir noch einen 2. Pi, den Test-Pi, besorgt, den hab ich hier mit gleicher Schaltung direkt am Arbeitsplatz aufgebaut.


    Als der Tür-Pi halbwegs stabil lief hatte ich diese Karte mit dd gesichert. und für den Test Pi auf eine andere Karte aufgespielt und den Hostnamen geändert. (Deswegen dieses DOOP1 und DOOP2)

    Wenn ich nun auf dem Test Pi etwas erfolgreich geändert/verbessert/neu gemacht hatte, hab ich dieses Image wiederum gesichert und auf den Tür-pi zurückgespielt. Und dann dort den Hostnamen wieder zurück geändert.

    Schätze mal, dass da mi der Zeit so einiges durcheinander gekommen ist. Putty hat mir zwar auch immer wieder mal eine Meldung gebracht, wenn ich bei einem neuen Image mit den gleichen Zugangsdaten reinwollte, da hab ich mir aber nichts bei gedacht. Erst als du mir gezeigt hattest, dass ich mich auch einfach über die Konsole des PCs verbinden kann hab ich ja mal mitbekommen was da alles ausgetauscht wird.


    Fazit: Da werde ich wohl meine chaotische Arbeitsweise doch etwas ändern müssen. Hatte mir nichts dabei gedacht. :daumendreh2:


    Zu deiner zweiten Frage: sichern mit dd, dann pishrink und Wiederaufspielen mit "Bootfahiges USB Medium erstellen" . Wenigstens da habe ich, glaube ich, alles richtig gemacht :) .


    So long


    Thorsten