Spannungsprobleme seit Verwendung des neuen Display

  • Hab auf meinem Raspi 2 bzw 3B ein neues Display im Einsatz. Führe die beiden Raspi an da die Probleme mit beiden gleich sind.

    Das neue Display ist folgendes von Waveshare

    Das Display selbst funktioniert prima. Nur sind die Spannungsprobleme dauerhaft. Der gelbe Blitz ist ständiger Begleiter. Selbst beim WLAn erscheint der Blitz. Die vorher funktionierende WLAn-Verbindung ist so schlecht, dass sie in er Regel überhaupt nicht aufgebaut wird. Alle zur Verfügung stehenden Netzteile schon ausprobiert (3 A sollten eigentlich ausreichen). Bringt alles nichts.

    Gemessen hab ich noch nichts. Weiss da nicht wo ich messen muss.

    Nun stört mich an dem Display eines. Warum kann man das nicht separat mit Spannung versorgen. Vielleicht sind dann die Probleme gelöst. Folgendes ist mir bei der Beschreibung des Display aber aufgefallen.

    Im Link gibt es eine Position "Demystifying Design Details". Dort erkennt man Lötpositionen die wie folgt beschrieben sind.

    Code
    5. USB and power input solder pads, breakout USB interface, easy for connecting external power supply

    Ich verstehe das so: Hier kann ich 5V zusätzlich für das Display anlegen. Bin mir da nur ein wenig unsicher. Hat das schon jemand gemacht und wenn ja wie.

    Jedenfalls ist das Display , welches an sich nicht schlecht ist, so nicht verwendbar.

    Könnt ihr einen Tipp geben.

    Danke

  • Was hast du denn sonst noch am USB des Pi angeschlossen?

    Ich habe ein Baugleiches Display, allerdings nicht von Waveshare.

    Zusammen mit einer SSD am USB des Pi habe ich auch Stromprobleme.


    Ich habe einen aktiven Hub dazwischen, an den ich das Display und die SSD angeschlossen habe und gut ist.

  • Hab es einfach mal versucht. Problem gelöst.

    Eine zusätzliche USB-Buchse direkt am Display angelötet und damit das Display mit Spannung zusätzlich versorgt. Der Blitz ist dauerhaft weg.

    Beim Einbau aber folgendes beachten. Nur 5v und GND anlöten. Verbindet man auch die beiden anderen Anschlüsse (DN und DP) dann funktioniert der Touch nicht mehr.

  • Welches Netzteil verwendest Du ??


    Viele Netzteile mögen zwar 3A bringen aber wenn die Spannung unter 4,8V unter Last springt, erscheint halt der Blitz ....

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Hatte zwei Netzteile von meine Xiaomi-Handys probiert . Waren beides Schnelladegeräte 3A. Brachte aber nichts.

    Jetzt hab ich zwei 0815 Teile (beide je 2A) angeschlossen und funktioniert alles prima. Halt mit der separaten Spannungsversorgung des Display.

  • Handy Ladegeräte sind in der Regel eh unbrauchbar, da die Spannung halt nicht stabil ist und das bei Handies auch keine Rolle spielt.


    Originales 3A Pi Netzteil kostet keine 10 Euro.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Handy Ladegeräte sind in der Regel eh unbrauchbar, da die Spannung halt nicht stabil ist und das bei Handies auch keine Rolle spielt.


    Originales 3A Pi Netzteil kostet keine 10 Euro.

    So ein Netzteil hab ich mittlerweile auch da. Nutze es aber trotzdem nicht. Meine Lösung ist für mich perfekt. Eine separate Spannungsversorgung des Display finde ich sowieso die bessere und sichere Lösung.