PIUPS+ startet Raspi immer neu

  • Raspi 2 mit PIUPS+ startet immer neu


    Hallo,

    seit ich vor 5 Tagen dem Raspi eine USV spendiert habe, fährt er ab und zu runter und startet dann gleich wieder neu.

    In Piupsmon.log sieht man dann, dass die Zeit zum Zeitpunkt des neu Startens ein paar Minuten weniger geworden ist?

    Außerdem stehen noch 2 Meldungen in Piupsmon.log:

    could not read from i2c bus

    could not write to i2c bus

    Manchmal startet er alle paar Minuten neu, ab und zu läuft er auch ne Std. oder länger durch.

    Ohne USV läuft er stabil.

    Die USV brauch ich nur zum runterfahren.

    Modell B2

    Raspbian 10 Buster

    Stromversorgung über Powerbank an INext

    LiIon Akku 3,7V 2600 mAh an INa

  • I2C-Bus nicht aktiviert?

    Code
    sudo raspi-config
    3 Interface Options
    P5 I2C

    Ich frag mich nur: Aber wie kommt er jetzt an die Spannung und den Strom?


    MfG


    Jürgen

  • Na über die Powerbank oben links im Bild

    Das Bild meinte ich nicht, ich meinte die Angaben in der Log-Datei.


    Ich muss mich mal mit meinen PIUSV+s unterhalten.


    Was steht bei Dir in der /etc/piupsmon/piupsmon.conf


    MfG


    Jürgen

  • Da sehe ich nichts. Hier mal eine meiner Konfigs:

    Code
    PowerOffTimer=15
    ShutdownTimer=600
    #ShutdownCmd=init 0
    ShutdownCmd=/usr/local/bin/allOff.sh
    LogLevel=error
    LogStatusDesc=1
    StatusChangedCmd=

    Bevor Du dich über das Script /usr/local/bin/allOff.sh wunderst:

    In der Anleitung ist eine Anordnung der elektronischen Bauteile auf der Platine.

    Sieh Dir mal unter der Lupe das Bauteil D3 etwas näher an.

    Wird das warm? War mit einer der häufigsten Ausfallursachen bei der Karte.


    MfG


    Jürgen

  • Wenn in der piupsmon.log steht:

    "piupsmon started"

    ist die Zeit meist 2 Minuten in der Vergangenheit


    021-07-24 21:42:08 [NOTICE] Shutdown timer: 61 / 65

    2021-07-24 21:42:09 [NOTICE] Shutdown timer: 62 / 65

    2021-07-24 21:42:10 [NOTICE] Shutdown timer: 63 / 65

    2021-07-24 21:42:11 [NOTICE] Shutdown timer: 64 / 65

    2021-07-24 21:42:12 [NOTICE] Shutdown timer: 65 / 65

    2021-07-24 21:42:12 [NOTICE] System shutdown!

    2021-07-24 21:40:44 [NOTICE] piupsmon started

    2021-07-24 21:48:19 [NOTICE] piupsmon started

    2021-07-24 21:58:13 [NOTICE] Status changed from 9 (primary power,charging) to 2 (battery power)

    2021-07-24 21:58:14 [NOTICE] Shutdown timer: 1 / 65

    2021-07-24 21:58:15 [NOTICE] Shutdown timer: 2 / 65

    2021-07-24 21:58:16 [NOTICE] Shutdown timer: 3 / 65

    2021-07-24 21:58:17 [NOTICE] Shutdown timer: 4 / 65

    2021-07-24 21:58:18 [NOTICE] Shutdown timer: 5 / 65

    2021-07-24 21:58:19 [NOTICE] Shutdown timer: 6 / 65

    2021-07-24 21:58:20 [NOTICE] Shutdown timer: 7 / 65

    2021-07-24 21:58:22 [NOTICE] Shutdown timer: 8 / 65

    2021-07-24 21:58:23 [NOTICE] Shutdown timer: 9 / 65

    2021-07-24 21:58:24 [NOTICE] Shutdown timer: 10 / 65

    2021-07-24 21:58:25 [NOTICE] Shutdown timer: 11 / 65

    2021-07-24 21:58:26 [NOTICE] Status changed from 2 (battery power) to 9 (primary power,charging)

    2021-07-24 21:56:30 [NOTICE] piupsmon started

    2021-07-24 22:03:11 [NOTICE] Status changed from 9 (primary power,charging) to 2 (battery power)

    2021-07-24 22:03:12 [NOTICE] Shutdown timer: 1 / 65

    2021-07-24 22:03:13 [NOTICE] Shutdown timer: 2 / 65


  • https://www.reichelt.de/raspbe…-usv--p169883.html?&nbc=1


    Unter dem Reiter Datenblätter, den Treiber hast Du installiert?


    MfG


    Jürgen

  • Das ist ein I2C-Pegelwandler mit dem bürgerlichen Namen PCA9306DCT.


    Und bevor Du fragst, ja, ich habe den Schaltplan, aber ich darf und werde den nicht veröffentlichen. Sorry


    Wie warm der wird, weiss ich nicht, ich kann keinen im Moment erreichen der hier in Betrieb ist. Alle zugebaut.


    Kannst Du den bei Reichelt umtauschen? Normalerweise sollte die einwandfrei funktionieren.


    MfG


    Jürgen

  • Ich werde morgen nochmal probieren und dann nächste Woche versuchen ihn umzutauschen.

    Am USB-Eingang startet er auch nicht von alleine wenn Spannung anliegt, er startet nur automatisch vom INext.

    Danke für deine Hilfe. :):thumbup:

    Ich schreib dann wie es weiter geht


    Tschau

  • Hab die USV heute am Raspi 4 gehabt.

    An dem hat sie auch nur teilweise funktioniert, runtergefahren hat sie den Raspi dort gar nicht.

    Entweder ist der Raspi nach Stromabschaltung sofort abgestürzt oder ewig über den Akku weitergelaufen.

    Ich schick das morgen zurück, die sollen das umtauschen.


    Tschau

  • Ich würde jetzt auf den Transistor V8 oder die Ansteuerung dazu tippen.


    Aber sieh Dir auch mal die S.USV mal näher an: https://s-usv.de/produkte/

    Ist zwar teurer, macht aber einen guten Eindruck. Ob man die komplett per Software abschalten kann weiß ich allerdings nicht.

    Sie hatte sogar auf meinen Vorschlag eine Option mit in die Client Software aufgenommen.

    War im Rahmen dieses Tuts: Monitoring Die S.USV


    Und die haben immer bei Problemen kompetent geantwortet, obwohl ein Namensvetter von mir denen das Leben schwer gemacht hat.

    (Die haben mich mal mit dem verwechselt, daher weiß ich das.)


    MfG


    Jürgen


    Edit: Nachtrag


    Die Optionen sind wohl noch immer drin: z.B.: S.22 ./susv -vin [0]

    oder S.33 Wie man die S.USV auf eine sichtbare I2C-Adresse wieder hinkriegt wenn man sie mal vergeigt hat.

  • So, ich habe jetzt mal auf einen 3B+ eine PIUSV+ installiert, sie läuft hardwaremäßig erstmal ohne Probleme.

    Nur der Treiber macht noch Sperenzchen, kann aber sein das das an Buster64 liegt.


    MfG


    Jürgen

  • Hallo,


    wollte nochmal schreiben was jetzt daraus geworden ist.

    Also, die neue USV von Reichelt zeigte fast das gleiche Verhalten wie die alte USV.

    Hab dann Jessie installiert, damit lief es fast fehlerfrei, außer als ich den Monitor wieder in Betrieb nahm,

    dann wurde der Raspi ab und zu wieder nicht richtig herunter gefahren.

    Es scheint damit zusammen zu hängen wie viel Strom der Raspi benötigt.

    Raspi mit LCD ohne Monitor funktioniert, er wird heruntergefahren, mit der Ausnahme dass die eingestellte Zeit

    bis zum herunterfahren manchmal nicht stimmt.

    Es funktioniert aber nur am iNext Eingang, am USB Anschluß geht es meist nicht.


    Tschau

  • Gerade gefunden: https://github.com/dehapama/piupsmonitor-raspberrypi


    Hat wohl jemand einen Treiber programmiert.

    Ob der funktioniert weiss ich aber (noch) nicht


    MfG


    Jürgen


    Edit: Erster Versuch unter Buster64 fehlgeschlagen:

  • Tja, man kanns nicht glauben aber ich habe einen neuen Batteriehalter gekauft

    an den man selber ein Kabel anlöten kann.

    Hab dann 2,5mm² Kabel angelötet.

    Seitdem funktioniert die USV (auch mit Monitor). :/

    Ich hatte das dünne Kabel schon lange in Verdacht. :thumbdown:

    Mit USB hab ich es leider noch nicht probiert, mach das aber demnächst noch. :)