InfluxDB startet nach reboot nicht mehr

  • Hallo, es geht um einen RPi Zero W mit Raspberry Pi OS Lite (buster). Darauf laufen Mosquitto, Grafana und InfluxDB und ein Python Script, statische IP-Adresse. Auf der SD-Karte nur bootcode.bin, Rest des OS auf USB-Stick.


    Influx wurde installiert wie folgt ( abgeschrieben bei Installing InfluxDB & Grafana on Raspberry Pi – Simon Hearne) :


    wget -qO- https://repos.influxdata.com/influxdb.key | sudo apt-key add -

    source /etc/os-release

    echo "deb https://repos.influxdata.com/debian $(lsb_release -cs) stable" | sudo tee /etc/apt/sources.list.d/influxdb.list

    sudo apt update && sudo apt install -y influxdb

    sudo systemctl unmask influxdb.service

    sudo systemctl start influxdb

    sudo systemctl enable influxdb.service


    Das Ganze läuft auch nach der Installation prima. Aber nach Neustarts des RPis - manchmal nach einem, dann wieder erst nach 10 -

    startet InfluxDB nicht mehr, bleibt hängen mit


    sudo systemctl list-units --type=service

    .......

    influxdb.service loaded activating start start InfluxDB is an open



    sudo journalctl -u influxdb.service sagt:


    -- Logs begin at Tue 2021-08-17 00:17:18 CEST, end at Tue 2021-08-17 12:03:10 CEST. --

    Aug 17 00:17:48 RpiC systemd[1]: Starting InfluxDB is an open-source, distributed, time series database...

    Aug 17 00:17:52 RpiC influxd-systemd-start.sh[441]: Merging with configuration at: /etc/influxdb/influxdb.conf

    Aug 17 00:17:52 RpiC influxd-systemd-start.sh[441]: ts=2021-08-16T22:17:52.372932Z lvl=info msg="InfluxDB starting" log_id=0W0GX3y0000 version=1.8.9

    Aug 17 00:17:52 RpiC influxd-systemd-start.sh[441]: ts=2021-08-16T22:17:52.379617Z lvl=info msg="Go runtime" log_id=0W0GX3y0000 version=go1.13.8 max

    Aug 17 00:17:52 RpiC influxd-systemd-start.sh[441]: ts=2021-08-16T22:17:52.574192Z lvl=info msg="Using data dir" log_id=0W0GX3y0000 service=store pa

    Aug 17 00:17:52 RpiC influxd-systemd-start.sh[441]: ts=2021-08-16T22:17:52.581821Z lvl=info msg="Compaction settings" log_id=0W0GX3y0000 service=sto

    Aug 17 00:17:52 RpiC influxd-systemd-start.sh[441]: ts=2021-08-16T22:17:52.587260Z lvl=info msg="Open store (start)" log_id=0W0GX3y0000 service=stor

    Aug 17 00:17:52 RpiC influxd-systemd-start.sh[441]: Merging with configuration at: /etc/influxdb/influxdb.conf

    Aug 17 00:17:53 RpiC influxd-systemd-start.sh[441]: ts=2021-08-16T22:17:53.052464Z lvl=info msg="Reading file" log_id=0W0GX3y0000 engine=tsm1 servic

    Aug 17 00:18:09 RpiC influxd-systemd-start.sh[441]: Failed to reach influxdb http endpoint at http://localhost:8086/health

    Aug 17 00:18:09 RpiC systemd[1]: influxdb.service: Control process exited, code=exited, status=1/FAILURE

    Aug 17 00:18:09 RpiC systemd[1]: influxdb.service: Failed with result 'exit-code'.

    Aug 17 00:18:09 RpiC systemd[1]: Failed to start InfluxDB is an open-source, distributed, time series database.

    Aug 17 00:18:10 RpiC systemd[1]: influxdb.service: Service RestartSec=100ms expired, scheduling restart.

    Aug 17 00:18:10 RpiC systemd[1]: influxdb.service: Scheduled restart job, restart counter is at 1.

    Aug 17 00:18:10 RpiC systemd[1]: Stopped InfluxDB is an open-source, distributed, time series database.

    Aug 17 00:18:10 RpiC systemd[1]: Starting InfluxDB is an open-source, distributed, time series database...

    Aug 17 10:39:13 RpiC influxd-systemd-start.sh[563]: Merging with configuration at: /etc/influxdb/influxdb.conf

    Aug 17 10:39:14 RpiC influxd-systemd-start.sh[563]: ts=2021-08-17T08:39:14.298374Z lvl=info msg="InfluxDB starting" log_id=0W0p4_UW000 version=1.8.9

    Aug 17 10:39:14 RpiC influxd-systemd-start.sh[563]: ts=2021-08-17T08:39:14.303342Z lvl=info msg="Go runtime" log_id=0W0p4_UW000 version=go1.13.8 max

    Aug 17 10:39:14 RpiC influxd-systemd-start.sh[563]: ts=2021-08-17T08:39:14.487494Z lvl=info msg="Using data dir" log_id=0W0p4_UW000 service=store pa

    Aug 17 10:39:14 RpiC influxd-systemd-start.sh[563]: ts=2021-08-17T08:39:14.493591Z lvl=info msg="Compaction settings" log_id=0W0p4_UW000 service=sto


    Und das offensichtlich in einer Schleife.


    Nach


    sudo apt-get purge --auto-remove influxdb

    sudo rm -rf /var/lib/influxdb


    und Neuinstallationvon Influx wie oben geht es manchmal wieder (allerdings sind dann natürlich die Daten weg). In der Regel ist aber eine komplette Neuinstallation des OS erforderlich


    Eine andere Fehlermeldung taucht auch mal auf:


    pi@RpiC:~ $ sudo systemctl status influxdb.service

    ● influxdb.service - InfluxDB is an open-source, distributed, time series database

    Loaded: loaded (/lib/systemd/system/influxdb.service; enabled; vendor preset: enabled)

    Active: failed (Result: exit-code) since Tue 2021-08-17 13:39:37 CEST; 36min ago

    Docs: https://docs.influxdata.com/influxdb/


    Aug 17 13:39:36 RpiC systemd[1]: influxdb.service: Service RestartSec=100ms expired, scheduling restart.

    Aug 17 13:39:36 RpiC systemd[1]: influxdb.service: Scheduled restart job, restart counter is at 738.

    Aug 17 13:39:37 RpiC systemd[1]: Stopped InfluxDB is an open-source, distributed, time series database.

    Aug 17 13:39:37 RpiC systemd[1]: influxdb.service: Start request repeated too quickly.

    Aug 17 13:39:37 RpiC systemd[1]: influxdb.service: Failed with result 'exit-code'.

    Aug 17 13:39:37 RpiC systemd[1]: Failed to start InfluxDB is an open-source, distributed, time series database.



    Das habe ich ca 20 mal durchgespielt, ist also reproduzierbar. Gleiches Verhalten, wenn das gesamte OS und alles andere auf der SD-Karte installiert ist.


    Im Internet habe ich an mehreren Stellen gefunden, dass es Berechtigungsprobleme geben soll, die dort empfohlenen Befehle helfen aber auch nicht. Und wie gesagt, es funktioniert ja auch einige Male - die grundsätzlichen Berechtigungen müssen also mal gepasst haben.


    Kennt jemand eine Lösung? :danke_ATDE:

    Edited 3 times, last by rohowen ().

  • Moin rohowen,


    was passiert denn wenn du Grafana und influxdb mit sudo systemctl stop xxx erstmal stoppst und dann erst influxdb startest.

    Kontrolle mit systemctl status influxdb und dann Grafan startest?


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Bernd666 danke für die Reaktion!

    habe System gestartet, dabei werden ja grafana und influxdb von systemd gestartet. Beide beendet - mit systemctl überprüft - und neu gestartet.

    Ergebnis:

    pi@RpiC:~ $ sudo systemctl start influxdb.service

    Job for influxdb.service failed because the control process exited with error code.

    See "systemctl status influxdb.service" and "journalctl -xe" for details.


    pi@RpiC:~ $ sudo systemctl status influxdb.service

    ● influxdb.service - InfluxDB is an open-source, distributed, time series databa

    Loaded: loaded (/lib/systemd/system/influxdb.service; enabled; vendor preset:

    Active: activating (start) since Tue 2021-08-17 23:57:36 CEST; 4s ago

    Docs: https://docs.influxdata.com/influxdb/

    Cntrl PID: 3582 (influxd-systemd)

    Tasks: 8 (limit: 877)

    CGroup: /system.slice/influxdb.service

    ├─3582 /bin/bash -e /usr/lib/influxdb/scripts/influxd-systemd-start.s

    ├─3583 /usr/bin/influxd -config /etc/influxdb/influxdb.conf

    └─3613 curl -k -s -o /dev/null http://localhost:8086/health -w %{http


    Aug 17 23:57:36 RpiC systemd[1]: Starting InfluxDB is an open-source, distribute

    Aug 17 23:57:36 RpiC influxd-systemd-start.sh[3582]: Merging with configuration

    Aug 17 23:57:36 RpiC influxd-systemd-start.sh[3582]: ts=2021-08-17T21:57:36.6671

    Aug 17 23:57:36 RpiC influxd-systemd-start.sh[3582]: ts=2021-08-17T21:57:36.6806

    Aug 17 23:57:36 RpiC influxd-systemd-start.sh[3582]: ts=2021-08-17T21:57:36.7904

    Aug 17 23:57:36 RpiC influxd-systemd-start.sh[3582]: ts=2021-08-17T21:57:36.8011

    Aug 17 23:57:36 RpiC influxd-systemd-start.sh[3582]: ts=2021-08-17T21:57:36.8055

    Aug 17 23:57:36 RpiC influxd-systemd-start.sh[3582]: ts=2021-08-17T21:57:36.9262

    Aug 17 23:57:37 RpiC influxd-systemd-start.sh[3582]: Merging with configuration


    pi@RpiC:~ $ sudo journalctl -xe -u influxdb

    -- Subject: A stop job for unit influxdb.service has finished

    -- Defined-By: systemd

    -- Support: https://www.debian.org/support

    --

    -- A stop job for unit influxdb.service has finished.

    --

    -- The job identifier is 3231 and the job result is done.

    Aug 17 23:58:35 RpiC systemd[1]: Starting InfluxDB is an open-source, distribute

    -- Subject: A start job for unit influxdb.service has begun execution

    -- Defined-By: systemd

    -- Support: https://www.debian.org/support

    --

    -- A start job for unit influxdb.service has begun execution.

    --

    -- The job identifier is 3231.

    Aug 17 23:58:35 RpiC influxd-systemd-start.sh[3839]: Merging with configuration

    Aug 17 23:58:35 RpiC influxd-systemd-start.sh[3839]: ts=2021-08-17T21:58:35.7101

    Aug 17 23:58:35 RpiC influxd-systemd-start.sh[3839]: ts=2021-08-17T21:58:35.7328

    Aug 17 23:58:35 RpiC influxd-systemd-start.sh[3839]: ts=2021-08-17T21:58:35.8422

    Aug 17 23:58:35 RpiC influxd-systemd-start.sh[3839]: ts=2021-08-17T21:58:35.9164

    Aug 17 23:58:35 RpiC influxd-systemd-start.sh[3839]: ts=2021-08-17T21:58:35.9190

    Aug 17 23:58:36 RpiC influxd-systemd-start.sh[3839]: ts=2021-08-17T21:58:36.0513

    Aug 17 23:58:36 RpiC influxd-systemd-start.sh[3839]: Merging with configuration

    lines 2897-2919/2919 (END)


    Das sag mir leider überhaupt nichts.



  • Moin rohowen,


    man kann keine eindeutige Fehlerhinweise erkennen.

    Ich würde nun schrittweise vorgehen...


    - System aufsetzten und einrichten

    - Influxdb installieren und starten und enablen.

    - Reboot und Kontrolle ob die DB gestartet ist und auch noch läuft.

    - Grafana installieren.

    - Reboot und vorherige Kontrolle

    - Grafana und Influxdb einrichten

    - Reboot und Kontrolle


    Irgendwann wird der Fehler auftauchen und dann hast du einen Ansatzpunkt zur Suche.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd666,

    habe System komplett neu aufgesetzt, InfluxBB installiert und die Sequenz

    • Influx checken
    • sudo reboot

    10 x ausgeführt. War alles gut.

    Dann grafana installiert, gleiche Sequenz. Beim 3. Mal der bekannte Fehler mit Influx.

    Dann Influx remove/install -> 10 x die Sequenz: alles gut.


    Das hatte ich aber auch schon so erlebt, dass eine Neuinstallation nichts nutzte.


    Erinnert mich an eine Situation unter Windows, als ein Tool zufällig und sporadisch im Betrieb einen registry-key falsch setzte und dann den Dienst verweigerte. Zum Glück gab's ne Anleitung, welcher key es war.


    Ich nehm das jetzt einfach so hin. Danke für das Kümmern! :danke_ATDE:

  • Moin rohowen,


    hast du denn schon die Datenbank mit Grafana verknüpft? Sprich in Grafana schon was eingerichtet?


    Ich habe auf meinem Testsystem mal influxdb und Grafana installiert. Im Moment rennt es ohne Probleme.


    Magst du mir schreiben was du da gemacht hast? Oder belässt du es dabei?


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • moin moin Bernd666,

    ich nehme alles zurück und behaupte das Gegenteil:


    es ist wohl doch ein Berechtigungsproblem, allerdings ein skurriles.


    Korrektur: siehe unten


    Nachdem der Fehler wieder auftrat, habe ich mal nicht neu installiert, sondern versucht, InfluxDB manuell mit "influxd" zu starten. Kam:


    run: open server: open tsdb store: mkdir /var/lib/influxdb/data/_internal/_series: permission denied.

    Dann "sudo influxd" und alles war ok.


    Aber warum kam der Fehler erst nach 23 reboots und bis dahin ging alles gut?


    In Troubleshoot systemd errors | InfluxDB OSS 1.8 Documentation (influxdata.com) findet man dann den Befehl:


    sudo chown -R influxdb:influxdb /var/lib/influxdb/*


    der genau dieses Problem lösen soll. Den hatte ich aber schon vorher mal gefunden und da hat er nicht funktioniert. Ich kann jetzt nur abwarten, ob es diesmal stabil bleibt.


    Korrektur: beim nächsten reboot wieder der gleiche Fehler:      influxdb.service loaded activating start start InfluxDB is an open-s.........

    Startversuch mit influxd führt zu: run: open server: listen: listen tcp 127.0.0.1:8088: bind: address already in use

    Dann sudo systemctl stop influxdb.service und sudo influxd und es läuft wieder.


    Mein größtes Problem ist, dass ich einen fertig konfigurierten RPi an ein Umweltprojekt verschicken will und dann keinen Zugriff mehr darauf habe. Es muß also stabil laufen, und das kann ich so nicht sicherstellen.



    PS.: ich habe versucht, mich in der RPi-Plauderecke anzumelden. Die Bestätigungsmail kommt aber trotz wiederholter Versuche nicht bei mir an, und nochmal anmelden geht auch nicht. Schade.

    Edited once, last by rohowen ().

  • Moin rohowen,


    wie geschrieben, bei mir geht es.

    Darum meine Frage:

    hast du denn schon die Datenbank mit Grafana verknüpft? Sprich in Grafana schon was eingerichtet?

    oder eine feste IP schon eingerichtet?


    73 de Bernd


    //EDIT

    Startversuch mit influxd führt zu: run: open server: listen: listen tcp 127.0.0.1:8088: bind: address already in use

    Wieso PORT 8088??? Bei mir ist es der Port 8086!!

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666 ().

  • moin moin Berd666,


    im beschriebenen Fall hatte ich noch nichts mit Grafana gemacht, nur installiert und als Service eingerichtet. Ich hatte den Fehler aber auch schon nachdem Grafana auf InfluxDB zugegriffen hatte (ich kämpfe seit fast 3 Wochen mit dem Problem und habe wohl alle denkbaren Szenarien ausprobiert).


    Zu dem Port: Influx scheint beide zu nutzen:



    Dazu gibt es Internet auch etliche Posts, allerdings habe ich keine brauchbare Erklärung gefunden. Grafana jedenfalls greift über 8086 zu.


    Ich habe inzwischen das Ganze neu installiert und im Moment läuft es auch. Mein Problem ist ja, dass es nicht bootfest ist und nach einer variablen Anzahl von Neustarts InfluxDB nicht startet. Ich habe ja den Fehler beim - echt dokumentierten - 23. Neustart erlebt!


    Inzwischen ist mein - nein nicht Kenntnis- sondern Ahnungssstand folgender:

    Es gibt 2 Fehlerarten:

    Die erste - der Berechtigungsfehler - entsteht, wenn ich dummerweise InfluxDB manuell als user Pi starte. Dann legt Influx irgendwelche Dateien an, auf die der Dienst beim nächsten Start über systemd nicht zugreifen kann. Wird durch Neuinstallation von Influx behoben.

    Die zweite Fehlerart scheint zu entstehen, wenn beim Runterfahren des Systems etwas nicht sauber zurückgesetzt wird. Ich habe mal flüchtig in einem Log gesehen, dass eine Start?datei (vom letzten Lauf?) im Wege war. Leider habe ich nicht geschaltet und das nicht aufgeschrieben und nun finde ich es nicht wieder.

    Das kann ich bisher nur durch Neuinstallation des ganzen Systems beheben.

    Und ich suche nun nach dem, was beim Runterfahren zufällig und manchmal nicht sauber läuft, um gezielt dasjenige zurückzusetzen.


    suchende Grüße

    rohowen

  • Moin rohowen,


    du hast noch Mosquitto an?


    Wegen des Startens von influxdb, mach es immer mit sudo systemctl start influxdb.service.

    Du hattest irgendwo die Fehlermeldung... Ah, da ist sie.

    Aug 17 00:18:09 RpiC influxd-systemd-start.sh[441]: Failed to reach influxdb http endpoint at http://localhost:8086/health

    Darum meine Frage, weil hier der Port 8086 angegeben wird, ob du schon was mit der IP gemacht hast.

    Wenn ich bei mir in einer Konsole den Befehl influx eingebe, kommt folgendes


    Code
    Connected to http://localhost:8086 version 1.8.9
    InfluxDB shell version: 1.8.9
    > 

    Speicher doch mal den Startverlauf von journalctl -u influxdb.service wenn es geklappt hat und einmal beim Fehler.Ev. siehst du da was.

    Ansonsten bin ich auch langsam ratlos.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • moin moin Berd666

    habe gerade gefunden, dass Influxdb den Port 8086 für HTTP-Zugriffe von außen nutzt und 8088 für RPC für eigene interne Zwecke.


    Ich habe auch eine ellenlaaange Konversation in einem Forum gefunden, wo einer genau den gleichen Fehler hatte:


    influxdb.service: Start request repeated too quickly.


    Die haben das auch nicht gelöst.


    Nochmals vielen Dank und gute Nacht

    rohowen

  • Rest des OS auf USB-Stick

    Ihr habt ja schon viel versucht, aber ich würde als erstes diese Variable mit dem USB-Stick entfernen und es dann nochmal probieren. Gibt es einen Grund, warum du vom USB-Stick und nicht von der SD-Karte booten willst?


    Dann wäre noch der Inhalt von /etc/influxdb/influxdb.conf interessant, falls da ein paar Zeilen noch nicht aus-auskommentiert wurden.

    Kelvin

  • Hallo Kelvin,


    das OS ist auf einem USB-Stick (genauer auf einer USB-SSD), um die Daten vor Verlust bei Versagen der SD-Karte zu bewahren. Ich habe da ganz schlechte Erfahrungen machen müssen. InfluxDB schreibt ja ungeheure Mengen von Logs und da ist die SD-Karte schnell hinüber.


    Das Szenario - alles auf SD-Karte - habe ich testhalber auch schon probiert - gleiche Fehlersituation.


    Und noch mal: der Fehler

    run: open server: open tsdb store: mkdir /var/lib/influxdb/data/_internal/_series: permission denied

    wenn man die Datenbank mit blanken influxd als user pi startet, beruht auf eigener Dummheit. Habe ich gelernt. Abgehakt.


    Der andere Fehler Start request repeated too quickly ist interessanter. Ich habe just einen Hinweis

    (https://serverfault.com/questi…y-refusing-to-start-limit)

    gefunden, dass er an einem unguten Zusammenwirken des influx-services, systemd und dem RPi-Zero liegen könnte.

    Ich reime mir das so zusammen, dass der RPi-Zero es in der Mehrzahl der Fälle so eben und eben schafft, den influxdb-service im erforderlichen zeitlichen Rahmen unter der Kontrolle von systemd zu starten, manchmal aber auch nicht. Und dann kennzeichnet systemd den Service als krank und das wars dann.

    Es scheint einen Befehl zu geben systemctl reset-failed <service name>, das zu heilen. Aber gerade jetzt habe ich nicht die Fehlersituation um das zu testen. Und provozieren will ich ihn im Moment nicht, mein so schön laufendes Testsystem brauche ich.


    Und den RPi-Zero kann ich nicht gegen einen leistungsstärkeren Pi austauschen. Er dient im monatelangen Dauerbetrieb als stromsparender Sammler und Visualisierer von Daten, die er von etlichen Sensoren über Mosquitto erhält. Und die Kombination Zero, infllux, mosquitto, grafana habe ich schon problemlos an anderer Stelle in Produktion. Nur neu gestartet habe ich das noch nicht so oft. Die jetzige Installation wird weit entfernt aufgestellt, da habe ich getestet, ob sie auch widerstandsfähig ist und da hatte ich den Salat.


    Die influxdb.conf habe ich angehängt. Sie ist aber völlig so, wie sie installiert wurde. Weißt du, wie man das Logging sicher ausschaltet?

  • InfluxDB schreibt ja ungeheure Mengen von Logs und da ist die SD-Karte schnell hinüber.


    Das Szenario - alles auf SD-Karte - habe ich testhalber auch schon probiert - gleiche Fehlersituation.

    Von wie vielen Jahren Einsatz sprechen wir denn? Ich schreibe seit 2 Jahren einige Messwerte auf meine SD-Karte und habe nebenbei noch den ioBroker laufen. Je nach Wichtigkeit der Messwerte, würde ich das OS auf der SD-Karte laufen lassen und die Datenbank außerhalb auf einem USB-Stick speichern (oder eben der USB-SSD, wobei das schon Perlen vor die Säue wäre, wenn du dir da schon was schickes geholt hast).


    Und die Kombination Zero, infllux, mosquitto, grafana habe ich schon problemlos an anderer Stelle in Produktion.

    Dumme Frage: Hast du damals was anders gemacht, als heute? 😅 Welche Version von InfluxDB läuft dort? OS auch auf externer USB-SSD?


    Die influxdb.conf habe ich angehängt. Sie ist aber völlig so, wie sie installiert wurde. Weißt du, wie man das Logging sicher ausschaltet?

    In Zeile 371 könntest du testweise das # entfernen und debug anstelle von info schreiben. Vielleicht spuckt dir Influx beim Starten noch mehr Infos aus.



    Was ist aus dem Fehler Failed to reach influxdb http endpoint at http://localhost:8086/health geworden?


    Nachtrag, bevor ich es überhaupt abgesendet habe: Habe eben an meiner Config gespielt und jetzt auch den Fehler mit http://localhost:8086/health 😅

    Kelvin

  • Was ein Scheiß, jetzt hänge ich da auch schon wieder seit einer Stunde dran, um das bei mir zu fixen :lol: Scheint aber ein bekanntes Problem zu sein, wenn man nach langer Zeit ein Update auf 1.8.9 gemacht hat (wie ich und seitdem habe ich auch keinen Neustart mehr gehabt. Spätestens beim nächsten Stromausfall hätte ich es dann bemerkt) oder Influx mit einem Pi nutzt, der kein 4er ist (wie in unserem Fall. Du hast den Zero W, ich den 3B+). Das Update 1.8.10 ist schon auf dem Weg und soll das Problem lösen. Hat was mit den Berechtigungen von /usr/lib/influxdb/scripts/influxd-systemd-start.sh zu tun und scheinbar funktioniert Version 1.8.9, wenn man dieses Shell-Skript von Version 1.8.7 nimmt.

    Kelvin

  • oder Influx mit einem Pi nutzt, der kein 4er

    Ich lese hier interessiert mit da ich denselben Setup bei mir habe: Influxdb + Telegraf, Grafana und mosquitto. Bei mir laeuft 1.8.9-1 ohne Probleme auf einem Pi4. Heisst Deine Bemerkung Du hast rausgefunden dass das Problem nicht bei einem Pi4 existiert oder muss ich damit rechnen dass das Problem bei mir auch nach einem Restart auftritt?

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :shy: Bei mir tut das automatisch raspiBackup ;)

  • Ich lese hier interessiert mit da ich denselben Setup bei mir habe: Influxdb + Telegraf, Grafana und mosquitto. Bei mir laeuft 1.8.9-1 ohne Probleme auf einem Pi4. Heisst Deine Bemerkung Du hast rausgefunden dass das Problem nicht bei einem Pi4 existiert oder muss ich damit rechnen dass das Problem bei mir auch nach einem Restart auftritt?

    Selbst getestet habe ich nicht, weil ich hier gerade keinen Pi 4 rumliegen habe, an dem ich "spielen" könnte. Ich grase aber das Internet nach dem gleichen Problem ab und bin auf das hier gestoßen: https://administrator.de/conte…649770#comment-1152714014

    Dort steht, dass sein 2er und 3er Pi Probleme mit 1.8.9 haben, beim 4er aber alles läuft. Ich versuche es jetzt auch mal mit dem alten Shell-Skript, das dort im Thread zu finden ist (https://administrator.de/conte…649770#comment-1150990735).


    Seit Mitte Juli gibt es ein paar Issues und Pull Requests zu influxd-systemd-start.sh, beginnend mit 1.8.7: https://github.com/influxdata/…=influxd-systemd-start.sh



    EDIT: Das mit dem alten Skript hat tatsächlich funktioniert!

    Hier nochmals aus Version 1.8.7:


    Was ich gemacht habe:

    Kelvin

    Edited once, last by Kelvin ().

  • Moin!


    Danke an Kelvin für seine Forschung!!!


    Ich habe es mit einem 4er getestet. Hätte wohl doch den Zero nehmen sollen. Ist aber egal.

    Hauptsache der Grund ist gefunden und eine Lösung ist auch da.


    Was sagst du, rohowen, alles gelöst?


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • rohowen Eine Frage noch, auch wenn das hier eher OT ist. Hast Du einen anderen Mailprovider als den, mit dem Du die Mailadresse in der Plauderecke angegeben hast? (Umständlich formuliert, aber ich wollte den Namen nicht nennen ;) )


    Anders gefragt: Hast Du evtl. auch eine GMX o.ä. Mailadresse, mit der Du die Anmeldung nochmals versuchen könntest?


    //Edit Bernd666 Die Erklärung ist jetzt in der Plauderecke. :)