InfluxDB startet nach reboot nicht mehr

  • Moin!


    ich habe auch ein Echtsystem mit Grafana und influxdb am Start. Auf einen 3B. Und das rennt.


    Habe mich gewundert warum ich nich tauch den Fehler habe....

    Code
    Connected to http://localhost:8086 version 1.6.4
    InfluxDB shell version: 1.6.4

    Grund, ich habe keinen Eintrag für influxdb in /etc/apt/sources.list.d/  :) Muss ich damals anders installiert haben.

    Und das lass ich dann auch erstmal.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • ich habe auch ein Echtsystem mit Grafana und influxdb am Start. Auf einen 3B. Und das rennt.

    Ich glaube 1.6.4 (o.ä.) hatte ich vorgestern auch noch, dann habe ich nach sehr langer Zeit mal alles auf den neusten Stand gebracht und bin bei 1.8.9 gelandet. Wäre wohl auch weiterhin gut gegangen, weil ich das System so gut wie nie neustarten muss.


    Und das lass ich dann auch erstmal.

    Ist auch meine Empfehlung 😅 Never change a running system.


    Echtsystem mit Grafana

    P.S. Grafana gibt es jetzt auch schon in der Version 8 und nach dem Update musste ich erstmal meine ganzen Graphen einzeln umstellen, damit sie zur neuen Version passen (geht auch ohne, aber irgendwann muss man es mal machen). Meine schicken Graphen für's Wetter (2x Temperatur, 1x Luftfeuchte; mit speziellen Overrides zur Darstellung) kann ich noch nicht umstellen, weil Grafana sich da blöd anstellt. Ist aber zum Glück überwiegend rückwärtskompatibel.

    Kelvin

  • Hallo an alle,


    ganz toll vielen Dank! Ich sehe wieder Licht am Ende des Tunnels!

    Danke an Kelvin für seine Forschung!!!

    Und ich schließe mich da vollinhaltlich an!!!!

    Von wie vielen Jahren Einsatz sprechen wir denn? Ich schreibe seit 2 Jahren einige Messwerte auf meine SD-Karte


    Ich hab leider weniger gute Erfahrung: nach ca 4 Monaten an meinen Umweltsensoren war meine (allerdings nicht neue) SD-Karte zerschrieben und alle Daten waren weg - auch die sensationellen Feinstaubwerte von Sylvester ;) !

    Und diesmal geht nicht um meine eigenen Daten - ich bin in einem Umweltprojekt nur der Datenvisualisierer - da will ich 157%ig sicher gehen.


    Auf meinem "Produktions" RPi Zero läuft Influx 1.8.6 und das stabil. Und nach dem Crash auch mit USB-SSD. Allerdings habe ich den nach der Installation wohl noch nicht rebootet.


    Anders gefragt: Hast Du evtl. auch eine GMX o.ä. Mailadresse, mit der Du die Anmeldung nochmals versuchen könntest?

    ja, versuche ich


    Und noch mal ganz vielen Dank an alle! :danke_ATDE::danke_ATDE::danke_ATDE:

    rohowen

  • ich habe in der Systemd Konfig /etc/systemd/system/influxd.service folgendes auskommentiert:

    Code
    #Type=forking

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert :shy: Bei mir tut das automatisch raspiBackup ;)