Boot nur mit Netzwerk

  • Hallo zusammen

    Ich habe Änderungen an meinem Netzwerk vorgenommen und wollte mein Raspberry PI anpassen. Dabei habe ich aber die Änderungen noch nicht durchgeführt und die Funktion "only boot with network connected" aktiviert - logischerweise bootet jetzt mein Raspberry PI nicht mehr... :wallbash:

    Wie kann ich das jetzt rückgängig machen oder fixen ohne einen kompletten Reset?


    Schon mal Danke für die Hilfe!


    Gruss

    Silverhammer

  • Hallo silverhammer,


    willkommen im Forum!

    ie Funktion "only boot with network connected"

    Meinst Du Damit "Network at Boot - Select wait for network connection on boot"? im raspi-config?


    Falls ja, dann ist, soweit ich das richtg sehe, die Datei /etc/systemd/system/dhcpcd.service.d/wait.conf dafür verantwortlich. Wird diese gelöscht, dann sollte diese Funktion deaktiviert sein.


    Hier der entsprechende Teil des raspi-config-Skripts von meinem Test-RPi zu Nachlesen:


    Mounte also Deine SD-Karte mit einem Linux-Computer und lösche (oder umbenennen könnte evtl. auch ausreichen) die oben genannte Datei. Ein Linux-Computer könne übrigens auch einfach eine andere SD-Karte im RPi sein. ;)

  • Wenn es ein Pi4 ist dürfte es einfacher sein, die Netzwerkänderung (Dein Netzwerk) zum Starten des Pi zurückzusetzen, da Du SD Boot und USB Boot ausgeschaltet hast und das Pi-4 EEPROM nur ein Netzwerk Boot mit den im EEPROM hinterlegten Parametern zulässt.


    Sonst siehe https://www.raspberrypi.org/documentation/ Configuration bzw. Remote Access --> Network boot Your Raspberry Pi



    Servus !

    RTFM = Read The Factory Manual, oder so

  • hyle Danke für die Antwort. Ich habe einen Windows10 und leider kein Linux. Die von dir genannte Datei sehe ich gar nicht erst im Boot-Bereich der SD-Karte. Um auf den Pfad /etc/... zugreifen zu können müsste ich doch den Raspberry starten können? Das geht im Moment aber nicht. Ideen?


    RTFM auch dir erst mal Danke. Es ist ein PI4, doch in der Dokumentation finde ich die Netzwerkänderung nicht... kannst du mir da nochmals aushelfen?

  • Ok das Problem ist gelöst - ich habe die Netzwerkanpassungen rückgängig gemacht und die Option im Rapsberry deaktiviert.
    Trotzdem würde mich euer Lösungsansatz noch interessieren :)

  • Um auf den Pfad /etc/... zugreifen zu können müsste ich doch den Raspberry starten können? Das geht im Moment aber nicht. Ideen?

    Genau, deshalb Linux. Mit einer zweiten SD-Karte oder einem USB-Stick, auf die/den Du ein Raspberry Pi OS flashen könntest und diese(n) statt der "guten" SD in dem RPi verwendest, hättest Du ein Linuxsystem. ;)

    Dann könntest Du die "gute" SD mit Hilfe eines Cardreaders am RPi mounten und die Datei (deren Pfad dann ein anderer ist, vermutlich unter /media/pi/root/etc/systemd/system/dhcpcd.service.d/wait.conf) löschen oder umbenennen.



    //Edit


    Ah, hat sich überschnitten mit meinem schreiben.

    Ok das Problem ist gelöst

    Das ist schön! Ging es eigentlich ums warten auf das Netzwerk oder um Netzwerkboot?

  • Trotzdem würde mich euer Lösungsansatz noch interessieren

    "Bis Netzwerk vorhanden" bedeutet nicht, dass der PI eine Verbindung zu anderen Systemen bekommt.

    HIer reicht einfach nur ein aktiver Netzwerkport (elner Port bei einem Switch zum Beispiel, oder auch eine Verbindung zu einem anderen Rechner (LAN-Port an LAN-Port) vollkommen aus.

    Selber denken,
    wie kann man nur?