Raspbi 3b keine Verbindung mit WLAN möglich

  • Allerdings bleibt rästelhaft mit was die Verbindung hergestellt wird, da die IP und gateway nichts mit meinem Netz zu tun haben.

    Das Herstellen einer WLAN-Verbindung hat nichts mit einer IP-Adresse oder mit einem Netz zu tun. Das ist so ähnlich wie das Herstellen einer Kabelverbindung, zwischen deinem PI und deiner FritzBox. Das (klassische) zuweisen (oder nicht zuweisen) der IP-Adresse _per DHCP_, kann immer erst nach dem Herstellen der WLAN- oder der Kabel-Verbindung, statt finden.


    Poste mal von deinem PI3, die Ausgaben von:

    Code
    modinfo brcmfmac | grep -i parm
    ps aux | grep -i [w]pa

    Poste mal detailliert, wie das WLAN deiner FritzBox konfiguriert ist:

    2.4 und 5.0GHz?

    Anzahl der SSIDs?

    Autokanal?

    Wifi-Sendestärke?

    MAC-Adressen-Filter?

    etc.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Poste mal von deinem PI3, die Ausgaben von:
    Code modinfo brcmfmac | grep -i parm ps aux | grep -i [w]pa



    Code
    pi@pi:~ $ modinfo brcmfmac | grep -i parm
    parm:           txglomsz:Maximum tx packet chain size [SDIO] (int)
    parm:           debug:Level of debug output (int)
    parm:           p2pon:Enable legacy p2p management functionality (int)
    parm:           feature_disable:Disable features (int)
    parm:           alternative_fw_path:Alternative firmware path (string)
    parm:           fcmode:Mode of firmware signalled flow control (int)
    parm:           roamoff:Do not use internal roaming engine (int)
    parm:           iapp:Enable partial support for the obsoleted Inter-Access Point Protocol (int)
    parm:           ignore_probe_fail:always succeed probe for debugging (int)
    Code
    pi@pi:~ $ ps aux | grep -i [w]pa
    root       427  0.0  0.3  10744  3756 ?        Ss   14:31   0:00 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
    root       608  0.1  0.4  11132  4268 ?        Ss   14:31   0:07 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext


    • Zu Testzwecken im Moment nur 2,4
    • 1 SSID
    • Nein, zu Testzwecken auf manuel mit der geringsten Auslastung
    • -49dBm
    • Nein, alle neuen Geräte werden zugelassen
    • -
  • Zu der Frage wie es zu der IP 169.254.x.x kommt:

    Das ist eine APIPA Adresse, die ein auf DHCP eingestelltes Netzwerkgerät dann annimmt, wenn kein DHCP Server gefunden wird.

    Da Du offenbar keine WLAN Verbunding herstellen kannst, kann über WLAN auch der DHCP Server nicht erreicht werden.

    Irgendwann erhält dann die WLAN Schnittstelle daher diese Adresse (das ist vom Betriebssystem so vorgesehen).

    Ganz simpel steht es hier.


    Gruss

  • Kommt denn eine Verbindung zustande, wenn du in /etc/dhcpd.conf eine fixe IP vergibst ?

    Code
    interface wlan0
    static ip_address=192.168.178.222/24
    static routers=192.168.178.1
    static domain_name_servers=192.168.178.1 8.8.8.8

    Ich gehe mal davon aus, dass die Fritzbox die 192.168.178.1 hat und die 192.168.178.222 frei ist, sonst anpassen.

  • Zu der Frage wie es zu der IP 169.254.x.x kommt:

    Alles klar, danke für die Erklärung!



    Kommt denn eine Verbindung zustande, wenn du in /etc/dhcpd.conf eine fixe IP vergibst ?

    Das sollte ja auf dasselbe rauskommen, wie wenn ich die Angaben über das GUI eingebe, oder? Da war es ohne Erfolg. Aber ich teste nochmal.


    Nachtrag: Leider wie gehabt. Nur Verbindung nach 169.254... wird hergestellt

    Edited once, last by bucadoX ().

  • Nachtrag: Leider wie gehabt. Nur Verbindung nach 169.254... wird hergestellt

    Für eine brauchbare manuelle Zuweisung der IPv4-Adresse, brauchst Du die richtige MAC-Adresse der FritzBox.

    Hast Du evtl. eine funktionierende WLAN-Verbindung mit einem anderen Gerät, so dass Du dort den arp-cache einsehen kannst? Mit z. B.:

    Code
    arp -a

    in Windows?


    EDIT:


    BTW: Wann stellst Du das power_save auf off? Denn das ist ja nicht persistent. Gut wäre eine service-unit, die vom wlan0-device abhängig ist und die service-unit für den wpa_suplicant, sollte dann von der service-unit für das power_save off, abhängig sein.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ok, die MAC hab ich. Wie sähe denn der Codeblock für dhcpd.conf aus?

    BTW: Wann stellst Du das power_save auf off? Denn das ist ja nicht persistent.

    Jetzt verstehe ich die Bemerkung von davor mit nicht persistent ;)



    Gut wäre eine service-unit, die vom wlan0-device abhängig ist und die service-unit für den wpa_suplicant, sollte dann von der service-unit für das power_save off, abhängig sein

    Da musst du mich einige Stockwerke tiefer abholen ;) Was mich allerdings wundert: Über das RPi hatte ich vorher überhaupt keine Probleme eine WLAN Verbindung herzustellen. D.h. mit einer Raspian Version von November 2020. Power_save war damals kein Thema.

  • Ok, die MAC hab ich. Wie sähe denn der Codeblock für dhcpd.conf aus

    Manuell heißt ja, ohne die dhcpcd.conf. Z. B. in der Kommandozeile:


    Code
    sudo ifconfig wlan0 inet 192.168.178.4 netmask 255.255.255.0 broadcast 192.168.178.255
    sudo arp -i wlan0 -d 192.168.178.1
    sudo arp -i wlan0 -s 192.168.178.1 <richtige-MAC-Adresse-FB>

    (ohne spitze Klammern).

    Danach hier posten:

    Code
    ip a
    arp -a
    ping -c 3 192.168.178.1

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Es geht :)
    Ich habe die Befehle wie angegeben ausgeführt (allerdings 3 vor 2, da es ja noch keine Verbindung zum router gab und damit auch arp ins Leere läuft). Danach ging aber weiter nichts. Darauf habe ich nochmal das Netz aus dem GUI gelöscht, neu ausgewählt, neu das Passwort eingegeben und tschagga, Verdbindung steht :conf:


    Besten Dank für die Geduld!

  • Es geht :)

    Nicht lange bzw. nicht persistent. Die Eingaben sollten lediglich ein Test sein und die Ausgaben, hättest Du genau so posten sollen. Aber gut, ... wer nicht will, der hat schon.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden