login loop rasbian desktop

  • Hi


    vllt kann mir einer weiterhelfen.


    Und zwar habe ich folgendes Problem, das ich nach der Installation von Rasbian buster, mich nicht mehr auf desktop (pi per hdmi angeschloßen) einloggen kann. Das pw stimmt zu 100% und ist auch deutsches Tastatur layout eingestellt.


    Es passiert auch kein autologin, sondern es kommt nur die Login maske, nach der Passwort eingabe und das bestätigen mit enter, wird der Bildschirm schwarz und es kommt wieder die Login Maske.


    Woran liegt das ?


    Und welche datei ist dafür zuständig ?

  • ja kann ich mich ;)


    ausgabe von df:

    Code
    Dateisystem    Typ      Größe Benutzt Verf. Verw% Eingehängt auf
    /dev/root      ext4       30G    4,2G   24G   15% /
    devtmpfs       devtmpfs  1,7G       0  1,7G    0% /dev
    tmpfs          tmpfs     1,9G       0  1,9G    0% /dev/shm
    tmpfs          tmpfs     1,9G    680K  1,9G    1% /run
    tmpfs          tmpfs     5,0M    4,0K  5,0M    1% /run/lock
    tmpfs          tmpfs     1,9G       0  1,9G    0% /sys/fs/cgroup
    /dev/sda1      vfat      253M     49M  204M   20% /boot
    tmpfs          tmpfs     380M       0  380M    0% /run/user/1000
    tmpfs          tmpfs     380M       0  380M    0% /run/user/109

    das ist der Login Screen, gebe ich da das Passwort ein , dann kommt ein schwarzer Bildschirm und wieder die Login maske

  • Ist das komplett oder fehlt da nicht am Ende noch ein ,errors=remount-ro? Sonst sehe ich hier auch nichts Auffälliges.


    Vielleicht hilft ein Blick in die Logs unter /var/log. :conf:


    Oder / und erstmal unter sudo raspi-config boot into desktop aktivieren.

  • oh ja stimmt das ist komplett


    Code
    ─/boot                               /dev/sda1  vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro

    ok aber in welchen logs ? welches ist für den login dort zuständig ?

  • Das war quasi gleichzeitig geantwortet:

    Oder / und erstmal unter sudo raspi-config boot into desktop aktivieren.


    ok aber in welchen logs ? welches ist für den login dort zuständig ?

    Z.B. in der /var/log/syslog sollten gescheiterte Loginversuche dokumentiert sein.

  • das habe ich auch schon gemacht, hat auch nicht geholfen

    Tja dann... *


    auch die .Xauthority im home verzeichniss von pi user, die richtigen Rechte

    Da muss man nicht rumpfuschen! Die Rechte setzt der Inhaber / Ersteller der Datei.



    *) hat IMHO das System durch fehlerhaftes Schreiben während der Installation einen weg oder ist Dein USB-Stick im Argen.

  • Ja das habe ich immer gemacht, doch läuft schon was darauf.


    Könnte vllt das dafür verantwortlich sein

    Code
    -(/home/pi)->cat .xsession-errors
    Xsession: X session started for pi at Sa 18. Sep 16:29:28 CEST 2021
    dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
    dbus-update-activation-environment: setting DISPLAY=:0
    dbus-update-activation-environment: setting XAUTHORITY=/home/pi/.Xauthority
    localuser:pi being added to access control list
    /etc/X11/Xsession: 12: /etc/profile.d/aliases.sh: source: not found
    /etc/X11/Xsession: 3: /etc/profile.d/function.sh: Syntax error: "(" unexpected

    die letzten beiden Zeilen ?