RPI3A+ mit 7"Display über Akku betreiben

  • Hallo liebes Forum,

    Da ich neu hier bin erstmal zu mir, ich bin der Daniel 25Jahre alt und komme aus Friedrichshafen.


    Ich hoffe ihr könnt mir helfen denn ich weis langsam nichmehr was ich noch testen soll.


    Ich habe einen Rpi3A+ hier mit einem 7" Uperfect Touchscreen den möchte ich gerne per li-ion Akku betreiben.


    Das Problem:

    Der Rpi bekommt Strom und Arbeitet auch (grüne led blinkt auf) wenn ich den rpi per HDMI am TV anschließe bekomme ich auch ein Bild.


    Schließe ich aber das Display an scheint der pi nichtmehr genug Strom zu bekommen, die grüne led leuchtet zwar noch das Display geht aber im Sekundentakt an und aus.


    bisher getestet:

    4x li-ion Batterien zu einem Akkublock verschweißt (Punktschweißen) 3.7V an einen Stepup Converter angeschlossen und mit Mulimeter auf 5.1V eingestellt.

    Ergebnis ohne Display ist das undervoltage Symbol, mit Display fährt der pi nicht hoch.


    12V Motorradbatterie an einen Stepdown Converter angeschlossen und auch auf 5.1V eingestellt.

    Ergebnis ohne Display ist auch das undervoltage Symbol, mit Display fährt der pi auch noch hoch aber das Display geht an und aus im Sekundentakt.


    Mit angeschlossenem pi habe ich bei beiden oben genannten versuchen die Voltzahl hochgedreht um zu schauen ob das undervoltage Symbol verschwindet, beim 12V versuch verschwand das Symbol bei ca. 7.4V.


    Der stepup und Stepdown Converter geben max. 3A ab das sollte also reichen. Die Kabel habe ich möglichst kurz gehalten ca. 5cm.


    Mit Original rpi Netzteil funktioniert alles ohne Probleme.


    Da ich ein ziemlicher Anfänger im Bereich Elektronik bin weis ich nun nichtmehr woran es liegen kann, aber einen pi mit 7.4V oder mehr dauerhaft zu betreiben scheint mir doch recht kritisch zu sein.


    Hoffentlich könnt ihr mir helfen oder mir die Thematik etwas besser Erklären, wenn mehr Infos benötigt werden schicke ich gerne mehr rein.


    vielen dank für eure hilfe :)

  • Am Raspi müssen 5.1V anliegen.

    Das Problem liegt im sehr stark wechselndem Strom-Bedarf des Raspi.

    Die Spannung darf niemals unter einen Schwellwert sinken, sonst wird Undervoltage erkannt.


    "Kabel" haben auch einen Widerstand. Je mehr Strom fließt, desto größer ist der Spannungsabfall.


    Da es mit dem Original Raspberry Pi Netzteil (5.1V/2.5A) mit Mikro-USB- Stecker keine Probleme gibt, zieht das Display auch nicht zu viel Strom.


    Ich verdächtige den Stepdown-Regler oder die "Kabel"

  • Indemfall werde ich mal schauen wie ich dickere Kabel an einen Microusb Stecker bekomme, meine Kabel haben momentan 2mm Durchmesser(mit Isolierung), ein wie ich hoffe etwas "Qualitativerer" Stepdown sollte die Tage ankommen, wie kann ich Strom und Spannung denn am besten direkt am rpi messen ?


    Vielen dank kle


    und danke fürs verschieben ins richtige Foreneck war mir nicht ganz sicher wohin damit.

  • Ich würde sagen, Stromversorgung zu schwach!

    Und die 5.1V sollten unter Last anliegen.

    Ohne Laste dürfen dann auch 5,2 oder 5,3V sein.

    Da das PI 3B Netzteil 2,5A hat, solcher der DC-DC Wandel auch locker 3A können.

    Und der Akku auch dementspr. kräftig sein.


    Für 1 Stunde Laufzeit ist da geschätzt bei 6V dann 15Ah und bei 12V dann 30Ah, also schon eine kleine Autobatterie.

  • Hallo Daniel.


    Sonst könntest du es ja auch mit einem Lipoakku für Ferngesteuerte Autos versuchen. Ob es funktioniert kann ich dir nicht sagen, aber die haben eine sehr grosse Entladungsrate und ein zweizeller hat 7.4 v. Sie sind halt einfach sehr teuer.

    Die Hand voller Asse, doch das Leben spielt Schach.



    Erfolg besteht aus drei Buchstaben: Tun

    Göthe

  • Hallo Daniel.


    Sonst könntest du es ja auch mit einem Lipoakku für Ferngesteuerte Autos versuchen. Ob es funktioniert kann ich dir nicht sagen, aber die haben eine sehr grosse Entladungsrate und ein zweizeller hat 7.4 v. Sie sind halt einfach sehr teuer.

    Und bedingen zudem ein spezielles Ladegerät!

    Speziell für Lipo Modellbau Akkus mit Balancer Anschluss.

    Sieh z.B. so einen LiPo Modellbauakku.

    Link

    Soll heißen nicht unbedingt gut händelbar!

    Weshalb ich immer noch NiMH Akkupacks für meine RC-Modell bevorzuge!


    Meine Angabe sind nur Schätzwerte, da ich ja nicht weis, wie hoch sein Strombedarf wirklich ist und wie lange er den PI am Akku betreiben will.

  • So ein ladegerät bekommst du für 20 Fr.


    Und Lipo hat über die gesamte Laufzeit eines Zyklus immer die gleiche Spannung. die der NiMh sinkt, je leerer er wird.

    Die Hand voller Asse, doch das Leben spielt Schach.



    Erfolg besteht aus drei Buchstaben: Tun

    Göthe

  • So ein ladegerät bekommst du für 20 Fr.


    Und Lipo hat über die gesamte Laufzeit eines Zyklus immer die gleiche Spannung. die der NiMh sinkt, je leerer er wird.

    Ha, in der Schweiz vielleicht!

    Hier in D so ab 40 Euro aufwärts, für ein zuverlässiges.

    Macht dann mit Akku rund einen Hunderter in Euro oder ca. 110 Fränkli.

    Wie gesagt ich pers. verzichte auch LiPo Akkus, die Dinger sind gefährlich, wenn sie hochgehen.

    Aber ich hätte ein Ladegerät, dass auch solche Akkupacks laden könnte, mit Balancer.

    Aber wenn man Platz und Kapazität braucht, führt da kein Weg an solcher Art Akku vorbei.

    Allerdings rate ich dann von Billig Akkus und Ladegeräten aus Asien bzw. unbekannter Herkunft ab.

    Man könnte sich das Zimmer, Wohnung oder Auto abfackeln, wenn so ein Akku hochgeht.

    So wie schon öfter mit Fahrrad, Rasenmäher Akkus etc. bereits öfters geschehen.

    Die sogar meist an den dafür vorgesehenen Ladegeräten hingen.

  • Okey.... Ich dachte auch das wäre in Deutschland viel günstiger als in der Schweiz...

    Quote

    Allerdings rate ich dann von Billig Akkus und Ladegeräten aus Asien bzw. unbekannter Herkunft ab.

    Man könnte sich das Zimmer, Wohnung oder Auto abfackeln, wenn so ein Akku hochgeht.

    So wie schon öfter mit Fahrrad, Rasenmäher Akkus etc. bereits öfters geschehen.

    Die sogar meist an den dafür vorgesehenen Ladegeräten hingen.

    Da stimme ich dir voll und ganz zu.

    Die Hand voller Asse, doch das Leben spielt Schach.



    Erfolg besteht aus drei Buchstaben: Tun

    Göthe

  • Danke erstmal für so viele Antworten :)

    Li-ion Batterien mit 3.7V hätte ich noch 12Stk. mit 3200mah hier, wenn ich die so schalte das ich 7.4V bekomme sollte das Akkupack doch genug Power haben um den pi zu versorgen oder ?


    lipo habe ich mir auch schon angeschaut aber die sind tatsächlich etwas arg teuer hier in de und da ich schon Ladeboards usw. für Li-ion habe würd ich die auch gern verbauen :)

  • Versorgst du das Display über den Pi mit Strom?

    Das Ding sollte doch eine getrennte Stromversorgung haben.

    Hast du eine Angabe über den Stromverbrauch und die Versorgungsspannung dieses Displays? Ich habe bei AliEs sowas gefunden - da stand 12V/2A - da wäre es kein Wunder, wenn dir das Ding in die Knie geht.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Ja, aber wenn der Pi selbst schon über 1 A oder mehr braucht und das Display dann noch 2 A aus den Pins zieht, ist es kein Wunder, wenn dir das Teil in die Knie geht. Ich bezwiiefele, dass der 5V Spannungsregler des Pi 3A+ damit gut zurecht kommt.

    Versorge das Display am Pi vorbei direkt mit Spannung, dann wird das auch funktionieren.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Was PI und das Display an Strom brauchen, dass müsste man messen, um es genau zu wissen.

    Dazu sind erstens entspr. Messgeräte und Messadapter nötig.

    Gerade diese Messadapter sind keine Standardware, die muss man selber bauen.

    Denn ich gehe davon aus, dass dieses Display kein 2A braucht.

    Da ist halt ein Standard Netzteil dabei, denn 2A ist in etwa dass was man als kleinstes Steckernetzteil im Handel bekommt.

    Wenn man dann genau weis was beides zusammen an Strom braucht, kann man auch Ausrechnen, was man an Akku Kapazität braucht.

    Alles andere ist Versuch und Irrtum oder rumgestochere im Nebel.

    Du kannst es ja mal zwei deiner Akkus in Reihe versuchen, aber das wird vermutlich nicht lange laufen.

    Ein Pi3B braucht im Leerlauf schon etwas mehr wie 1A und dass Display kommt wahrscheinlich noch mit 1 bis 1,5A dazu.

  • So ich habe getestet:

    12v Motorradbatterie mit Stepdown(max. 3A)

    von dort aus direkt an das Display und direkt an den pi.

    Ergebnis: alleine laufen sowohl Display als auch pi sobald beides zusammen angeschlossen ist kommt wieder das Stromsymbol und das Display flackert ab und du.

    Also gleiches Problem wie wenn das Display am pi angeschlossen ist.


    Ich habe mit meinem Multimeter nun mal gemessen wieviel A der pi mit Display zieht, bei 5V waren das maximal 1.4A (das schien mir etwas wenig) also habe ich von 5V auf 7V hochgedreht dann waren es über 2A.


    Falls ich mich irre bitte erleuchtet mich :D aber kann es sein das der Stepdown einfach bei 5V nicht mehr wie die 1.4A bereitstellen kann?

    Da ja mehr A bei 7V gezogen werden können.

  • Den Stromverbrauch kann man mit jedem 10-€-Aldi-Multimeter messen. Wenn ich so einen Unsinn lese rollen sich mir die Fußnägel hoch.

    Hirny hat keinen 3B, sondern einen 3A+ (siehe #1).

    Der Pi 3A+ braucht im Leerlauf ca. 360 mA, nicht 1 A.

    Der 3A+ hat keinen Spannungsregler für 5 V (nur für 3,3 und 1,8 V) und hat also insofern keine Beschränkung. Die Polyfuse ist auf 2,6 A ausgelegt, ist aber hier offenbar nicht das Problem.

    Theoretisch wäre es also kein Problem, 360 mA für den Pi (Leerlauf) und zusätzlich 2 A für das Display durchzuleiten. Wenn es weniger braucht, umso besser. Das Problem sind wahrscheinlich eher die lütten Pins und Jumper-Drähtchen, die für 1-2 A Strom nicht ausgelegt sind.

    Wenn man das Display getrennt mit Strom versorgt, schließt man diese Fehlerquelle jedenfalls aus.

    4 Li-Ion-Akkus haben auf jeden Fall genügend Leistung, um nicht gleich einzubrechen. Ob man sie parallel schaltet und einen Stepup dahinter klemmt oder in Reihe und einen Stepdown benutzt, spielt dabei kaum eine Rolle.

    Ich habe mit meinem Multimeter nun mal gemessen wieviel A der pi mit Display zieht, bei 5V waren das maximal 1.4A (das schien mir etwas wenig) also habe ich von 5V auf 7V hochgedreht dann waren es über 2A.

    Falls ich mich irre bitte erleuchtet mich :D aber kann es sein das der Stepdown einfach bei 5V nicht mehr wie die 1.4A bereitstellen kann?

    Da ja mehr A bei 7V gezogen werden können.

    Ich tippe eher, das Display hat einen Spannungsregler, der die zusätzlichen 2 V einfach in Wärme verwandelt (1,4 / 5 x 7 = 1,96).

    Bist du sicher, dass deine sonstige Verkabelung korrekt ist und das alle Kabel wirklich fest sitzen und keine Wackler drin sind?

    Hast du mal zwei getrennte Spannungsregler für den Pi und das Display ausprobiert? Vielleicht stört die Art der Stromabnahme des Displays den Regler.Du könntest notfalls mal versuchen, einen dicken Kondensator an den Ausgang des Spannungsreglers zu hängen.

    Oh, man kann hier unliebsame Nutzer blockieren. Wie praktisch!

  • Den Stromverbrauch kann man mit jedem 10-€-Aldi-Multimeter messen. Wenn ich so einen Unsinn lese rollen sich mir die Fußnägel hoch.

    Hirny hat keinen 3B, sondern einen 3A+ (siehe #1).

    Der Pi 3A+ braucht im Leerlauf ca. 360 mA, nicht 1 A.

    Der 3A+ hat keinen Spannungsregler für 5 V (nur für 3,3 und 1,8 V) und hat also insofern keine Beschränkung. Die Polyfuse ist auf 2,6 A ausgelegt, ist aber hier offenbar nicht das Problem.

    Der PI3A hat die selbe Micro USB Buchse wie alle Pi 3.

    Und erklär mir dann mal, wenn da das eingesteckte Original Netzteil eingesteckt ist, wie due da dann Spannung und Stom messen willst!

    Gut Spannung kann man auch wo anders Abgreifen, aber Strom eben nicht.

    Somit musst du entweder ein Micro USB Verlängerungskabel schlachten und es zu einem Strom Mess Adapter umhummlen oder einen USB Spannung/Strommesser einsetzen.

    Sowas in der Art hier (Affiliate-Link).

    Denn alleine mit einem banalen DVM kommst da nicht wirklich weiter.

    Aber mit dem DC-DC Wandler zusammen könnte es gehen, wenn man weis, wie das richtig anzuwenden ist.

    Auch würde ich an seiner Stelle mal die Adernquerschnitte seiner Stromkabel betrachten.

    Denn wenn PI 3A und Display zusammen nicht laufen, liegt das was im Argen.


  • 7V, Keine gute Idee!

    Beide Geräte vertragen dass nicht!

    5V bzw. 5,1V ist vorgeschrieben.

    Alles was dann über sagen wir mal 5,6V rausgeht ist für einen PI definitiv Gefährlich!

  • So ich hab mal die Idee von Gnom getestet, kondensatoren hab ich tatsächlich nicht hier liegen hab ich gemerkt aber mit einem Wandler am Display und einem am pi funktioniert es bei angegebenen 5.1V ohne Probleme.


    Würde für mich jetzt erstmal bedeuten das ein einzelner Wandler wohl nicht genug dampf hat beides zu bepowern?


    Aber kann der eine Wandler nich dem anderen Wandler schaden wenn beide an der gleichen Batterie/Akku angeschlossen sind ?


    Das die 7V keine gute idee sind dachte ich mir schon zum glück ist nichts kaputt gegangen:)