Phoniebox – kein Ton

  • Hallo zusammen


    Es gab ja bereits Beiträge bzgl. «kein Ton bei der Phoniebox». Ich suchte mich durchs ganze Forum, fand jedoch keinen Beitrag, der mir bei meinem «Tonproblem» half.


    Zuerst: Ich bin ein totaler Programmier- & Raspberry-Newbie, wollte die Herausforderung der Toniebox jedoch für unseren Sohn antreten.


    Gearbeitet habe ich mit der Anleitung von @splitti79. Von den Komponenten her bin ich jedoch das absolute Minimum gefahren mit dem Ziel, später weitere Komponenten dazu zunehmen (wenn ich denn die Basic-Phoniebox mal geschafft habe). Will heissen, ich habe lediglich den «Raspberry Pi 3 B+», sowie einen «RFID-Reader» angeschafft. Gearbeitet habe ich über die Desktop-Version.

    Nach einigen Versuchen hab ichs tatsächlich hinbekommen, dass die Software, wie auch der RFID-Reader funktionierten. Nur leider kommt kein Ton (wenn ich sonst auf dem Raspberry Musik laufen lasse, höre ich den Sound).


    Ich verwende noch keinen Verstärker (z.B. HifiBerry MiniAmp), sondern arbeite über den Kopfhörer-Ausgang. So habe ich nach der Anleitung bei «Headphone als iFace» «Y» geklickt.

    Ich habe das Raspberry-Betriebssystem, wie auch die Phoniebox-Software schon öfters neu installiert, jedoch immer mit dem gleichen Ergebnis.


    Hat jemand eine Idee, an was es liegen könnte? Wenn ihr irgendwelche Systeminfos oder Codes braucht, gebt mir bitte einen Tipp. 😉


    Herzlichen Dank für eure Hilfe.


    SaiBoT*84

  • Moin!


    Ich kenne mich mit der Phoniebox nicht aus!


    Würde das bei der Fehlersuche helfen? speaker-test -c2 -twave.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Danke für eure weiteren Tipps.

    Leider immer noch kein Ton. "mpc volume 100" setzte die Lautstärke zwar auf 100, jedoch ohne hörbare Veränderung.

    Das Audiofile habe ich als mp3 hoch geladen. Über das Spotify-Menu kam ich auf die "Iris" Plattform. Jedoch auch da, ohne Ton.


    hyle gehe ich richtig in der Annahme, dass bei den Codes die ich gezeigt habe, soweit alles stimmen sollte?

    Du fragtest noch, ob ich evtl. die Spotify-Version habe. Sollte ich mal jene Version ohne Spotify installieren?


    Bernd666 Vielen Dank. Ich habe den Befehl ausgeführt, mit folgendem Ergebnis:

    pi@raspberrypi:~ $ speaker-test -c2 -twave

    speaker-test 1.1.8

    Playback device is default

    Stream parameters are 48000Hz, S16_LE, 2 channels

    WAV file(s)

    Rate set to 48000Hz (requested 48000Hz)

    Buffer size range from 96 to 1048576

    Period size range from 32 to 349526

    Using max buffer size 1048576

    Periods = 4

    was set period_size = 262144

    was set buffer_size = 1048576

    0 - Front Left

    1 - Front Right

    Time per period = 3.220280

    0 - Front Left

    1 - Front Right

    Time per period = 3.187769


    ...der Test lief dann "ewig" so weiter. Kannst du was daraus lesen?

  • Moin SaiBoT*84,


    wenn du nichts gehört hast, sagt es mir, das was nicht stimmt ;-))

    Und das dein System noch englisch spricht. Aber das ist nicht wichtig.


    was sagt denn der alsamixer? Einfach in der Konsole aufrufen.

    Bei mir sieht es so aus:

    Code
      Gerät: bcm2835 Headphones                        F1:  Hilfe                │
    │    Chip: Broadcom Mixer                            F2:  System-Informationen │
    │ Ansicht: F3:[Wiedergabe] F4: Aufnahme  F5: Alle    F6:  Soundkarte auswählen │
    │ Element: Headphone [dB-Änderung: 4,00]             Esc: Beenden              │

    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo Bernd666

    Wenn man es so betrachtet, kann ich dir nur recht geben. ;)


    Das mit dem Alsamixer könnte was sein. Als ich es aufrief, zeigte es mir Folgendes an:


    Card: PulseAudio F1: Help

    Chip: PulseAudio F2: System information

    View: F3:[Playback] F4: Capture F5: All F6: Select sound card

    Item: Master Esc: Exit


    Über F6 konnte ich dann ebenfalls die bcm2835 Headphones anwählen:

    Card: bcm2835 Headphones F1: Help

    Chip: Broadcom Mixer F2: System information

    View: F3:[Playback] F4: Capture

    F5: All F6: Select sound card

    Item: Headphone [dB gain: 0.00] Esc: Exit


    Beim Ausprobieren der Phoniebox hörte ich dann immer noch nichts. Jedoch, als ich den Alsamixer nochmals aufrief, war er wieder auf das obige "PulseAudio" eingestellt. Kann es sein, dass ich die bcm2835 Headphones irgendwie fixen muss/kann?

  • Moin SaiBoT*84,


    ich teste es hier mit einem einfachen Raspberrypi OS. Habe kein MPD oder sowas installiert. Kenne das Teil überhaupt nicht!!!

    Kann mir aber vorstellen, das was in der mpd.conf nicht richtig ist.


    Du hast nicht noch eine SD-Karte, auf der man besagtes OS installiert und dann einfach mal die komplette Hardware prüfen kann?

    Nur um sicher zu gehen, das Buchse, Stecker und Lautsprecher funktionieren.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • unter welchem Betriebssystem installierst du die Phoniebox? Raspberry pi OS desktop oder ...lite? Desktop nutzt mittlerweile PulseAudio als Aufsatz über ALSA (und macht in meinen Augen mehr Ärger als es nutzt). Nur unter Lite läuft noch das nackte und unverfälschte ALSA.


    splitti79 empfahl in seiner an sich guten Anleitung, Desktop zu verwenden und dann die nicht benötigten Pakete zu löschen (allerdings kenne ich den aktuellen Stand nicht). Aber seit der Umstellung auf PulseAudio in Desktop rate ich mehr denn je dazu, die Phoniebox gleich auf Lite zu installieren, zumal das Konzept der Phoniebox ohne Bildschirm auskommt.


    Edit:

    Leider ist meine Anleitung mittlerweile auch nicht mehr auf dem aktuellen Stand, Zeitmangel

  • Moin!


    Das hatte ich vergessen. Ich habe hier auch die Liteversion. Kann es aber auch mit einer Fullversion testen. Aber nicht mehr heute...


    Das hat mir nun doch keine Ruhe gelassen.

    Nun das nackte RaspberryPi OS mit Desktop. Ging zuerst auch nicht. Dann im Desktop mit der rechten Maustaste das Lautsprechersysmbol angeklickt und auf AV-Jack umgestellt. Danach ging es.



    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

    Edited once, last by Bernd666: Test hinzu gefügt ().

  • gehe ich richtig in der Annahme, dass bei den Codes die ich gezeigt habe, soweit alles stimmen sollte?

    Jain. In Deiner /etc/mpd.conf sind die Zeilen 261-269 doppelt vorhanden. Kann aber auch ein Kopierfehler von Dir und in der Originaldatei richtig sein.

    Code: /etc/mpd.conf
    # MPD supports various audio output types, as well as playing through multiple
    # audio outputs at the same time, through multiple audio_output settings
    # blocks. Setting this block is optional, though the server will only attempt
    # autodetection for one sound card.
    #
    # An example of an ALSA output:
    #
    audio_output {
            type            "alsa"


    Mit Spotify dürfte das ansonsten bei einem Raspberry Pi OS mit Desktop (also mit PulseAudio) normal sein. Die alsa-Dateien sind auch leer, weil PulseAudio verwendet wird.


    Du fragtest noch, ob ich evtl. die Spotify-Version habe. Sollte ich mal jene Version ohne Spotify installieren?

    Das kannst Du gerne auf einer anderen SD-Karte mal versuchen.


    Das eigentliche Problem an der Sache ist für mich, dass die Version mit Spotify einen anderen Player verwendet und nicht den Standard MPD / MPC. Ich habe kein Spotify und somit keine Erfahrungen damit.


    Ich würde aber laut dieser Doku https://docs.mopidy.com/en/latest/config/ mal nachsehen was im Audio-Block steht, also dieser Teil hier

    Code
    [audio]
    mixer = software
    mixer_volume =
    output = autoaudiosink
    buffer_time =

    IMHO wäre vor allem erstmal was bei mixer steht interessant.

  • Ihr seid grossartig, danke für eure Mitdenken und MIträtseln. Auch wenn es leider immer noch nicht geklappt hat.

    Herzlichen Danke Bernd666, dass du dir diese Mühe extra genommen hast. Ich habe das mit der rechten Maustaste probiert - leider war es schon auf AV-Jack umgestellt.


    Jain. In Deiner /etc/mpd.conf sind die Zeilen 261-269 doppelt vorhanden. Kann aber auch ein Kopierfehler von Dir und in der Originaldatei richtig sein.

    Das wird ziemlich sicher ein Kopierfehler gewesen sein.


    IMHO wäre vor allem erstmal was bei mixer steht interessant.

    Hier steht folgendes:

    Code
    [audio]
    mixer = software
    mixer_volume = 30
    output = alsaink
    buffer_time =

    hyle: Wär cool, wenn du mir dazu noch ein Feedback geben könntest.


    Ansonsten bleibt mir wohl nichts anderes übrig, als die Sache doch mal über die Liteversion (Danke schlizbäda) oder die Version ohne Spotify zu probieren (Danke hyle)

  • Wär cool, wenn du mir dazu noch ein Feedback geben könntest.

    Ich kann bei der Spotify-Variante leider auch nichts anderes machen als die Doku zu lesen und zu raten. Versuchen könntest Du noch output = autoaudiosink oder ggf. output = pulsesink. Ob das aber was bringt, kann ich nicht sagen.


    Verschwende dann aber keine Zeit mit weiteren Versuchen, falls das nicht funktioniert und fang mit dem anderen Weg an. Du willst ja irgendwann mal etwas hören. ;) Rumspielen und nach den Gründen suchen, warum das hier nicht funktioniert, kannst Du später immer noch.

  • Hallo zusammen
    Es dauerte etwas, bis ich wieder Zeit hatte für das weitere Probieren.


    Ich habe die Phoniebox nun unter Raspberry pi OS lite, sowohl einmal mit Spotify und einmal ohne Spotify installiert. Jedoch hatte ich bei beiden Varianten weiterhin keinen Ton.

    Unter Alsamixer habe ich nun tatsächlich auch die Konfiguration u.a. wie bei Bernd666 und nicht mehr jene mit Pulseaudio.


    Hat jemand noch eine weitere Idee, was ich unter diesem Setup noch ändern könnte?
    Vielen Dank.

    was sagt denn der alsamixer? Einfach in der Konsole aufrufen.

    Bei mir sieht es so aus:

    Code
      Gerät: bcm2835 Headphones                        F1:  Hilfe                │
    │    Chip: Broadcom Mixer                            F2:  System-Informationen │
    │ Ansicht: F3:[Wiedergabe] F4: Aufnahme  F5: Alle    F6:  Soundkarte auswählen │
    │ Element: Headphone [dB-Änderung: 4,00]             Esc: Beenden              │

    73 de Bernd

  • Moin SaiBoT*84,


    es ist nur ein Hobby.


    Dann solltest du mit dem Befehl speaker-test -c 2 -twave eine Stmme höen die immer rechts link sagt. Beenden mit steuerung c.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Und nun bitte nochmals folgendes von der Version ohne Spotify:

    Zeig mal bitte Deine /etc/mpd.conf, die /etc/asound.conf und die /home/pi/.asoundrc!


    //Edit


    Falls die /etc/asound.conf wieder leer sein sollte, kannst Du es mal mit folgendem Eintrag versuchen:

    Danach am besten den RPi mal neu starten.