Seagate 5TB USB Platte an Raspberry 4 läuft ständig an und bricht ab

  • Hallo Zusammen,


    ich habe mir einen Raspberry 4 mit 4GB gekauft. Da habe ich mir Openmediavault installiert um mir ein kleines NAS aufzubauen. Nun habe ich meine Seagte Expansion+ mit 5TB HDD angeschlossen um meine Filme mir darüber angucken zu können. Doch leider fährt die Platte da nur kurz an und bricht immer wieder ab. Man hört richtig den Motor wie er anläuft und stoppt. auf meinem Raspberry3 auf dem Openelec läuft habe ich diese Probleme nicht. :wallbash:



    Gibts da einen kniff oder eine Idee, was da das Problem ist?





    Ein paar Infos:

    Linux raspberrypi 5.10.60-v7l+ #1449 SMP Wed Aug 25 15:00:44 BST 2021 armv7l GNU/Linux


    openmediavault information


    Release: 5.6.16-1

    Codename: Usul



    VG niesel

  • Es gibt von Delock einen Raspberry Pi - Konverter Micro-USB auf SATA:

    https://www.reichelt.de/raspbe….html?&trstct=pol_7&nbc=1

    Mit dem habe ich gute Erfahrungen gemacht. Der ist nicht so billig wie ein USB-Adapter, aber gut.


    Kannst ihn an eine andere Stromversorgung als den Raspi hängen. Der Raspi 4 zieht mehr Strom als der Raspi 3, dadurch wird der Spannungsabfall über das Kabel und die Platine höher. Wenn die HD mehr Strom zieht, bricht die Spannung zusammen.

  • Aktiven USB HUB an den Pi und daran die Platte.

    Sämtliche Pis können an den USB Ports keine Festplatten ausreichend versorgen, zumindest keine so großen und/oder ältere.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Hi,


    das schaut ganz nach zu wenig Strom aus.

    Schau mal was sudo dmesg im Terminal ausgibt. Sollten irgendwo Meldungen in Richtung "Mir fehlt der Strom!!" auftauchen.

    Dann nutze einfach einen aktiven USB-Hub zwischen dem Pi und der Platte. Ich verwende diesen hier (Affiliate-Link)und er tut schon seit einigen Jahren seinen Dienst.