unzuverlässige WLAN Verbindung

  • Hallo Experten,

    habe im Garten, in einer Gartenleuchte mittels eines RPiZeroW und

    einer PiCam ein Kamerasystem installiert, welches mir täglich zu einer

    in crontab festegelegten Zeit ein Foto macht und mir dieses per e-mail

    über mein lokales WLAN sendet. Dieses Kamerasystem - in einem

    verschlossenen Kunststoffgehäuse - ist ca. 25 m vom Router einfernt.

    Das System hat lange Zeit gut funktioniert.

    Seit ca. 1 Monat erscheinen diese e-mails/Fotos aber nur noch in

    unregelmässigen Abständen in meiner Mailbox, anstatt jeden Tag.

    Hat jemand eine Idee ? Müsste ich evtl. einen Repeater installieren ?

  • Moin luemar,


    schon mal einen Ping aus dem heimischen Netzwerk auf den Zero abgesetzt?

    Einfach den Ping mal länger laufen lassen.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • ... - ist ca. 25 m vom Router einfernt.

    Das System hat lange Zeit gut funktioniert.

    Seit ca. 1 Monat erscheinen diese e-mails/Fotos aber nur noch in

    unregelmässigen Abständen in meiner Mailbox, anstatt jeden Tag.

    Hat jemand eine Idee ? Müsste ich evtl. einen Repeater installieren ?

    Welchen Router hast Du? Kannst Du im Log des Routers nach schauen, ob dort neue WLAN-Abmeldungen und WLAN-Anmeldungen eingetragen sind? Schau mal im PI nach, ob sich die PIDs des wpa_supplicant ändern.

    Oder was genau meinst Du mit "unzuverlässiger WLAN-Verbindung"?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Evtl. ist auch in der Umgebung ein weiteres oder weitere WLAN Netztwerke dazu gekommen.

    Wenn die z.B. in der Nähe auf dem selben Kanal Funken, kann auch Unterbrechungen geben.

    Vor allem, weil ja diese Minigeräte nicht grad Sende und Empfangsstark sind.

  • Alternativ wäre es möglich einen USB-Dongle mit einer besseren Reichweite zu verwenden. Das setzt natürlich voraus, dass er ins Gehäuse passt. Das glaube ich aber nicht.

    Ich benötigte in meinem Projekt neben der internen Schnittstelle wlan0 einen weiteren wlan-Anschluss (wlan1).

  • Ich würde erstals nachsehen, ob überhaupt das WLAN der Verursacher ist, dass keine Mails ankommen.

    [ /var/log/sys* | kern*]


    Servus !

    RTFM = Read The Factory Manual, oder so