Fehlermeldung beim Codeblock installieren

  • Hallo ich bin ein totaler Neuling was Linux und den Raspberry-Pi angeht,

    ich sitze jetzt seit 3 Tagen an dieser Fehlermeldung und habe bis jetzt auch noch nichts im Internet gefunden was mir weitergeholfen hat. :helpnew:


    Ich habe versucht die Codeblocks mit dem Befehl "sudo apt install codeblocks" und "sudo apt-get install codeblocks" zu installieren.

    Woraufhin mir diese Fehlermeldung angezeigt wurde:


    pi@raspberry:~ $ sudo apt install codeblocks

    Reading package lists... Done

    Building dependency tree

    Reading state information... Done

    The following package was automatically installed and is no longer required:

    python-colorzero

    Use 'sudo apt autoremove' to remove it.

    The following additional packages will be installed:

    codeblocks-common libcodeblocks0 libutempter0 libwxbase3.0-0v5

    libwxgtk3.0-0v5 xbitmaps xterm

    Suggested packages:

    libwxgtk2.8-dev | libwxgtk3.0-dev wx-common codeblocks-contrib

    xfonts-cyrillic

    The following NEW packages will be installed:

    codeblocks codeblocks-common libcodeblocks0 libutempter0 libwxbase3.0-0v5

    libwxgtk3.0-0v5 xbitmaps xterm

    0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.

    Need to get 780 kB/15.4 MB of archives.

    After this operation, 46.1 MB of additional disk space will be used.

    Do you want to continue? [Y/n] Y

    Err:1 http://ftp.debian.org/debian buster/main i386 xterm i386 344-1

    404 Not Found [IP: 199.232.150.132 .79]

    E: Failed to fetch http://ftp.debian.org/debian/p…term/xterm_344-1_i386.deb 404 Not Found [IP: 199.232.150.132 79]

    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


    Ich habe schon versucht "sudo apt-get update", "sudo apt-get upgrade", "sudo apt-get dist-upgrade", "sudo apt-get clean", das alles hat nichts gebracht.

    Kann mir vielleicht jemand erklären was ich tun muss um die Codeblocks installieren zu können?


    Würde mich riesig über Hilfe freuen!

  • Go to Best Answer
  • Moin Lolli,


    erstmal: Herzlich Willkommen im Forum!


    http://ftp.debian.org/debian buster/main i386 xterm i386 344-1

    Du hast anscheinend einen falschen Eintrag in der /etc/apt/sources.list. Hast du die bearbeitet?

    Am besten zeigst du die Datei, bitte, in Code, dieses Zeichen </> nutzen.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Vielen Dank für deine Antwort! :)


    Meintest du das hier:

    deb http://ftp.debian.org/debian/ buster main contrib non-free

    deb http://security.debian.org/ buster/updates main contrib non-free

    deb http://ftp.debian.org/debian/ buster-updates main contrib non-free


    # Uncomment lines below then 'apt-get update' to enable 'apt-get source'

    #deb-src http://ftp.debian.org/debian/ buster main contrib non-free

    #deb-src http://security.debian.org/ buster/updates main contrib non-free

    #deb-src http://ftp.debian.org/debian/ buster-updates main contrib non-free


    # This system was installed using small removable media

    # (e.g. netinst, live or single CD). The matching "deb cdrom"

    # entries were disabled at the end of the installation process.

    # For information about how to configure apt package sources,

    # see the sources.list(5) manual.

  • Moin Lolli,


    ja meine ich, aber das sieht mir nicht nach Raspberry aus.


    Welchen Raspberry nutzt du und welches Betriebssystem hast du installiert?


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Ich habe die Raspberry Pi Desktop Software auf einer virtuellen Maschine installiert die mit Linux und Debian 32 Bit läuft

  • Moin Lolli,


    und die VM rennt mit dem Debian Buster with Raspberry Pi Desktop.

    In der VM arbeitest du auch???

    Du hast sudo apt update und sudo apt upgrade gemacht. Dann sudo apt install codeblocks.

    Soweit richtig?


    Nun hast du eine Fehlermeldung?


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Genau in der VM habe ich dann das 2021-01-11-raspios-buster-i386 hinzugefügt und da gebe ich auch alle Kommandos ein.

    Ja das habe ich alles ausprobiert und nun ist diese Fehlermeldung da.

    • Best Answer

    Moin Lolli,


    kann es sein das die Seite nicht da war?

    Ja das habe ich alles ausprobiert

    Wurden denn auch Updates installiert? Danach nochmal die VM neu gestartet?

    Ich habe sonst keine Idee.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Lolli

    Selected a post as the best answer.
  • Vielen lieben Dank du hast mir gerade total weitergeholfen!!! :danke_ATDE: , ich habe die Updates nicht zugelassen :wallbash:

  • Moin Lolli,


    dann, bitte, dein Thema als erledigt markieren. Das geht oben bei "Thema bearbeiten".


    Danke!


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.