Raspi4 login nur noch über SSH möglich

  • Hi,


    ich habe einen RPI4, den ich als NAS im Netzwerk hängen habe. Über SSH kann ich mich nach dem booten ganz normal anmelden. Gestern habe ich das Ganze mal über den Monitor versucht, und bekomme keine Loginoption. Der Pi hängt scheinbar grafisch(?) bei [Status] started generate the prelogin message (siehe Bild).


    Wenn ich nun über SSH etwas mache, wirft er auch weiterhin Statusmeldungen aus, arbeitet also, aber gibt mir keinerlei Möglichkeit, mich anzumelden. Ich habe update und upgrade bereits durchgeführt, ohne Veränderung, auch den anderen HDMI Port habe ich bereits genutzt. Kennt sich da jemand von euch aus? Ich wäre euch sehr dankbar.


    Update:

    Nach mehreren Minuten wirft er noch folgende Statusmeldungen aus, dann passiert wieder nichts (Ich habe mich nicht per SSH angemeldet)


    Liebe Grüße, Am4ranth

    Edited once, last by Am4ranth ().

  • Ich habe vor einigen Monaten mal einen lokalen Login probiert, da ging es. Ich habe auch ansonsten nichts derartiges geändert. Wo könnte ich denn sowas nachvollziehen?

  • Vielleicht hat ja das Filesystem o. die SD Karte ein Problem, das könnte man mit fsck bzw. mit badblocks prüfen. Man könnte schauen, ob ps ax |grep -i tty nützliche Infos ausgibt.

  • Ich habe beides jetzt probiert, badlocks fragt nach sehr vielen Optionen, die ich aus Mangel an Kentnissen nicht unbedingt verstehe, fsck sagt mir, dass der Befehl mit erheblichen Datenschäden verbunden ist? Und der Letzte Befehl gibt folgendes aus, für mich unverständlich:

    ps ax | grep -i tty:

    Code
    PID TTY      STAT   TIME COMMAND
     1199 pts/0    S+     0:00 grep --color=auto -i tty

    Edit:

    mit sudo badblocks -v /dev/sda > badsectors.txt werde ich jetzt mal einen Check durchführen. Mal sehen was es bringt.

  • Hier die Ergebnisse:

    Code
    systemctl list-units -t service | grep getty
    getty@tty1.service                                                                        loaded inactive   dead    start Getty on tty1                         
    getty@tty2.service                                                                        loaded inactive   dead    start Getty on tty2                         
    serial-getty@ttyS0.service                                                                loaded inactive   dead    start Serial Getty on ttyS0   
  • Du könntest mal versuchen die systemd tty Dienste systemctl restart getty@tty1.service manuell zu starten, ob es geklappt hat siehst Du mit systemctl status getty@tty1.service Falls der tty Prozess ( hier nur tty1 ) wieder läuft, kannst Du mal versuchen ob bei Strg+Alt F1 ein Login in Konsole 1 möglich ist.

  • Er meinte wohl, die Files sein verschoben und ich sollte systemctl daemon-reload asuführen, nachdem ich systemctl restart getty@tty1.service ausgeführt habe, kam folgendes, ohne dass weiteres geschah:

    Code
    pi@NAS:~ $ systemctl restart getty@tty1.service
    ==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
    Authentication is required to restart 'getty@tty1.service'.
    Authenticating as: ,,, (pi)
    Password:
    ==== AUTHENTICATION COMPLETE ===

    Danach arbeitet er, aber es passiert wieder ewig nichts. Dementsprechend liefert auch systemctl status getty@tty1.service folgendes Ergebnis:

    Code
    pi@NAS:~ $ systemctl status getty@tty1.service
    ● getty@tty1.service - Getty on tty1
       Loaded: loaded (/lib/systemd/system/getty@.service; enabled; vendor preset: e
      Drop-In: /etc/systemd/system/getty@tty1.service.d
               └─noclear.conf
       Active: inactive (dead)
         Docs: man:agetty(8)
               man:systemd-getty-generator(8)
               http://0pointer.de/blog/projects/serial-console.html
    lines 1-8/8 (END)
  • Die Überprüfung hat genau das selbe Problem, es sieht auf der Shellebene nicht danach aus, als würde was passieren...


    DIe Folgenden Files gibt ls aus:

    die Datei getty@tty1.service ist nicht dabei...


    Edit:

    der andere Ordner:

    Edited once, last by Am4ranth ().

  • Für den Check der SD Karte bzw. des Filesystems sollte diese nicht eingehangen / in Betrieb sein. Das macht man am besten mit einem anderem Linuxsystem (Notebook), ggf. mit einem ext. USB SD Kartenleser.

  • Oh, na das müsste ich dann über den Laptop mal machen. Wie würde der Befehl dazu dann aussehen? sudo badblocks [pfad der Karte] oder?

    Edit: Ich bin echt zu unerfahren, um das hinzubekommen.. ich finde die SD Karte nicht in der Shell...

    Edited once, last by Am4ranth ().