Höchste Auflösung HQ Camera nur über "Terminaleingabe" erreichbar, aber nicht mit Pythoncode "camera.capture()"

  • Liebe Community,


    ich habe das Problem, dass ich Bilder mit sehr hoher Auflösung benötige und möchte am liebsten die Höchste Auflösung (4056x3040) der HQ-Camera nutzen.

    Wenn ich die Bilder über das Terminal mit dem Befehl: " raspistill -o image.jpg " aufnehme, dann bekomme ich diese Auflösung auch hin (vgl. Bild1)



    Ich muss die Bilder allerdings mithilfe eines Pythoncodes aufnehmen, da das alles mit Schrittmotoren etc. kombiniert und automatisiert funktionieren soll. Sobald ich aber versuche ein Bild durch diese Vorgehensweise (vgl. Bild2) aufzunehmen,

    ist maximal eine Auflösung von (3000x2600) möglich.

    Sobald ich eine höhere Auflösung bekomme ich eine Fehlermeldung (vgl. Bild 3), die ich aber leider nicht wirklich deuten kann bzw. dazu auch bisher nichts aussagekräftiges für mein Problem gefunden habe.



    Ich hoffe einer von euch kann mir helfen! Vielen Dank schon mal für all euren Input.


    Liebe Grüße

    Theresa

  • Go to Best Answer
  • Hallo Zusammen,


    anbei noch der Text der Fehlermeldung:


    mmal: mmal_vc_port_enable: failed to enable port vc.ril.image_encode:out:0(JPEG): ENOMEM

    mmal: mmal_port_enable: failed to enable port vc.ril.image_encode:out:0(JPEG)(0xb92c20) (ENOMEM)


    Backend terminated or disconnected. Use 'Stop/Restart' to restart.


    Außerdem habe ich noch folgenden Eintrag gefunden:

    https://github.com/raspberrypi/firmware/issues/733

    Allerdings wird hier vorgeschlagen ein sudo rpi-update auszuführen, das möchte ich aber nicht einfach so machen. Ich bin mir nicht ganz sicher, ob ich überhaupt dasselbe Problem habe bzw. wie ich das nachprüfen kann.


    Grüße

    Race

    • Best Answer
    • Official Post

    Hallo Race94,


    willkommen im Forum! ;)


    Das Thema in Deinem Link ist schon älter und somit schon gefixt. Und rpi-update löst eh so gut wie nie ein Problem, ganz im Gegenteil!


    Bringt es etwas, wenn Du GPU Memory unter sudo raspi-config >> Performance Options >> GPU Memory auf z.B. 256 setzt? Mehr RAM würde ich aber (erstmal) nicht azweigen, das ist natürlich vom RPi-Modell abhängig.

  • Hallo hyle ,


    vielen vielen tausend Dank für deine Hilfe!! Dein Vorschlag hat geklappt! Da merke ich einfach wieder, dass mir viel zu viel Grundwissen fehlt.


    Danke auf jeden Fall! Das hat mir jetzt wirklich große Kopfschmerzen erspart!


    Viele liebe Grüße und ein schönes Wochenende!

    Race

  • Race94

    Selected a post as the best answer.