Bitwarden_rs / Vaultwarden_rs auf eigenen Raspi installieren

  • Hallo!


    Bin neu hier und hätte ein Frage an euch, würd mich freuen wenn mir wer helfen könnte.


    Habe auch das Problem nach der Installation von Vaultwarden / bitwarden_rs , wenn ich die DynDDNS Adresse anklicke funktioniert es nicht.

    Hat es jemand schon auf den Raspi mit Docker und Portainer / Nginx Proxy Manager für Let's Encrypt schon installiert ( und es läuft bei Ihm ) :?:


    Danke im vorraus

    Wäre über jede hilfe dankbar


    Zitat:



    Hallo,


    vielleicht kann mir hier jemand helfen ?


    Dieser Fehler kommt in der im Portainer im Container: nginx_app_1


    Fehler Code:

    [2021] [Time PM] [Nginx ] › ℹ info Reloading Nginx

    [2021] [Time PM] [Nginx ] › ℹ info Reloading Nginx

    [2021] [Time PM] [SSL ] › ℹ info Requesting Let'sEncrypt certificates for Cert #1: xxx-ddns.xxx.de

    [2021] [Time PM] [SSL ] › ℹ info Command: certbot certonly --non-interactive --config "/etc/letsencrypt.ini" --cert-name "npm-1" --agree-tos --authenticator webroot --email "test@test.de" --preferred-challenges "dns,http" --domains "xxx-ddns.xxx.de"

    [2021] [Time PM] [Nginx ] › ℹ info Reloading Nginx

    [2021] [Time PM] [Express ] › ⚠ warning Command failed: certbot certonly --non-interactive --config "/etc/letsencrypt.ini" --cert-name "npm-1" --agree-tos --authenticator webroot --email "test@gtest.de" --preferred-challenges "dns,http" --domains "xxx-ddns.xxx.de"

    Saving debug log to /var/log/letsencrypt/letsencrypt.log

    Some challenges have failed.


    Mit der Internen IP Adresse http://192.168.0.89:8080 komme ich auf Biitwarden ohne SSL aber Registieren funktioniert nur mit SSL daher kommt immer dieser Fehler in Rot "This browser requires HTTPS to use the web vault"


    Zitat Ende:


    lg

    Habakuck

    Edited 2 times, last by Habakuck ().

  • Bei mir läuft das als DOcker hervoragend.


    Bitwareden_rs als Docker Image. Zugriff von außen über einen Reverse Proxy (Nginx), der über eine Domain angesprochen wird (DynDNS über meinen Domainanbieter). Die ganze Zertifikatsgeschichte läuft auf dem Reverseproxy, da der ja die Verbindung von außen nach innen macht. Die Authentifizierung von Lets Encrypt mache ich über TXT Einträge bei der Domain.


    Bitwarden im Docker läuft über Port 8080 ohne SSL. SSL kommt erst beim Reverse Proxy ins Spiel

    Willst du einen Tag lang glücklich sein, dann saufe.

    Willst du ein Jahr lang glücklich sein, dann heirate.

    Willst du ein Leben lang glücklich sein, dann fahr Yamaha.

  • Internet --> Domain SSL (Pot 443) --> Nginx Reverseproxy --> http Port 8080 --> Docker Bitwarden

    Willst du einen Tag lang glücklich sein, dann saufe.

    Willst du ein Jahr lang glücklich sein, dann heirate.

    Willst du ein Leben lang glücklich sein, dann fahr Yamaha.

  • hi hast du auch eine Anleitung ?

    Habe schon vieles versucht, immer bei Zertifikat bricht er ab

    Kannst du mir vielleicht helfen installiere es nochmal von einer Anleitung

    lg

    Edited 2 times, last by Habakuck ().

  • Ich versuch das mal fix. Wenn Fragen sind, einfach schreiben.



    Annahme:

    - Bitwarden läuft als Docker, ohne SSL über Port 80 (8080).

    - Nginx ist installiert


    Damit man nun von außen (aus dem Internet) auf Bitwarden zugreifen kann, muss man Nginx Sagen, dass er die Anfragen an den Dockercontainer weiterleiten soll. Jetzt ist die Frage, ob dud as über eine Subdomain machen willst (https://bitwarden.DOAMIN.de) oder über eine Non-root Subdomain (https://DOMAIN.de/bitwarden). DOAMIN ist dabie die Domain, die du hast. Ich habe die zweite Variante im Einsatz. Daher sind alle meine Unterseiten in einer VHost definiert (/etc/nginx/sites-available/default), die nach /etc/nginx/site-enabled verlinkt ist. Der Inhalt sieht dann so aus:




    Anzupassen ist jeweil proxy_pass. Bei mir läuft Docker auf einem extra-Pi, daher steht hier dessen IP-Adresse. Wenn alles auf einer Maschiner läuft, muss hier die Adresse des entsprechend Raspberrys rein. ACHTUNG: Hier kommt nicht die eine IP-vom Docker-Container selber rein. Auch der Port muss entsprechend angepasst werden (:80 oder :8080).

    In meinem Fall habe ich die Admin-Seite (/bitwarden/admin ) auch erreichbar gemacht, das sollte man sich aber auch sehr gut überlegen, ob man das braucht. Wenn ja, muss man das bei Bitwarden auch konfigurieren, das das glaub ich standardmäßig deaktiviert ist.


    Die ganze SSL-Geschichte habe ich global in Nginx konfiguriert und nicht in der VHost, da es für alle meine Subdomains und Unterseiten gelten soll. Das habe ich gemacht in /etc/nginx/nginx.conf



    Die entsprechenden Zertifikate gibts von Lets Encrypt. certbot habe ich nach Anleitung installiert (hier habe ich keine Anleitung parat, da das schon eine Weile her ist.)

    Der Zertifikatsbezug erfolgt über:


    certbot certonly --manual --preferred-challenges dns -d DOAMIN.de -d *.DOMAIN.de --rsa-key-size 4096


    Damit bekomme ich ein Wildcard-Zertifikat, was auch für Subdomains gilt.

    Wenn ich diesen Befehl ausführe, wir mir 2x einHash angezeigt, den ich bei meinem Domainanbieter (Strato) hinterlegen muss. Dazu muss in den DNS-Einstellungen beim Domainanbieter ein TXT-Record angelegt werden. Der hat das Präfix _acme-challenge, den Typ TXT und als Wert den Hash, den Certbot ausgibt.

    Dieser Hash beim Domainanbieter muss bei jedem Zertifikatsbezug neu hintelegt werden. Damit prüft Lets Encrypt, ob man berechtigt ist, für diese Domain ein Zertifikat zu beantragen. Wenn certbot dann fertig ist und das Zertifikat gespeichert ist (der Pfad muss in der nginx.conf stimmen), dann noch Nginx neustarten und fertig. Bitwarden ist dann in meinem Fall erreichbar unter https://DOAMIN.de/bitwarden. DIese URL muss dann noch in Bitwarden selber eingetragen werden (Genberal Settings - Domain URL)

    Willst du einen Tag lang glücklich sein, dann saufe.

    Willst du ein Jahr lang glücklich sein, dann heirate.

    Willst du ein Leben lang glücklich sein, dann fahr Yamaha.

  • Hallo FoCMB !


    Habe Portainer ( Container : Portainer, Bitwarden ,nginx_db, nginx _app_1 installiert hat auch das Zerfitfikat geladen in Ngnix aber wenn ich es aufrufe komme ich immer zum Router Login. Ports: 80 / 443 freigegeschaltet auf dieser Internen IP 192.168.1.xx


    Verwende eine https://ddnss.de/ sollte aber mit dieser laufen. Aber wenn ich nslookup ausführe kommt es immer so....


    C:\Windows>nslookup xxx.ddnss.de


    Kommt immer mein PHole

    Server: pi.hole

    Address: 192.168.1.160


    Nicht autorisierende Antwort:

    Name: xxx.ddnss.de

    Address: 80.10.......IP meiner Internet verbindung



    Weis nicht mehr weiter hab es schon so oft probiert. Vielleicht kannst du mir helfen ?


    lg Habakuck

    Edited once, last by Habakuck ().

  • Ich kanns versuchen. Wird aber erst heute abend, da ich auf Arbeit bin.

    Willst du einen Tag lang glücklich sein, dann saufe.

    Willst du ein Jahr lang glücklich sein, dann heirate.

    Willst du ein Leben lang glücklich sein, dann fahr Yamaha.