OctoPrint: 1.7.0 Update Fehler

  • Hallöchen Leuts,


    Vieleicht kann mir ja jemand helfen, Ich habe von Linux nicht wirklich Ahnung. Ich nutze 2 Raspberrys für 2 Verschiedene 3D Drucker. Bei dem einen klappte das Update auf 1.7.0 ohne Probleme aber bei dem anderen kommt dieser Fehler:


    Python
    Aktualisiere gerade, bitte warten.++++++++++++++++++++++++++++++++Aktualisiere OctoPrint auf 1.7.0++++++++++++++++++++++++++++++++/home/pi/oprint/bin/python2 -m pip --disable-pip-version-check install https://github.com/OctoPrint/OctoPrint/archive/1.7.0.zip --no-cache-dirLooking in indexes: https://pypi.org/simple, https://www.piwheels.org/simpleCollecting https://github.com/OctoPrint/OctoPrint/archive/1.7.0.zipDownloading https://github.com/OctoPrint/OctoPrint/archive/1.7.0.zip (6.6 MB)Requirement already satisfied: OctoPrint-FileCheck>=2021.2.23 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (2021.2.23)Requirement already satisfied: OctoPrint-FirmwareCheck>=2021.10.11 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (2021.10.11)Requirement already satisfied: OctoPrint-PiSupport>=2021.8.2 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (2021.8.2)Requirement already satisfied: markupsafe<2.0,>=1.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (1.1.1)Requirement already satisfied: markdown<3.2,>=3.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (3.1.1)Requirement already satisfied: regex!=2018.11.6 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (2019.8.19)Requirement already satisfied: wrapt<1.13,>=1.12.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (1.12.1)Collecting flask<2,>=1.1.4Downloading Flask-1.1.4-py2.py3-none-any.whl (94 kB)Collecting Jinja2<3,>=2.11.3Downloading Jinja2-2.11.3-py2.py3-none-any.whl (125 kB)Requirement already satisfied: Flask-Login<0.6,>=0.5 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (0.5.0)Requirement already satisfied: Flask-Babel<2,>=1.0 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (1.0.0)Requirement already satisfied: Flask-Assets<3,>=2.0 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (2.0)Requirement already satisfied: werkzeug<2,>=1.0.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (1.0.1)Requirement already satisfied: itsdangerous<2,>=1.1.0 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (1.1.0)Requirement already satisfied: cachelib<0.2,>=0.1 in /home/pi/oprint/lib/python2.7/site-packages (from OctoPrint==1.7.0) (0.1)Collecting PyYAML<6,>=5.4.1Downloading PyYAML-5.4.1.tar.gz (175 kB)Installing build dependencies: startedERROR: Command errored out with exit status 1:command: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-aADArI/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple --extra-index-url https://www.piwheels.org/simple -- setuptools wheel Cythoncwd: NoneComplete output (24 lines):Traceback (most recent call last):File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main"__main__", fname, loader, pkg_name)File "/usr/lib/python2.7/runpy.py", line 72, in _run_codeexec code in run_globalsFile "/home/pi/oprint/lib/python2.7/site-packages/pip/__main__.py", line 26, in <module>sys.exit(_main())File "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/cli/main.py", line 73, in maincommand = create_command(cmd_name, isolated=("--isolated" in cmd_args))File "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/commands/__init__.py", line 105, in create_commandmodule = importlib.import_module(module_path)File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module__import__(name)File "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/commands/install.py", line 17, in <module>from pip._internal.cli.req_command import RequirementCommand, with_cleanupFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/cli/req_command.py", line 18, in <module>from pip._internal.index.collector import LinkCollectorFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_internal/index/collector.py", line 14, in <module>from pip._vendor import html5lib, requestsFile "/home/pi/oprint/lib/python2.7/site-packages/pip/_vendor/requests/__init__.py", line 43, in <module>from pip._vendor import urllib3File "/home/pi/oprint/lib/python2.7/site-packages/pip/_vendor/urllib3/__init__.py", line 9, in <module>from logging import NullHandlerImportError: cannot import name NullHandler----------------------------------------ERROR: Command errored out with exit status 1: /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-aADArI/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple --extra-index-url https://www.piwheels.org/simple -- setuptools wheel Cython Check the logs for full command output.Installing build dependencies: finished with status 'error'Die Aktualisierung wurde nicht erfolgreich abgeschlossen. Bitte konsultiere <code>octoprint.log</code> und <code>plugin_softwareupdate_console.log</code> für Details.


    Ich verstehe einfach nur Bahnhof.... ?(:( Vieleicht kann mir ja jemand helfen?

    Edited once, last by Mocom ().

  • Schade, dass du den Ausgangsbeitrag gelöscht hast !
    Schön, dass sich das Problem für DICH geklärt hat !
    Es wäre schön, wenn du uns hier auch aufklärten würdest, wie du das gemacht hast.

    Ich habe unter

    https://github.com/OctoPrint/OctoPrint/releases/tag/1.7.0


    gefunden, dass Python2 und Python2.7 (wie noch von dir benutzt) mit einem Update versorgt werden sollten:


    Quote

    Heads-up for anyone still on Python 2

    I'll do my very best to keep OctoPrint functional under Python 2 until the release of OctoPrint 2.0.0, however Python 2.7 has been EOL now for almost two years, a lot of third party libraries are releasing updates for Python 3 only at this point, and many plugin authors for OctoPrint do so as well.

    It is time to upgrade, and so OctoPrint 1.7.0 will now show you a pop-up about that fact when you open the UI. You do not have to act, but it is strongly recommended you do if you don't want to be left behind, and the pop-up will also tell you how to update: