php5-pgsql installieren

  • hallo an alle,


    ich versuche gerade auf meinen alten pi3 mit auch alten Softwarestand Postgresql zu installieren. Besser gesagt ist Postgresql 9.4 schon seit Jahren auf dem pi. Nun möchte ich aber PHP5 (ja auch das ist schon etwas in die Jahre gekommen) mit Postgresql zusammen nutzen.


    Dazu fehlt mir "php5-pgsql" und dieses wollte ich mit "sudo apt-get install php5-pgsql" nachinstallieren.


    Dabei erhalte ich nachfolgende Fehlermeldung:


    sudo apt-get install php5-pgsql

    Paketlisten werden gelesen... Fertig

    Abhängigkeitsbaum wird aufgebaut.

    Statusinformationen werden eingelesen.... Fertig

    Die folgenden NEUEN Pakete werden installiert:

    php5-pgsql

    0 aktualisiert, 1 neu installiert, 0 zu entfernen und 139 nicht aktualisiert.

    Es müssen 48,8 kB an Archiven heruntergeladen werden.

    Nach dieser Operation werden 205 kB Plattenplatz zusätzlich benutzt.

    WARNUNG: Die folgenden Pakete können nicht authentifiziert werden!

    php5-pgsql

    Diese Pakete ohne Überprüfung installieren? [j/N] J

    Fehl http://mirrordirector.raspbian.org/raspbian/ jessie/main php5-pgsql armhf 5.6.33+dfsg-0+deb8u1

    404 Not Found [IP: 93.93.128.193 80]

    E: Fehlschlag beim Holen von http://mirrordirector.raspbian…3+dfsg-0+deb8u1_armhf.deb 404 Not Found [IP: 93.93.128.193 80]


    E: Einige Archive konnten nicht heruntergeladen werden; vielleicht »apt-get update« ausführen oder mit »--fix-missing« probieren?




    Ein apt-get update habe ich auch schon laufen lassen, trotzdem der gleiche Fehler.

    Was kann ich noch machen?

  • Na gut dann halt doch! also


    dann "sudo apt-get update" und dann "sudo apt-get dist-upgrade" ??


    Wenn ja erhalte ich nun auch hier schon Fehlermeldungen das diverse Pakete nicht mehr heruntergeladen werden können.


    Gibt es noch einen anderen Weg?

  • Ich bringe schon wieder schlechte Nachrichten. Jessie ist schon so alt, dass ein Upgrade zum aktuellen Release so nicht funktioniert. Ich fürchte Du musst ganz neu installieren und alles wieder von Hand einrichten. Dazu empfehle ich Dir dringendst eine neue SD-Karte zu verwenden.


    Tut mir wirklich leid und ich schäme mich sogar ein bissel hier der Bote der schlechten Nachrichten zu sein. ;)

  • Warum eine neue SD Karte? 32 gb sind drin und es ist ein pi 3. wenn ja welches würdest du empfehlen?