Keine Verbindung mehr über IP4-Adresse

  • Hi,


    ich betreibe einen Raspi 3B in meinem lokalen Netz als pihole-Server. Das ging auch lange Zeit so problemlos, dass ich den Raspi fast vergessen habe ;)


    Dann habe ich vor ein paar Tagen komplett die Verbindung verloren -

    • ssh geht nicht (Connection refused),
    • pihole-Adminseite kann nicht mehr aufgerufen werden (Server not available),
    • aber ein ping auf die IP4-Adresse geht.

    Ich bin dann mit Tastatur und Monitor an den Pi gegangen und habe etwas gesucht:

    • ip a liefert eth0 als aktiv, aber ausschließlich mit inet6-Adresse
    • manuell kann man die IP4 erzwingen, aber den Pi dennoch nicht erreichen - nach einem Reboot ist sie auch wieder weg
    • Der Pi selber kommt problemlos ins Internet
    • Alle IP4-Befehle (ssh, ping etc.) von der Konsole des Pi scheitern mit "connect: das Netzwerk ist nicht erreichbar"


    Als Router habe ich eine Fritzbox 6591 mit FritzOS 7.27 (Vodafone Kabel). Wenn nicht Vodafone irgendwas remote verstellt hat, ist die unverändert seit vor dem Ausfall der Verbindung zum Pi.

    Die Fritzbox kennt den Pi auch unter seiner IP4-Adresse. Der Pi hängt über einen Switch direkt am LAN1 der Fritzbox.


    Ich habe die statische IP (die Fritzbox vergibt immer die gleiche an den Pi) in /etc/dhcpcd.conf eingetragen - null Effekt.


    Ich habe mit apt-get upgrade das Raspbian auf den neuesten Stand gebracht - keine Änderung.


    Jetzt sind mir die Ideen ausgegangen. Kann mir jemand weiterhelfen?

    Edited once, last by Miq61: Ergebnis von ssh und ping von der Konsole aus hinzugefügt. ().

  • Moin Miq61,


    erstmal: Herzlich Willkommen im Forum!


    Ganz einfache Frage. Die Fritzbox mal neu gestartet?

    Hat bei mir schon mehrfach geholfen.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • ...

    • aber ein ping auf die IP4-Adresse geht.

    Ich bin dann mit Tastatur und Monitor an den Pi gegangen und habe etwas gesucht:

    • ip a liefert eth0 als aktiv, aber ausschließlich mit inet6-Adresse


    Als Router habe ich eine Fritzbox 6591 mit FritzOS 7.27 (Vodafone Kabel). ... Der Pi hängt über einen Switch direkt am LAN1 der Fritzbox.

    Wie kann ein Ping auf die IPv4-Adresse funktionieren, wenn "ip a" auf deinem PI, nur eine IPv6-Adresse für das eth0-Interface deines PIs anzeigt?


    Hast Du DS oder DS-lite, bei Vodafone?

    Teste mal temporär über einen geeigneten Zeitraum, ohne Switch, d. h. den PI direkt mit der FritzBox verbinden und nicht via Switch.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Ja, mehrfach. Leider keine Änderung.

  • Wie kann ein Ping auf die IPv4-Adresse funktionieren, wenn "ip a" auf deinem PI, nur eine IPv6-Adresse für das eth0-Interface deines PIs anzeigt?


    Hast Du DS oder DS-lite, bei Vodafone?

    Teste mal temporär über einen geeigneten Zeitraum, ohne Switch, d. h. den PI direkt mit der FritzBox verbinden und nicht via Switch.

    Ich vermute, die Fritzbox übersetzt das in IPV6 und spricht den Pi darüber an.


    DS sagt mir nix, ich bin quasi Kriegsbeute als ehemaliger Unitymedia-Kabelkunde.

  • Ich vermute, die Fritzbox übersetzt das in IPV6 und spricht den Pi darüber an.


    DS sagt mir nix, ich bin quasi Kriegsbeute als ehemaliger Unitymedia-Kabelkunde.

    Nein, das mit dem Übersetzen gibt es nicht. Schau mal im Gerät von dem Du den v4-Ping machst, wie dort die Ausgabe von:

    Code
    arp -a

    ist, wenn der v4-Ping funktioniert obwohl der PI keine IPv4-Adresse mehr hat.

    DS (Dual Stack) und DS-lite hat es auch schon bei Unitymedia gegeben.

    BTW: Ab und zu gibt es auch Probleme mit der Koexistenz von IPv4 und IPv6. Es könnte aber auch mit deinem Switch zu tun haben.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • ping 192.168.178.99 liefert


    arp -a liefert:

    Code
    192.168.178.99        00-27-15-08-5e-f9     dynamisch

    Dabei ist die MAC-Adresse aus dem ping eine andere als die, die ich mit ifconfig auf dem Raspi bekomme.


    Das Ganze ist genauso, wenn ich den Raspi direkt an die Fritzbox hänge.


    Nach einem Neustart des Switch (ohne dass der Raspi da noch dranhing) liefert arp jetzt

    Code
    192.168.178.99        b8-27-eb-5d-61-db     dynamisch

    mit der korrekten MAC-Adresse.


    Nach einem Restart des Raspi kommt aber wieder die erste, falsche MAC-Adresse.


    Aufruf von ssh oder der pihole-Adminseite geht konsequent nicht.


    ping vom RAspi an eine der IP4-Adressen brint konsequent "Das NEtzwerk ist nicht erreichbar"

  • Dabei ist die MAC-Adresse aus dem ping eine andere als die, die ich mit ifconfig auf dem Raspi bekomme.


    Das Ganze ist genauso, wenn ich den Raspi direkt an die Fritzbox hänge.

    So richtig verstehe ich nicht, was Du da schreibst bzw. meinst. Denn beim ping gibt es z. B. keine MAC-Adresse.

    Ich vermute, dass der Switch dein Problem ist. Benutze mal über einen Zeitraum von ca. 4 Wochen keinen Switch.

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • So richtig verstehe ich nicht, was Du da schreibst bzw. meinst. Denn beim ping gibt es z. B. keine MAC-Adresse.

    Ich vermute, dass der Switch dein Problem ist. Benutze mal über einen Zeitraum von ca. 4 Wochen keinen Switch.

    Nict das ping gibt die Adresse, sondern arp -a. Kannst Du ja oben sehen.


    Und ohne Switch bricht hier alles zusammen, da hängen 6 Geräte und ein Subnetz dran - die Fritzbox 6591 hat ja nur noch 2 LAN-Ports.

    Edited once, last by Miq61 ().

  • ..., sondern arp -a. Kannst Du ja oben sehen.

    Ja, und das habe ich schon gesehen, aber Du hast ping und nicht arp geschrieben.

    BTW: Wenn arp für ein und dieselbe IPv4-Adresse, verschiedene MAC-Adresse-Zuordnung im arp-cache findet, stimmt etwas nicht.

    Welches Gerät/NIC hat die MAC-Adresse "00-27-15-08-5e-f9" und welches Gerät/NIC hat die MAC-Adresse "b8-27-eb-5d-61-db"? Evtl. mit MAC-Adresse-Lookup feststellen.


    EDIT:


    Ist das:

    Code
    MAC Address Details
    Company Rebound Telecom. Co., Ltd
    Address Shanghai 200233
    CHINA
    Range 00:27:15:00:00:00 - 00:27:15:FF:FF:FF
    Type IEEE MA-L

    evtl,. dein Switch oder dein Router/Modem?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Egal mit ping und arp, denke ich.


    Die b8:27:... MAC-Adresse ist der eth0 vom Raspi, die 00:27:... ist Rebound Telecom - ich habe keine Ahnung, was für ein Gerät das sein könnte.

  • ..., die 00:27:... ist Rebound Telecom - ich habe keine Ahnung, was für ein Gerät das sein könnte.

    Naja, irgendwo muss das Gerät schon sein, denn diese MAC-Adresse ist ja nicht vom Himmel gefallen.

    Versuch mal auf dem PI, mit:

    Code
    sudo arp-scan -I eth0 192.168.178.0/24
    sudo apt update
    sudo apt-get install netdiscover
    sudo dpkg --configure -a
    sudo netdiscover -i eth0 -c 3 -r 192.168.178.0/24
    arp -av

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Tja, das scheitert ja leider am Urproblem "Das Netzwerk ist nicht erreichbar" - der Raspi hat ja keine IP4-Adresse. Ich kann nicht einmal arp-scan herunterladen.

    Er versucht es mit der IP6-Adresse, bekommt aber keine Verbindung mehr. Wie geschrieben, gestern ging noch ein apt-get...

    Edited once, last by Miq61: Detaillierte Beschreibung ().

  • Tja, das scheitert ja leider am Urproblem "Das Netzwerk ist nicht erreichbar" - der Raspi hat ja keine IP4-Adresse.

    Dann versuch mal mit:

    Code
    sudo systemctl restart dhcpcd
    ip a

    und wenn das keine IPv4-Adresse zuweist, dann mit einem reboot des PI. Evtl. auch überlegen, den dhcpcd5 zu deinstallieren und die IPv4-Adresse mit systemd-networkd zuweisen lassen.


    BTW: Benutzt Du IPv6 bzw. brauchst Du zwingend IPv6 mit deinem PI?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Von einer virtuellen Linux-Maschine im gleichen Netz:

    Code
    $ sudo arping -c 3 -I eth0 192.168.178.99
    ARPING 192.168.178.99 von 192.168.178.58 eth0
    Unicast antworten von 192.168.178.99 [00:27:15:08:5E:F9]  113.466ms
    Unicast antworten von 192.168.178.99 [00:27:15:08:5E:F9]  33.130ms
    Unicast antworten von 192.168.178.99 [00:27:15:08:5E:F9]  108.395ms
    Sent 3 probes (1 broadcast(s))
    3 Antwort(en) erhalten

    und

    Code
    $ traceroute 192.168.178.99
    traceroute to 192.168.178.99 (192.168.178.99), 64 hops max
    1   192.168.178.99  126,575ms  11,807ms  132,505ms
  • Code
    Unicast antworten von 192.168.178.99 [00:27:15:08:5E:F9]

    Da hast du wohl ein gerät in deinem Netz, welches diese IP fest einkonfiguriert hat und somit deinen PI-Hole verdrängt.

    Wenn du nicht weißt, was das ist, schau mal bei der FritzBox, die dein WiFi bereitstellt, ob sie diese IP bei einer Verbindung hat (WLAN => Funknetz).

    Auch kannst du das in der F!B in der Heimnetz => Netzwerk sehen, wer das sein könnte

    Selber denken,
    wie kann man nur?

  • Die Fritzbox hat unter WLAN die IP nicht, unter Netzwerk dies hier:

    Das passt auch alles, die MAC-Adresse ist richtig.

  • Tadaaa!


    Ich habe das Gerät aus der Fritzbox gelöscht. Dann hat sich der Raspi neu per DHCP angemeldet und nun geht alles wieder?!? :bravo2: