Samba funktioniert trotz gleicher Konfiguration nicht

  • Edit: Lösung siehe am Post-Ende.


    Hallo zusammen,


    ich bin mir sicher, dass es hier schon viele Threads dazu gibt, aber ich habe noch keinen mit einer passenden Lösung gefunden. Dr. Google kann auch nicht helfen.


    Hintergrund-Info:

    Ich habe auf einem Pi 4B mit Raspbian Buster und auf einem Pi 2B mit Raspbian Stretch Lite Samba zum Laufen gebracht, bei ersterem recht umständlich, bei zweiterem ohne Probleme, da ich scheinbar die Probleme, die ich beim 4B hatte, umgangen bin. Jetzt möchte ich Samba auf dem Pi 4B auf einer anderen SD-Karte mit Raspbian Buster Lite installieren.


    Dazu habe ich das übliche gemacht:

    1) Das System auf den neuesten Stand gebracht

    2) sudo apt install samba samba-common-bin

    3) mkdir /home/michael/shares

    4) sudo chmod 777 /home/michael/shares

    5) sudo nano /etc/samba/smb.conf und diese danach konfiguriert. Jetzt sieht sie so aus:


    Danach habe ich Samba mittels sudo service smbd restart neu gestartet.


    Mit Windows 10 will ich jetzt auf diesen geteilten Ordner zugreifen - \\192.168.8.180 funktioniert nicht: Fehlermeldung 0x80004005.


    Per \\192.168.8.170 kann ich auf die geteilten Ordner der SD-Karte im Pi 2B zugreifen (welche vorher übrigens in ebendiesem Pi 4B war).


    Die Samba-Konfiguration auf dieser SD-Karte sieht so aus:



    Natürlich ist der Ordner /home/pi/Motion vorher ebenfalls mit sudo chmod 777 bearbeitet worden.


    Bei Bedarf kann ich den Inhalt der Samba-Konfigurationsdatei der Stretch-Installation auch posten.


    Ich hoffe ihr könnt mir helfen...


    Viele Grüße

    Michael :)


    Edit: Die Lösung:

    Ich konnte nicht auf die Samba-Freigabe zugreifen, weil ich auf dem Raspi die ufw-Firewall installiert hatte und dementsprechend fast alle Port geblockt wurden. Hab dann also mittels sudo ufw allow 445 den Samba-Port freigegeben, jetzt funktioniert alles so, wie es soll ^^

    Edited 2 times, last by Arcturus ().

  • Go to Best Answer
  • Servus,


    nein habe ich nicht, weil ich es bei den ersten beiden Konfigurationen ebenfalls nicht gebraucht habe und das ganze sowieso ohne Passwort lösen möchte.


    LG

  • 3) mkdir /home/michael/shares


    [Motion] Comment = Raspberry Pi Shared Folder

    Path = /home/pi/Motion

    Browseable = yes

    Was denn nun? /home/michael/shares oder/home/pi/Motion ?

  • Was denn nun? /home/michael/shares oder/home/pi/Motion ?

    Am einen Pi will ich den shares-Ordner teilen, am anderen Pi den Motion-Ordner....

    Die restliche Konfiguration dürfte jedoch gleich sein.

  • hallo,


    du könntest auch versuchen das smb Protokoll anzuheben, indem du in der smb config unter global folgendes einträgst


    Code
    client max protocol = default  client min protocol = SMB2_02  server max protocol = SMB3  server min protocol = SMB2_02


    Quelle: https://wiki.ubuntuusers.de/Samba_Server/smb.conf/



    Code
    testparm -v | grep protocol


    Hiermit kannst du schauen, welches Protokoll aktuell aktiv ist

    Edited once, last by Andi17 ().

  • Ich habe in Windows die SMB1-Unterstützung aktiviert und dann wurde mir der Raspberry bei den Netzwerk-Geräten angezeigt, doch ich konnte nicht auf den Ordner zugreifen ?( deshalb habe ich es wieder deaktiviert.


    du könntest auch versuchen das smb Protokoll anzuheben, indem du in der smb config unter global folgendes einträgst

    Habe ich soeben gemacht:

    Danach wieder sudo service smbd restart, hat aber nicht geholfen. Trotzdem danke :thumbup:

  • doch ich konnte nicht auf den Ordner zugreifen

    Versuch es mal damit

    https://askubuntu.com/question…e-samba-share-no-password


    Quote

    edit the samba file

    Code
    nano /etc/samba/smb.conf

    find the line # ---- Standalone Server Options ---- append "map to guest"

    Code
    security = user
    passdb backend = tdbsam
    map to guest = Bad User

    Under the section #==== Share Definitions ==== add your share

    Code
    [SHARENAME]
    path = the_folder
    read only = no
    create mask = 777
    guest ok = yes

    Save the file and restart samaba

    Code
    /etc/init.d/smb restart
  • Danke für den Tipp, werde ich in den nächsten Tagen mal probieren.


    Anderes Thema:

    Wenn ich Samba mittels sudo apt purge samba samba-common-bin vollständig deinstalliere und danach wieder mittels sudo apt install samba samba-common-bin installiere, ist immer noch die alte Konfigurationsdatei mit deren Einstellungen vorhanden. Woran liegt das?

  • Ist mir auch schon aufgefallen, dass mit purge nicht unbedingt alles gelöscht wird. Wird wohl ein Fehler in den Skripten sein, oder mögliche Fehlermeldungen werden unterdrückt. Z.B. werden nicht leere Verzeichnisse nicht gelöscht. Das kann man aber von Hand nachholen, wenn man davon weiss.

  • So, ich habe in der Zwischenzeit Raspberry Pi OS mal als VM installiert und habe dort Samba installiert und konfiguriert. Und es funktioniert einwandfrei ^^;(


    Da ich jetzt dank euch weiß, wie die smb.conf richtig gelöscht werden kann, wollte ich das mal am Pi machen und Samba neu installieren. Und siehe da, er bootet auf einmal nicht mehr!


    Gestern Abend habe ich laut bash-history noch mal was an der smb.conf geändert (oder auch nicht, zumindest fällt mir hier am Hauptrechner über Zugriff auf die SD-Karte nix auf) und den Pi dann mittels sudo shutdown -h now heruntergefahren.


    Jetzt wollte ich ihn also wieder einschalten, doch die Activity-LED leuchtet und blinkt für ca. 10 Sekunden und geht dann aus (bzw. sie blinkt regelmäßig gaaaaanz schwach). Die beiden Ethernet-LEDs leuchten auch durchgehend --> keine Internetverbindung --> kein erfolgreicher Boot, schätze ich mal.


    Helft mir liebe Forumsmitglieder, ihr seid meine letzte Hoffnung.... ;)


    Kann man eventuell an irgendeiner Boot-Logdatei herausfinden, ob was beim Booten schiefläuft?

    • Best Answer

    Hab beide Probleme gelöst!


    Der Raspi bootete nicht vollständig, weil ich in der /etc/fstab das Auto-Mounten eines USB-Sticks eingestellt hatte und dieser bei den gestrigen Boot-Versuchen nicht eingesteckt war.


    Ich konnte nicht auf die Samba-Freigabe zugreifen, weil ich auf dem Raspi die ufw-Firewall installiert hatte und dementsprechend fast alle Port geblockt wurden. Hab dann also mittels sudo ufw allow 445 den Samba-Port freigegeben, jetzt funktioniert alles so, wie es soll ^^


    Vielen vielen Dank für alle eure Antworten!

    Edited once, last by Arcturus ().

  • Der Raspi bootete nicht vollständig, weil ich in der /etc/fstab das Auto-Mounten eines USB-Sticks eingestellt hatte und dieser bei den gestrigen Boot-Versuchen nicht eingesteckt war.

    Das lässt sich mit der Option nofail verhindern

  • Arcturus

    Selected a post as the best answer.
  • ist immer noch die alte Konfigurationsdatei mit deren Einstellungen vorhanden. Woran liegt das?

    Oft werden vom Anwender geänderte Konfigurationsdateien beim entfernen des Programms nicht mit gelöscht. Das wird dann auch auf der Kommandozeile ausgegeben, dass eine geänderte Konfigurationsdatei bestehen bleibt.

    Selber denken,
    wie kann man nur?

  • Arcturus Zeig beim nächsten mal bitte gleich alle Infos im ersten Beitrag, denn weder ufw noch externes Laufwerk finde ich dort! Hier in so einem Fall als Außenstehender erfolgreich zu helfen gleicht einem 6er im Lotto.

    Hast Recht, ja.

    Ich dachte, es würde keinen Einfluss haben und versuchte mich generell an "nur so viel Info wie nötig" zu orientieren, was auf Stack Overflow usw. auch gefordert wird.