Defekt nach Urlaub? Netzwerk LEDs bleiben aus

  • Hallo,


    seit einem halben ca. bin ich bisher ein glücklicher Besitzer eines Raspberry Pi 3 Model B V1.2

    Die Installation und Konfiguration von PiHole und Homebridge hat sehr gut funktioniert, bis ich vor kurzem in den Urlaub gefahren bin. Als ich zurück kam hatte ich Zuhause kein Internet mehr; schnell konnte der Raspberry als Fehlerquelle ausgemacht werden und die IP in der FritzBox wurde wieder zurück gesetzt. Seitdem soweit wieder alles gut, bloß der Raspberry ist ohne Funktion.

    Aufgefallen ist, dass zwar die rote LED leuchtet die NetzwerkLEDs jedoch nicht. Nach kurzer Recherche hab ich erstmal ein neues Netzteil bestellt jedoch auch ohne Erfolg.


    So nun zu meinen Fragen:

    1. Was könnte man noch probieren?
    2. Falls es wohl ein defekt ist, ist es möglich im neuen Pi die alte Konfiguration 1 zu 1 aufzuspielen?


    Vielen Dank

    Dennis

  • brasi93

    Changed the title of the thread from “Keine Funktion nach Urlaub” to “Defekt nach Urlaub? Netzwerk LEDs bleiben aus”.
  • Als ich zurück kam hatte ich Zuhause kein Internet mehr; schnell konnte der Raspberry als Fehlerquelle ausgemacht werden und die IP in der FritzBox wurde wieder zurück gesetzt. Seitdem soweit wieder alles gut, bloß der Raspberry ist ohne Funktion.

    Aufgefallen ist, dass zwar die rote LED leuchtet die NetzwerkLEDs jedoch nicht. Nach kurzer Recherche hab ich erstmal ein neues Netzteil bestellt jedoch auch ohne Erfolg.

    Mit "kein Internet" meinst Du, dass in deinem (W)LAN die Namensauflösung (DNS) nicht mehr funktioniert hat, weil diese vom PI gemacht wird? Deine FritzBox hatte schon Internetzugang, oder?

    Warum bzw. wie hast Du die IP in der FritzBox zurück gesetzt? Was genau meinst Du mit "alles gut"?


    BTW: Welches Netzteil hast Du für deinen PI3 jetzt bestellt?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Pi Netzteil Amazon (Affiliate-Link)Mit "kein Internet" meinst Du, dass in deinem (W)LAN die Namensauflösung (DNS) nicht mehr funktioniert hat, weil diese vom PI gemacht wird? Deine FritzBox hatte schon Internetzugang, oder?


    Warum bzw. wie hast Du die IP in der FritzBox zurück gesetzt? Was genau meinst Du mit "alles gut"?


    BTW: Welches Netzteil hast Du für deinen PI3 jetzt bestellt?

    Ganz genau. Hab die IP des PiHoles wieder aus der FritzBox genommen. Alles Gut, in dem Sinn dass das Internet wieder für alle Geräte verfügbar war.


    Pi Netzteil (Affiliate-Link)

  • Ganz genau. Hab die IP des PiHoles wieder aus der FritzBox genommen.

    Wie sind jetzt auf deinem PI die Ausgaben von:

    Code
    ip a
    route -n
    arp -av

    , wenn dein PI3 mit der FritzBox verbunden ist und gebootet ist?

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Wie sind jetzt auf deinem PI die Ausgaben von:

    Code
    ip a
    route -n
    arp -av

    , wenn dein PI3 mit der FritzBox verbunden ist und gebootet ist?


    Ich habe aktuell leider keinerlei Zugriff auf den Pi. Weder wird mir eine IP in der Fritzbox gezeigt noch sonst eine Möglichkeit. Einzig die SD Karte könnte ich auslesen via Cardreader.

  • Einzig die SD Karte könnte ich auslesen via Cardreader.

    OK, dann zeige mal das Datum und die Uhrzeit der Dateien, mit:

    Code
    ls -la /var/log/wtmp
    ls -la /var/run/utmp
    sudo ls -la /root/.bash_history
    ls -la /home/$USER/.bash_history

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • OK, dann zeige mal das Datum und die Uhrzeit der Dateien, mit:

    Code
    ls -la /var/log/wtmp
    ls -la /var/run/utmp
    sudo ls -la /root/.bash_history
    ls -la /home/$USER/.bash_history

    Viel konnte ich durch die SD Karte über den Explorer leider nicht heraisfinden.


    1. Datei total wirsch, mehr Hieroglyphen als alles andere. Einzig meine IP und einige befehle wie shutdown sind erkennbar.
    2. Die Datei ist komplett leer.
    3. nicht vorhanden
    4. Dort gibt es Inhalt, allerding kein Datum:
  • Hast Du eine zweite SD rumliegen, auf die Du ein Raspberry Pi OS aufsetzten und den RPi damit starten könntest?

    Nein leider nicht. Kann ich denn meine bisherigen Dateien sichern sodass ich mir einen neuen pi zero kaufe und dort die Karte hinein stecke und die Konfiguration ist wie zuvor?

  • Viel konnte ich durch die SD Karte über den Explorer leider nicht heraisfinden.


    1. Datei total wirsch, mehr Hieroglyphen als alles andere. Einzig meine IP und einige befehle wie shutdown sind erkennbar.
    2. Die Datei ist komplett leer.
    3. nicht vorhanden
    4. Dort gibt es Inhalt, allerding kein Datum:

    Ich habe ja auch nicht geschrieben, dass Du die Dateien wtmp, utmp und .bash_history öffnen sollst. Es geht nur um das Datum/Uhrzeit (und nicht um den Inhalt dieser Dateien). Z. B.:

    Code
    :~$ ls -la /var/log/wtmp
    -rw-rw-r-- 1 root utmp 1716480 Okt 30 09:17 /var/log/wtmp
    :~$ ls -la .bash_history
    -rw------- 1 xx xx 49240 Okt 29 22:41 .bash_history

    The most popular websites without IPv6 in Germany.  IPv6-Ausreden

  • Kann ich denn meine bisherigen Dateien sichern sodass ich mir einen neuen pi zero kaufe und dort die Karte hinein stecke und die Konfiguration ist wie zuvor?

    Mir ging es eher darum zu erfahren ob der RPi oder die SD-Karte oder das Dateisystem darauf das Problem ist. Wenn es am Dateisystem liegt, dann nützt Dir ein neuer Zero auch nichts. Dann wirst Du eh neu installieren müssen.


    Besorg Dir eine neue SD-Karte und installiere darauf ein Raspberry Pi OS und versuche damit den RPi zu booten. Dann weißt Du dass der RPi ok ist.

  • Mir ging es eher darum zu erfahren ob der RPi oder die SD-Karte oder das Dateisystem darauf das Problem ist. Wenn es am Dateisystem liegt, dann nützt Dir ein neuer Zero auch nichts. Dann wirst Du eh neu installieren müssen.


    Besorg Dir eine neue SD-Karte und installiere darauf ein Raspberry Pi OS und versuche damit den RPi zu booten. Dann weißt Du dass der RPi ok ist.

    Ok, ist bestellt. Werde dann berichten.


    Schonmal vielen Dank für die Unterstützung

  • So, denke dass der Pi leider defekt ist.

    Hab mir nun den Raspberry Pi Zero 2 W bestellt.


    Gibt es eine Möglichkeit die Konfiguration vom PiHole und von der Homebridge zu sichern, sodass die Einstellungen beibehalten werden können?