„Raspberry Pi 3 Model B Rev 1.2“ mit „Raspberry Pi 3 7“ Touch Display“

  • Hallo!

    Ich hab meinen „Raspberry Pi 3 Model B Rev 1.2“ mit „Raspberry Pi 3 7“ Touch Display“ nach drei Jahren Pause wieder in Betrieb genommen.


    Das ca. 3 Jahre alte BESY (Linux 9 Stretch) auf einer 16GB micro SD funktioniert wunderbar.


    Das neueste BESY (Linux 11 bullseye) inzwischen schon mehrmals herunter- und auf div. SD Karten geladen läuft einfach nicht.

    Taugt das nicht mehr für Alte Pi 3 Modelle?


    Nach Spannung EIN passiert folgendes:

    -Das Regenbogen Quadrat kommt

    -Das Welcome Bild kommt und verschwindet wieder

    -gleich danach kommen nur senkrechte Streifen am Display mit einem Abstand von ca. 1 mm

    -Über PuTTY und SSH komm ich ganz normal rein.

    -Das Netzteil macht 3A und ist offiziell von Raspberry wie alle anderen Teile.


    Passt die Firmeware evtl. nicht mehr für die älteren Pi 3 Modelle oder fehlt da was in der SW?


    Vielleicht weiß das jemand?

    Hans



    Neuestes BESY funktioniert nicht


    pi@raspberrypi:~ $ cat /etc/os-release

    PRETTY_NAME= "Raspbian GNU/Linux 11 (bullseye)"

    NAME= "Raspbian GNU/Linux"

    VERSION_ID= "11"

    VERSION= "11 (bullseye)"

    VERSION_CODENAME= bullseye

    ID= raspbian

    ID_LIKE= debian

    HOME_URL= "http://www.raspbian.org/"

    SUPPORT_URL= "http://www.raspbian.org/RaspbianForums"

    BUG_REPORT_URL= "http://www.raspbian.org/RaspbianBugs"



    Das ist OK:

    pi@raspi:~ $ cat /etc/os-release

    PRETTY_NAME= "Raspbian GNU/Linux 9 (stretch)"

    NAME= "Raspbian GNU/Linux"

    VERSION_ID= "9"

    VERSION= "9 (stretch)"

    VERSION_CODENAME= stretch

    ID= raspbian

    ID_LIKE= debian

    HOME_URL= "http://www.raspbian.org/"

    SUPPORT_URL= "http://www.raspbian.org/RaspbianForums"

    BUG_REPORT_URL= "http://www.raspbian.org/RaspbianBugs"

  • Go to Best Answer
  • Hallo Hans555,


    willkommen im Forum!

    Das Netzteil macht 3A und ist offiziell von Raspberry wie alle anderen Teile

    Das offizielle Netzteil für den RPi 3B hat 2.5A bei 5.1V. Dein Netzteil kann also nicht das offizielle sein. Leider verkaufen aber manche Händler ihre Netzteile als Originale. Das aber (erstmal) nur am Rande. ;)


    Hast Du evtl. ein Link zu diesem Netzteil oder besser noch zum ganzen Set?

  • Hallo Hoschi,

    das kann sein mit dem Netzteil, das ist von Amazon => https://www.amazon.de/dp/B07XR7YXZX/ref=pe_27091401_487024491_TE_item (Affiliate-Link)

    Ich hab das erst Heute bekommen.

    Sonst nutze ich ein 5A Labornetzteil mit Mikro USB Stecker.

    Daran kann es aber nicht liegen, denn wenn ich die alte Firmware (Stretch) stecke, funktioniert ja alles Wunderbar mit beiden Netzteilen.

    Das muss an der neuen Firmware liegen, obwohl auf der Raspi Seite steht: "Compatible with All Raspberry Pi models"

    Ich hab die hier: https://www.raspberrypi.com/software/operating-systems/

    "Raspberry Pi OS with desktop and recommended software"

  • Es klingt fuer mich eher nach einem Displayeinstellungsproblem. Da Du per ssh auf die Raspi kommst: Sieh doch mal in /var/log/messages nach ob Du da Fehlermeldungen dazu findest.

    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect."

    Linus Benedict Torvalds, 28.9.2003


    Hast Du die Woche schon Deine Raspberry gesichert =O Bei mir tut das raspiBackup automatisch ;)

    • Best Answer

    Ich habe hier gerade das Ganze mal nachgestellt.

    Buster geht, Bullseye nicht.

    Ich teste ein wenig und melde mich wieder.


    Und habe gerade das gefunden: https://beta.raspberrypi.org/forums/viewtopic.php?p=1935996 "The official DSI touchscreen on Bullseye without touch function!!!"


    u.a. mit:

    Quote

    Nothing forced you to upgrade to Bullseye on the first day of release, and there are a number of minor issues to solve. If it is such a showstopper to you, stay with Buster for the time being.

    Es lohnt aber, den kurzen Thread zu lesen!

    Edited once, last by simonz ().

  • Danke erst mal!

    Ich probier das aus.....


    Hier gibts noch alte Betriebssysteme: => https://downloads.raspberrypi.org/raspbian/images/

    STECTCH und BUSTER funktionieren WUNDERBAR, ab BULLS... geht dann nix mehr ...

    mit diesen 7“ Touch Display: => https://www.pollin.de/p/raspbe…ouch-lcd-7-17-8-cm-702623

    Dann stimmt aber die Aussage auf der Seite von <"RaspberryPi.com "Operating-System"> nicht ganz,

    denn dort steht bei der neuesten OS Version: Compatible with: All Raspberry Pi models


    Egal, Hauptsache ich hab meine beiden Raspi 3 Modell B mit 7" Displays wieder am laufen.


    Danke!

    Hans

    Edited 3 times, last by Hans555 ().

  • Hans555

    Selected a post as the best answer.
  • Hans555

    Selected a post as the best answer.