Nach der Neuinstallation mit dem Image vom 30.10. extrem niedrige Auflösung bei VNC

  • Hallo zusammen,


    nach der Neuinstallation mit dem "2021-10-30-raspios-bullseye-armhf" Image, habe ich nun unter VNC eine sehr kleine Auflösung (320x200 oder so) und kanne s auch nicht verändern, da beide HDMI ausgegraut sind.


    Boot.config ist wie folgt eingestellt:


    Code
    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=2
    hdmi_mode=82
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    hdmi_drive=2

    Der Rest ist so belassen.


    Das hatte früher immer prima geklappt.

  • Moin!


    Keine Ahnung ob das neu ist, aber es gibt eine Einstellung "headless Resulotion" Unter "Raspberry Pi-Konfiguration"



    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • Hallo hg6806,

    meine Einstellung sieht so aus:

    Code
    # hdmi_cvt=1366 768 60      # max Auflösung für meinen speziellen TV
    hdmi_cvt=1900 1000 60 3     # gewählte Auflösung unter VNC
    hdmi_group=2
    hdmi_mode=87
    hdmi_drive=2
    dtparam=audio=on
    [pi4]
    max_framebuffers=2
    [all]
    hdmi_force_hotplug=1

    Die Auflösung habe ich etwas kleiner als 1920x1080 gewählt,

    damit der HD-Monitor nicht voll ausgenützt wird und die Darstellung

    im Fenster sichtbar ist.

  • Moin hg6806,


    wenn dieses Problem damit erledigt ist, dann, bitte, als erledigt markieren. Das geht oben bei "Thema bearbeiten".

    Danke.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • In raspi-config verschwand die bisherige "D1 Resolution" Einstellung und stattdessen wurde unten "D5 VNC Resolution" angehängt, die wohl genau das jetzt steuern soll.


    Vielleicht hilft es.

    ;) Gruß Outi :D
    PIs: 2x Pi B (Rente) / 1x Pi B+ (Rente) / 1x Pi 2 B (Tests) / 2x Pi 3 B (RaspberryMatic / Repetier Server) / 2x Pi Zero 1.2 (B. Lite) / 2x Pi Zero 1.3 (B. Lite)
    2x Pi Zero W 1.1 (B. Lite) / 1x Pi Zero 2 (noch ohne) / 1x Pi 3 B+ (Tests) / 1x Pi 4 B 4GB (Ubuntu Server 64 Bit) / Pi 400 (Bullseye) / 2x Pi Pico
    Platinen: Sense HAT / RPI-RF-MOD / PiFi DAC+ V2.0 / TV HAT

  • Das sollte eigentlich schon länger Geschichte sein, aber versuchs mal mit auskommentieren (eine # an den Zeilenanfang) der Zeile(n) dtoverlay=vc4-fkms-v3d.


    Vielleicht bringt Das ja was.

    hhmm, damit folgt der Bildschirm zwar nun schön der Skallierung meines VNC Clientfensters ... ist schon mal was.


    :no_sad: Aber NEIN bezüglich Auflösung der Raspi Anzeige im VNC Clientfenster, die ist immer noch weit entfernt der in raspi-config unter D5 (Headless Resolution) eingestellten.


    Was ist zu tun?

    Gruss superbike

  • Also ich muss zugeben ich hab noch nie den eingebauten RealVNC benutzt, (oder auch schon vergessen) ich benutzte x11vnc weil man keine xstartup braucht, wobei ich nicht weiß wie man diese Datei anlegt :) zwecks Inhalt.

    Ich kann auch nicht sagen ob, man im VNC das sieht, was man auf dem Monitor sieht.


    Aber was ich weiß wie man den den Befehl eventuell aufmotzen kann um eine Auflösung zu erzwingen.


    sudo ps aux|grep -i vnc


    Damit müsste der Befehl wie vnc gestartet wird auftachen.

    Die Idee ist (ohne viel Ahnung zu haben, eigentlich praktisch 0 bei mir) um ein Display ""Resolution"" Argument bzw. Option dem Befehl hinzufügen wie hier beschrieben: https://help.realvnc.com/hc/en…tual-Man-Page#options-0-5


    Code
    -geometry WxH
    Specifies the size of the virtual desktop. The default is 1024x768.


    Dazu müsste man den vnc (s.h ps aux oben) "killen" und einfach -geometry anfügen und starten.

    Wie gesagt ich hab x11vnc, da muss man praktisch gar nichts wissen :)

    Ist aber ein nachgemachter VNC und RealVNC ist das Orginal.

  • PS: Mir ist gerade eingefallen (läuft schon 2 Jahre ohne Monitor am PI)

    Wenn kein Monitor angeschlossen ist, das ist das Problem, und er (Pi) kennt die Auflösung nicht.

    Früher hat das geholfen:

    nano /boot/config.txt

    (auskommentieren # vorne weg)

    hdmi_force_hotplug=1


    Aber das kam oben schon mal. Beim RaspberryPi wird (glaub ich) auch der AV Ausgang nicht per default eingeschaltet.

    Code
    hdmi_cvt .....

    Wurde oben schon beschrieben birkner, wenn das ein geschaltet wird sollte es auf dem PI 4b auch gehen.

  • Moin!


    ich habe mal eben einige Einstellungen für VNC getestet.


    Testumgebung: RPi4b mit Raspberry Pi OS (bullseye) mit Desktop. Laptop mit Arch-Linux und VNC-Viewer 6.20.xxx.


    Es ist egal, ob ich das mit raspi-config in der Konsole oder, Desktop, unter Himberre/Einstellungen/Raspberry Pi-Konfiguration/Anzeige/Auflösung einstellen, mache. Alles endet in der /boot/config.txt!!


    Code
    hdmi_force_hotplug=1

    Wenn der auskommentiert wird, dann sagt VNC "Desktop kann nicht angezeigt werden. Ergo: Erforderlich

    Code
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=2
    hdmi_mode=85

    Beide "Einstellungsprogramme" ändern die Einträge in diesen 2 Zeilen.


    73 de Bernd

    Ich habe KEINE Ahnung und davon GANZ VIEL!!
    Bei einer Lösung freue ich mich über ein ":thumbup:"

    Vielleicht trifft man sich in der RPi-Plauderecke.

  • .... Alles endet in der /boot/config.txt!!

    .. bei mir eben leider NICHT; Raspi 4 mit bullseye ohne Monitor (headless).

    Aber Du hast uns den richtigen Tipp gegeben, wie wir das händisch anstellen können:


    Nach Defaultinstallation von bullseye fehlen die Einstellmöglichkeit der Auflösung (D1 Resolution).



    In /boot/config.txt stelle ich die Einträge scharf (# amZeilenanfang löschen) ...

    Code
    hdmi_force_hotplug=1
    
    hdmi_group=2
    hdmi_mode=85

    ... neu booten ... und ich erhalte plötzlich die Einstellmöglichkeit der Auflösung (D1 Resolution)!



    Und nun kann auch für VNC eine beliebige Auflösung eingestellt werden.


    Fazit: Option "D5 VNC Resolution for headless use" scheint (noch) nicht korrekt zu funktionieren, obiger workaround erzielt das gesuchte Ergebnis.